Вход | Регистрация
 

поле объекта не обнаружено

поле объекта не обнаружено
Я
   wowas
 
19.03.19 - 09:16
Выдает ошибку Поле объекта не обнаружена(Специализация). Если убрать строчки со специализацией на Разряд то же самое. что делать
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
        ВыборСотрудников.Параметры.УстановитьЗначениеПараметра("Специализация", Параметры.Специализация);
        ВыборСотрудников.Параметры.УстановитьЗначениеПараметра("Разряд", Параметры.Разряд);
        Специализация=Параметры.Специализация;
        Разряд=Параметры.Разряд;
        
            КонецПроцедуры
 
 
   Fram
 
1 - 19.03.19 - 09:18
Отладчик в зубы
   wowas
 
2 - 19.03.19 - 09:20
(1) ну и что толку. До этой строки все идет хорошо. Параметры находит верные. На этой строке все ломается. Ошибка написана выше
   azt-yur
 
3 - 19.03.19 - 09:20
(0) структура Параметры очевидно не установлена. Как форму открываете?
   wowas
 
4 - 19.03.19 - 09:21
(3) &НаКлиенте
Процедура Подбор(Команда)
        
    Для Каждого вЗнч Из Объект.Работы Цикл
          нСтр = Элементы.Работы.ТекущиеДАнные;
      КонецЦикла;
      
         ПараметрыПередачи = Новый Структура;
         СтруктураОтбора = Новый Структура;
         СтруктураОтбора.Вставить("Специализация",нСтр.Специализация);
          СтруктураОтбора.Вставить("Разряд",ВытащитьРазряд(нСтр.Наименование));
ПараметрыПередачи.Вставить("Отбор",СтруктураОтбора);
      
                   

      ОткрытьФорму("Справочник.Сотрудники.ФормаВыбора",ПараметрыПередачи, Элементы.Работы);
      
КонецПроцедуры
   azt-yur
 
5 - 19.03.19 - 09:26
(4) судя по этому, то вместо Параметры.Специализация надо Параметры.Отбор.Специализация
   Галахад
 
6 - 19.03.19 - 09:30
ПараметрыПередачи = Новый Структура;
         СтруктураОтбора = Новый Структура;
Заполняется одна переменная, а передается другая.
   wowas
 
7 - 19.03.19 - 09:38
(5) от души

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует