Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Создание внешнего отчета

Создание внешнего отчета
Я
   rapashocker
 
18.03.19 - 13:14
Привет, всем, пытаюсь вывести внешний отчет, но не выводит ничего, подскажите в чем проблема.
 
 
   rapashocker
 
1 - 18.03.19 - 13:14
&НаКлиенте
Процедура НайтиДокумент(Команда)
ПоискДокумента();    
КонецПроцедуры


&НаСервере
Функция ПоискДокумента() 
//Получить Макет

ЭтотОбъект=РеквизитФормыВзначение("Объект");
Макет=ЭтотОбъект.ПолучитьМакет("Макет");
ТабДок=Новый ТабличныйДокумент;
ОбластьМакета=Макет.ПолучитьОбласть("Шапка");
ТабДок.Вывести(ОбластьМакета);
ОбластьМакета=Макет.ПолучитьОбласть("ШапкаТаблицы");
ТабДок.Вывести(ОбластьМакета);
ОбластьМакета=Макет.ПолучитьОбласть("Данные");
ТабДок.Вывести(ОбластьМакета);
    
    


Запрос=Новый Запрос;
Запрос.Текст="ВЫБРАТЬ
             |    КОЛИЧЕСТВО(РАЗЛИЧНЫЕ ЭлектронныйДокументВходящий.Ссылка) КАК Количество
             |ИЗ
             |    (ВЫБРАТЬ
             |        ЭлектронныйДокументВходящий.Ссылка КАК Ссылка
             |    ИЗ
             |        Документ.ЭлектронныйДокументВходящий КАК ЭлектронныйДокументВходящий) КАК ВложенныйЗапрос
             |        ЛЕВОЕ СОЕДИНЕНИЕ Документ.ЭлектронныйДокументВходящий КАК ЭлектронныйДокументВходящий
             |        ПО ВложенныйЗапрос.Ссылка.Ссылка = ЭлектронныйДокументВходящий.Ссылка
             |
             |СГРУППИРОВАТЬ ПО
             |    ВложенныйЗапрос.Ссылка
             |ИТОГИ
             |    СУММА(Количество)
             |ПО
             |    ОБЩИЕ";



//Запрос.УстановитьПараметр("НачалоПериода",Месяц(ТекущаяДата()));

//Запрос.УстановитьПараметр("КонецПериода",Месяц(ТекущаяДата()-6));
Результат=Запрос.Выполнить().Выбрать();

Пока Результат.Следующий() Цикл
ОбластьМакета.Параметры.Тип=Результат.Ссылка;
ОбластьМакета.Параметры.Количество=Результат.Количество;
ТабДок.Вывести(ОбластьМакета);
КонецЦикла;
Возврат ТабДок;
КонецФункции
   Garykom
 
2 - 18.03.19 - 13:19
ТабДок формируешь на сервере и передаешь на клиента, как у тебя правильно сделано через Возврат ТабДок;


&НаКлиенте
Процедура НайтиДокумент(Команда)
   ОтчетТабДок = ПоискДокумента();
   ОтчетТабДок.Показать();
КонецПроцедуры
   rapashocker
 
3 - 18.03.19 - 13:26
Что то все равно ничего не показывает
   Вася Теркин
 
4 - 18.03.19 - 13:30
(3) А зачем тебе в таблице первая строка пустая?
   rapashocker
 
5 - 18.03.19 - 14:55
Не понимаю о чем идет речь? Пояснение пожалуйста.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует