Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Ошибка COM соединения

Ошибка COM соединения
Я
   progaoff
 
12.02.19 - 14:12
Если ВыборкаУТ.ИмяДокумента = "РеализацияТоваровУслуг" Тогда
            ОбработатьРеализацияТоваровУслуг(ВыборкаУТ.Ссылка);
        ИначеЕсли ВыборкаУТ.ИмяДокумента = "СчетФактураВыданный" Тогда
            ОбработатьСчетФактураВыданный(ВыборкаУТ.Ссылка);
        ИначеЕсли ВыборкаУТ.ИмяДокумента = "ВозвратТоваровОтКлиента" Тогда
            ОбработатьВозвратТоваровОтКлиента(ВыборкаУТ.Ссылка);
        ИначеЕсли ВыборкаУТ.ИмяДокумента = "СписаниеБезналичныхДенежныхСредств" Тогда
            ОбработатьСписаниеБезналичныхДенежныхСредств(ВыборкаУТ.Ссылка);
        ИначеЕсли ВыборкаУТ.ИмяДокумента = "ПоступлениеБезналичныхДенежныхСредств" Тогда
            ОбработатьПоступлениеБезналичныхДенежныхСредств(ВыборкаУТ.Ссылка);
        ИначеЕсли ВыборкаУТ.ИмяДокумента = "ПриходныйКассовыйОрдер" Тогда
            ОбработатьПриходныйКассовыйОрдер(ВыборкаУТ.Ссылка);    
        ИначеЕсли ВыборкаУТ.ИмяДокумента = "РасходныйКассовыйОрдер" Тогда
            ОбработатьРасходныйКассовыйОрдер(ВыборкаУТ.Ссылка);    
        ИначеЕсли ВыборкаУТ.ИмяДокумента = "ПоступлениеТоваровУслуг" Тогда
            ОбработатьПоступлениеТоваровУслуг(ВыборкаУТ.Ссылка);
        ИначеЕсли ВыборкаУТ.ИмяДокумента = "ПередачаТоваровМеждуОрганизациями" Тогда
            ОбработатьПередачаТоваровМеждуОрганизациямиКакПоступление(ВыборкаУТ.Ссылка);    
        ИначеЕсли ВыборкаУТ.ИмяДокумента = "ПередачаТоваровМеждуОрганизациямиРТУ" Тогда
            ОбработатьПередачаТоваровМеждуОрганизациямиКакРеализация(ВыборкаУТ.Ссылка);    
        КонецЕсли;


Добрый день знатоки. Есть такой код, при выполнении условия делаем com соединение, ЗапросУТ = УТ.NewObject("Запрос");
На что мне говорят Значение не является значением объектного типа (NewObject)
До этого по ком соединению все идет, но после перехода в одну из процедур, теряется. Что может быть??
 
 
   progaoff
 
1 - 12.02.19 - 14:15
Почему теряется COM соединение?
   ДенисЧ
 
2 - 12.02.19 - 14:22
В какую из процедур? Где всё это работает? клиент, сервер?
   progaoff
 
3 - 12.02.19 - 14:23
(2) Да клиент сервер. Запрос по COM проходит в первой нормально. как входим сюда Если ВыборкаУТ.ИмяДокумента = "РеализацияТоваровУслуг" Тогда
            ОбработатьРеализацияТоваровУслуг(ВыборкаУТ.Ссылка);
Все отваливается
   progaoff
 
4 - 12.02.19 - 14:23
Функция ПодключитьсяКИБ()
    
    _Параметры = Новый Структура;
    _Параметры.Вставить("ВариантРаботыИнформационнойБазы",1)//Сервер

    _Параметры.Вставить("ИмяСервера1СПредприятия",Сервер1С);
    _Параметры.Вставить("ИмяИнформационнойБазыНаСервере1СПредприятия",База1С);
    _Параметры.Вставить("АутентификацияОперационнойСистемы",Ложь);
    _Параметры.Вставить("ИмяПользователя",Пользователь);
    _Параметры.Вставить("ПарольПользователя",Пароль);
    
    СообщениеОбОшибке = "";
    УТ = ОбщегоНазначенияКлиентСервер.УстановитьВнешнееСоединение(_Параметры,СообщениеОбОшибке);
    ЕСли УТ = Неопределено Тогда
        Сообщить(СообщениеОбОшибке);
        Возврат Ложь;
    КонецЕсли;
    
    Возврат Истина;
    
КонецФункции


Соединение с базой
   ZDenis
 
5 - 12.02.19 - 14:34
УТ - это глобальная переменная?
   ДенисЧ
 
6 - 12.02.19 - 14:36
С клиента на сервер как бы ком-объекты не передаются...
   progaoff
 
7 - 12.02.19 - 14:37
(5) Да
   progaoff
 
8 - 12.02.19 - 14:37
(6) Ну в предыдущей процедуре они передаются и я вижу что это сом
   ZDenis
 
9 - 12.02.19 - 15:04
(8) В какой предыдущей? У тебя несколько огрызков тут представлено. Где что создается не понятно, где пытаешься ты сделать
ЗапросУТ = УТ.NewObject("Запрос")
тоже не понятно.
   lodger
 
10 - 12.02.19 - 15:11
(4) это на клиенте?
(3)  а это на сервере?
 
 Рекламное место пустует
   ZDenis
 
11 - 12.02.19 - 15:13
(10) тогда ответ в (6)

Список тем форума
Рекламное место пустует  Рекламное место пустует
Прочитай, хотя бы, Митичкина "Разработка в системе 1С:Предприятие 8". Волшебник
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует