Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Открыть внешнюю обработку

Открыть внешнюю обработку
Я
   ParamPamPam
 
01.02.19 - 10:58
В форме документа разместил кнопку "ЗаполнитьПоПриемке" и написал в её процедуре:

Обработка в Сервис-Дополнительные отчеты и обработки - обработки заполнения табличных частей - Заполнить поступление товаров по приемке

&НаКлиенте
Процедура ЗаполнитьПоПриёмке(Команда)
    ОткрытьФорму("Справочник.ВнешниеОбработки.ЗаполнитьПоступлениеТоваровПоПриемке.Форма");
КонецПроцедуры



Ругается:
{Документ.ПоступлениеТоваровУслуг.Форма.ФормаДокументаУправляемая.Форма(1821)}: Ошибка при вызове метода контекста (ОткрытьФорму)
    ОткрытьФорму("Справочник.ВнешниеОбработки.ЗаполнитьПоступлениеТоваровПоПриемке.Форма");
по причине:
Неизвестное имя формы. Имя: "Справочник.ВнешниеОбработки.ЗаполнитьПоступлениеТоваровПоПриемке.Форма"

Как к неё обратится?
 
 
   ParamPamPam
 
1 - 01.02.19 - 11:02
ОткрытьФорму("Справочник.ВнешниеОбработки.Заполнить поступление товаров по приемке.Форма");
Тоже ругается. Как имя узнать?
   Гипервизор
 
2 - 01.02.19 - 11:06
Нужен объект обработки, что-то вроде того:

ИмяФайла = КаталогВременныхФайлов() + "PrnForm.tmp";
Объект = Ссылка.ПолучитьОбъект();
ДвоичныеДанные = Объект.ХранилищеВнешнейОбработки.Получить();
ДвоичныеДанные.Записать(ИмяФайла);
ОбработкаОбъект = ВнешниеОбработки.Создать(ИмяФайла);

Где Ссылка - это ссылка на обработку из справочника ВнешниеОбработки.
   Sergz66
 
3 - 01.02.19 - 11:12
   Радим1987
 
4 - 01.02.19 - 11:32
Справочник.ВнешниеОбработки???
   ParamPamPam
 
5 - 01.02.19 - 11:37
Я на стажировке программиста 1С и дают самые разные задания.
Сейчас перевожу в обычную форму документа ПоступлениеТоваровУслуг в управляемую и необходимо по кнопке открыть внешнюю обработку с заполнением таб части Товары

Стоп, что то я ещё больше запутался. Ссылка это адрес обработки? "Справочник.ВнешниеОбработки.ЗаполнитьПоступлениеТоваровПоПриемке.Форма" ?
   Радим1987
 
6 - 01.02.19 - 12:00
//МодульОбработки

Функция СведенияОВнешнейОбработке() Экспорт

    ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке("0.0.0.1");
    ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиЗаполнениеОбъекта();
    ПараметрыРегистрации.Версия = "0.1";
    ПараметрыРегистрации.Назначение.Добавить("Документ.ПоступлениеТоваровУслуг");
    ПараметрыРегистрации.Наименование = "ЗаполнениеТЧ";
    ПараметрыРегистрации.БезопасныйРежим = Ложь;
    
    НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
    НоваяКоманда.Представление = "Заполнение ТЧ";
    НоваяКоманда.Идентификатор = "ЗаполнениеТЧ";
    НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыОткрытиеФормы();
    НоваяКоманда.ПоказыватьОповещение = Истина; 

    Возврат ПараметрыРегистрации;
    
КонецФункции 

//МодульФормы


&НаКлиенте
Процедура ВыполнитьКоманду(ИдентификаторКоманды, ОбъектыНазначенияМассив) Экспорт
    
    ТЧ = ВладелецФормы.Объект.Товары;
    НоваяСтрока = ТЧ.Добавить();    
    НоваяСтрока.ЧтоТо = "ЧтоТО";
    
КонецПроцедуры

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует