Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Передать массив с клиента на сервер

Передать массив с клиента на сервер
Я
   ParamPamPam
 
30.01.19 - 12:18
На клиенте в таблице значений получаю массив ссылок:


МассивСсылок=Новый Массив;    
Для Каждого Строка Из НайденныеСтроки Цикл
МассивСсылок.Добавить(Строка.Ссылка);
КонецЦикла;



Затем необходимо использовать его на сервере в качестве параметра запроса:


ЗапросПоТоварам = Новый Запрос;

ЗапросПоТоварам.Текст =
"ВЫБРАТЬ
|    ЗаказПоставщикуТовары.Ссылка,
|    ЗаказПоставщикуТовары.НомерСтроки,
|    ЗаказПоставщикуТовары.ЕдиницаИзмерения,
|    ЗаказПоставщикуТовары.ЕдиницаИзмеренияМест,
|    ЗаказПоставщикуТовары.Заказ,
|    ЗаказПоставщикуТовары.Количество,
|    ЗаказПоставщикуТовары.КоличествоМест,
|    ЗаказПоставщикуТовары.Коэффициент,
|    ЗаказПоставщикуТовары.Номенклатура,
|    ЗаказПоставщикуТовары.ПлановаяСебестоимость,
|    ЗаказПоставщикуТовары.СтавкаНДС,
|    ЗаказПоставщикуТовары.Сумма,
|    ЗаказПоставщикуТовары.СуммаНДС,
|    ЗаказПоставщикуТовары.ХарактеристикаНоменклатуры,
|    ЗаказПоставщикуТовары.Цена,
|    ЗаказПоставщикуТовары.Спецификация
|ИЗ
|    Документ.ЗаказПоставщику.Товары КАК ЗаказПоставщикуТовары
|ГДЕ
|    ЗаказПоставщикуТовары.Ссылка В(&МассивСсылок)";

ЗапросПоТоварам.УстановитьПараметр("МассивСсылок", МассивСсылок);

Элементы.Товары = ЗапросПоТоварам.Выполнить().Выгрузить();



И после этого результат запроса выгрузить во 2 таблицу.
Как передать массив с клиента на сервер?
 
 
   Мыш
 
1 - 30.01.19 - 12:21
(0) Процедура НаСервереКоторая(МассивСсылок)
   Aggressor
 
2 - 30.01.19 - 12:22
&НаКлиенте
Процедура КлиентскаяПроцедура()
Массив = Новый Массив;
//Как то его заполнили.

СервернаяПроцедура(Массив);
КонецПроцедуры

&НаСервере
Процедура СервернаяПроцедура(НашМассив)
//Параметр НашМассив это тот же массив, что и на клиенте 


КонецПроцедуры
   ParamPamPam
 
3 - 30.01.19 - 14:37
Спасибо!

Список тем форума
Рекламное место пустует  Рекламное место пустует
Пользователь не знает, чего он хочет, пока не увидит то, что он получил.
Э. Йодан
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует