Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

БП 3,0 заполнить по инн

БП 3,0 заполнить по инн
Я
   lite777
 
29.01.19 - 09:14
Добрый день, БП 3,0 в справочнике контрагенты есть кнопка -ЗАПОЛНИТЬ ПО ИНН--ЗаполнитьРеквизитыПоИНН(Команда), хочу пройтись программно по контрагентам ,вопрос как обратиться к команде формы элемента-ЗаполнитьРеквизитыПоИНН(Команда)  ,код такой-    контр=Справочники.Контрагенты.Выбрать() ;

    Пока контр.Следующий() Цикл
        
         Если контр.ЭтоГруппа=Истина Тогда Продолжить ; КонецЕсли  ;
        
         Если конт.ИНН<>неопределено или контр.инн<>"" Тогда
               об=Контр.ПолучитьОбъект() ;
               ф=об.ПолучитьФорму("ФормаЭлемента");
              
               ЗаполнитьРеквизитыПоИНН(Команда)   //команда модуля формы элемента
            
         КонецЕсли ;    
            
    КонецЦикла ;
 
 
   unregistered
 
1 - 29.01.19 - 09:23
(0) Не надо этого делать. Бухи тебя потом проклянут за косяки. Будешь крайним, когда на каком-нибудь счете-фактуре с парой миллионов НДС неверный адрес распечатается или КПП.
   lite777
 
2 - 29.01.19 - 09:27
мы изначально заполняли по кнопке, просто названия контрагентов слетают при обмене через xml c 1c-Далион,(наименование-наименов полн),
   unregistered
 
3 - 29.01.19 - 09:43
(2) Ну так устраняйте проблему (правьте правила, вводите корректные названия в Далионе,...), а не изобретайте костыль.
Что-то не так заполнится автоматом - прилетит тебе.
   unregistered
 
4 - 29.01.19 - 09:43
Общий модуль РаботаСКонтрагентами

Функция РеквизитыЮридическогоЛицаПоИНН(Знач ИНН) Экспорт
// Возвращают реквизиты юридического лица по данным ЕГРЮЛ (наименование, адрес, коды и т.д.).

//
// Параметры:

//    ИНН - Строка - ИНН юридического лица, реквизиты которого надо получить.
//

// Возвращаемое значение:
//    Структура - реквизиты юридического лица.

//        * ИНН - Строка - ИНН юридического лица.
//        * КПП - Строка - КПП юридического лица.

//        * Наименование - Строка - представление юридического лица в учетной программе.
//        * НаименованиеПолное - Строка - полное наименование юридического лица.

//        * НаименованиеСокращенное - Строка - сокращенное наименование юридического лица.
//        * РегистрационныйНомер - Строка - ОГРН юридического лица.

//        * ПравоваяФорма - Строка, Неопределено - правовая форма юридического лица.
//        * ЮридическийАдрес - Структура, Неопределено - данные о юридическом адресе.

//            ** КонтактнаяИнформация - Строка - данные в формате XML.
//            ** Представление - Строка - представление адреса.

//            ** Комментарий - Строка - произвольный комментарий.
//            ** Корректный - Булево - адрес является корректным по данным ФИАС;

//        * Телефон - Структура, Неопределено - данные о телефоне.
//            ** КонтактнаяИнформация - Строка - данные в формате XML.

//            ** Представление - Строка - представление телефона.
//            ** Комментарий - Строка - произвольный комментарий.

//        * Руководитель - Структура, Неопределено - данные о руководителе.
//            ** Должность - Строка - должность руководителя.

//            ** Фамилия - Строка - фамилия руководителя.
//            ** Имя - Строка - имя руководителя.

//            ** Отчество - Строка - отчество руководителя.
//            ** Представление - Строка - ФИО руководителя.

//            ** ИНН - Строка - ИНН руководителя.
//            ** ДатаЗаписи - Дата - дата записи о руководителе.

//        * РегистрацияВНалоговомОргане - Структура, Неопределено - данные о регистрации в ИФНС.
//            ** Код - Строка - код налогового органа.

//            ** Наименование - Строка - наименование налогового органа.
//            ** ОКТМО - Строка - код ОКТМО налогового органа.

//            ** ОКАТО - Строка - код ОКАТО налогового органа.
//            ** ДатаРегистрации - Дата - дата постановки на учет в налоговом органе.

//        * ДатаРегистрации - Дата - дата регистрации юридического лица.
//        * РегистрацияВПенсионномФонде - Структура, Неопределено - данные о регистрации в ПФР.

//            ** РегистрационныйНомерПФР - Строка - регистрационный номер юридического лица в ПФР.
//            ** КодОрганаПФР - Строка - код органа ПФР.

//            ** НаименованиеОрганаПФР - Строка - наименование органа ПФР.
//            ** ДатаРегистрации - Дата - дата постановки на учет в ПФР.

//        * РегистрацияВФСС - Структура, Неопределено - данные о регистрации в ФСС.
//            ** РегистрационныйНомерФСС - Строка - регистрационный номер юридического лица в ФСС.

//            ** КодПодчиненности - Строка - код подчиненности органа ФСС.
//            ** КодОрганаФСС - Строка - код органа ФСС.

//            ** НаименованиеОрганаФСС - Строка - наименование органа ФСС.
//            ** ДатаРегистрации - Дата - дата постановки на учет в ФСС.

//        * КодОКВЭД - Строка - основной код по классификатору ОКВЭД.
//        * ЭтоОКВЭД2 - Булево - основной код приведен по классификатору редакции 2 или редакции 1.

//        * ИсторияРеквизитов - Структура - история изменения реквизитов юридического лица.
//            ** КПП - ТаблицаЗначений - история изменения значения реквизита КПП;

//                Колонки:
//                *** Дата - Дата - дата изменения КПП;

//                *** Значение - Строка - значение реквизита КПП;
//            ** Наименование - ТаблицаЗначений - история изменения наименования;

//                Колонки:
//                *** Дата - Дата - дата изменения наименования;

//                *** НаименованиеПолное - Строка - полное наименование юридического лица;
//                *** НаименованиеСокращенное - Строка - сокращенное наименование юридического лица;

//            ** Адрес - ТаблицаЗначений - история изменения адреса;
//                Колонки:

//                *** Дата - Дата - дата изменения адреса;
//                *** КонтактнаяИнформация - Строка - данные в формате XML;

//                *** Представление - Строка - представление адреса;
//                *** Комментарий - Строка - произвольный комментарий;

//            ** Статус - ТаблицаЗначений - история изменения статуса;
//                Колонки:

//                *** Дата - Дата - дата изменения наименования;
//                *** Код - Строка - код статуса;

//                *** Наименование - Строка - наименование статуса;
//            ** РеквизитыДиректора - ТаблицаЗначений - история изменения реквизитов директора;

//                Колонки:
//                *** Дата - Дата - дата изменения реквизитов директора;

//                *** ДатаОкончания - Дата - дата окончания действия реквизитов.
//                    Пустая дата, если директор действующий;

//                *** ИНН - Строка - ИНН;
//                *** Фамилия - Строка - фамилия директора;

//                *** Имя - Строка - имя;
//                *** Отчество - Строка - отчество;

//                *** ВидДолжности - Строка - вид должности;
//                *** НаименованиеДолжности - Строка - наименование должности;

//        * ОписаниеОшибки - Строка - описание возникшей ошибки.
//            Для обработки ошибки на клиентской части необходимо использовать метод

//            РаботаСКонтрагентамиКлиент.ОбработатьОшибку.
//
   lite777
 
5 - 29.01.19 - 09:59
попробую
   d4rkmesa
 
6 - 29.01.19 - 10:00
(0) Заполнить по ИНН работает через 1С Контрагент, а это, если я не ошибаюсь, 7200 обращений в год. Т.е. буквально за один раз можно выработать годовой лимит. Безлимитный стоит 3500 в месяц - не так уж мало. Поэтому, никого слушать не надо, пока счет на 42000 рублей не будет оплачен.
   lite777
 
7 - 29.01.19 - 10:08
да вопрос
   spiller26
 
8 - 29.01.19 - 10:21
(6) Как раз прибавить ещё обращения, которые при отладке будут тоже.
Вопрос зачем тебе это? Контроль осуществляют бухи или манагеры.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует