Вход | Регистрация
 

Проблема с авторизацией при обмене с Битрикс 24.

Проблема с авторизацией при обмене с Битрикс 24.
Я
   Nyarlathotep
 
28.01.19 - 11:18
Всем привет!

Делаю обмен с Битрикс 24. Делаю как написано тут - http://catalog.mista.ru/public/574117/. Остановился вот в этом месте


// если нас переадрессовали
    Если Ответ.КодСостояния = 302 Тогда
        
        //в Location взять code
        
        Параметры = ПолучитьПараметрыИзGetСтроки(Ответ.Заголовки.Получить("Location"));
        Cookie = Ответ.Заголовки.Получить("Set-Cookie");
        Код = Неопределено;
        
        
        Если Параметры.Свойство("code", Код) Тогда
            
            // используя Код получаем access_token и refresh_token
            
            Соединение = Новый HTTPСоединение(
                            "oauth.bitrix.info",
                            , // порт
                            , // пользователь
                            , // пароль
                            , // прокси
                            5, // таймаут в секундах
                            ssl // защищенное HTTPS соединение
                        );
                        
            Запрос.АдресРесурса    = "oauth/token" + ПараметрыАвторизацииВСтроке(Код);    
            Запрос.Заголовки.Вставить("Cookie", Cookie);
            
            
            Ответ = Соединение.Получить(Запрос);
            
            
            Если Ответ.КодСостояния <> 200 Тогда
                
                ВызватьИсключение "Ошибка при получении access_token";
                
            Иначе
                
                // разобрать полученный json
                json = Ответ.ПолучитьТелоКакСтроку();
                
                
                Чтение = Новый ЧтениеJSON;
                Чтение.УстановитьСтроку(json);
                ОтветСтруктура = ПрочитатьJSON(Чтение);
                
                // сохраняю параметры подключения
                AccessToken  = ОтветСтруктура.access_token;
                RefreshToken = ОтветСтруктура.refresh_token;
                RefreshTime  = ТекущаяДата() + ОтветСтруктура.expires_in;
                
            
            КонецЕсли;
            
            
            
        Иначе
            
            ВызватьИсключение "Ошибка при подключении, нет параметра code";
            
        КонецЕсли;
        
        
    КонецЕсли;


Битрикс меня переадресовывает на свой сервис OAuth, все хорошо, строкой

Запрос.АдресРесурса    = "oauth/token" + ПараметрыАвторизацииВСтроке(Код);

шлю ему запрос вот такого вида oauth/token/?grant_type=authorization_code&client_id=МойКлиентИД&client_secret=МойКлиентСекрет&code=МойКод.

Тоже все верно, как написано тут https://dev.1c-bitrix.ru/learning/course/index.php?COURSE_ID=99&LESSON_ID=2486.

Но в ответ на этот запрос, после разбора json, всегда получаю ответом от Битрикса ошибку - "wrong_rlient". Что делаю не так? Все по инструкциям вроде.
 
 
   Nyarlathotep
 
1 - 28.01.19 - 11:19
(0) Ошибка - "wrong_client", а не "wrong_rlient".

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует