Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Не работает отладка серверных процедур в одной из баз на сервере приложений.

Не работает отладка серверных процедур в одной из баз на сервере приложений.
Я
   vcv
 
26.01.19 - 21:40
Есть сервер приложений, на нем несколько практически одинаковых баз, рабочая и копии разработчиков. В одной из копий не работает отладка серверных процедур, в остальных базах нормально.

Сервер приложений перезапускал.
Базу из сервера приложений удалял и добавлял снова.
Базу из списка баз стартера удалял и добавлял снова.
Восстановить эту копию из SQL бэкапа рабочей базы пробовал.
На другом сервере добавить проблемную базу пробовал.
Ничего не помогло.

Где стоит ещё покопать?
 
 
   palsergeich
 
1 - 26.01.19 - 21:43
   lubitelxml
 
2 - 26.01.19 - 21:43
http://www.screencast.com/t/sgUTt3UR - эти галки стоят?
   palsergeich
 
3 - 26.01.19 - 21:43
И кеш на сервере почисти. Все проблемы с отладкой которые я видел это или кеш или закрытые порты
   palsergeich
 
4 - 26.01.19 - 21:44
(2) Эти галки на отладку на клиенте влияют
   palsergeich
 
5 - 26.01.19 - 21:46
https://yadi.sk/i/_h7ih4MQQSBFmw попробуй рука поставить еще.
Важно что бы 2я ссылка из (1) показывала корректный адрес
   timurhv
 
6 - 26.01.19 - 21:50
(0) В крайней тоже такую проблему заметил. В конфигураторе отключаю отладку от сеанса и подрубаю заново - сразу пашет.
   vcv
 
7 - 26.01.19 - 22:25
(1) В параметрах отладки стоит "Отладка по протоколу TCP/IP". Как и на всех других базах. В "Предметах отладки" видит и клиента и сервер, подключается нормально. Выглядит окно так же, как и на других базах, где отладка работает нормально.
(2) Не стоят. На других базах тоже не стоят. Попробовал поставить - не помогает.
(3) Базу на сервер приложений удалял и добавлял снова. Надеюсь это почистило кэши, касающиеся её. Глобально кэши сервера приложений не чистил - ещё надо время найти, пользователей выгонять.
(5) Предметы отладки видит. Окно с предметами отладки выглядит так же, как и на других базах.
(6) О! Похоже близко от проблемы. Если запустить базу из конфигуратора в режиме отладки, потом отключиться от сервера в предметах отладки и подключиться снова, отладка начинает работать. В этом запуске. Снова запускаешь отладку - и опять приходится переподключаться в серверу.

Значит вопрос перефразируется так: какого чёрта неправильно отладка подключается к серверу и куда попробовать потыкать пальцами, что бы она подключалась сразу сама правильно, не требуя ручного отключить/подключить в предметах отладки?

Вопрос больше теоретический. Что бы самому понимать, если что куда лезть. Это сейчас база всего лишь одна из нескольких разработческих баз, с большой вероятностью проблема исчезнет, если её совсем убить и сделать новую с ДРУГИМ ИМЕНЕМ. Но понять-то хочется.
   Lama12
 
8 - 26.01.19 - 23:21
(7) В конфигураторе, в подключении. Отключить отладку на сервере, подключить отладку на сервере. Должно работать.
Есть такой глюк начиная с 8.3.10
   vcv
 
9 - 27.01.19 - 00:44
Ну если глюк, тогда будем ждать, когда решат. Неприятно, но некритично переподключаться к серверу, что бы отладка заработала.
Спасибо всем за советы.
   timurhv
 
10 - 27.01.19 - 13:52
(9) Подытожим: версия 8.3.13.1690?
 
 Рекламное место пустует
   Cyberhawk
 
11 - 27.01.19 - 13:56
Переходи на хттп-отладку
   vcv
 
12 - 27.01.19 - 20:00
(10) Нет. 8.3.13.1513
Переход на другую версию несколько затруднён, потому что придётся устанавливать клиента на N компах в нескольких городах без домена и админских прав у пользователей. Не ради такого некритичного глючка.
   TormozIT
 
13 - 27.01.19 - 23:22
Если расширения есть в базе, то попробуй отключить.
   TormozIT
 
14 - 27.01.19 - 23:23
Не работает во всех модулях или только в некоторых? Если да, то в каких?
   АнализДанных
 
15 - 28.01.19 - 00:50
(0) У меня была проблема с отладкой фоновых заданий из-за того, что строка подключения для запуска конфигуратора не совпадала со строкой подключения фонового задания. Здесь подробно об этом написано:
http://professia1c.ru/reglamentnyie-zadaniya/otladka-fonovyih-zadaniy/
   dmpl
 
16 - 28.01.19 - 08:19
(7) Включи отладку HTTP - возможностей больше, неочевидных проблем меньше.
   vcv
 
17 - 28.01.19 - 08:59
(13) Пробовал. Вроде заработала отладка с отключенными расширениями, при следующем запуске опять не работает. Мутный глюк.
(14) Пробовал модули формы документов.
(16) Не хочется ради такой мелочи. Был негативный опыт с неочевидными проблемами в работе 1С, связанными с веб-сервером.
   Мыш
 
18 - 28.01.19 - 09:00
(17) Для отладки по хттп не нужен веб-сервер.
   TormozIT
 
19 - 28.01.19 - 09:13
хттп отладка имеет недостатки. Появляются всякие задержки при отображении значений, а иногда они вообще не вычисляются/отображаются.
   TormozIT
 
20 - 28.01.19 - 09:13
(15) Исправили еще в 8.3.8 это
   TormozIT
 
21 - 28.01.19 - 09:14
(16) Возможностей больше, но и глюков больше.
   dmpl
 
22 - 28.01.19 - 10:38
(19) По сравнению с полным отсутствием отладки из-за того, что где-то заблокировалось входящее соединение это цветочки.

(21) А выбора-то нет - автоматическое подключение фильтровать надо, а то возникает ад.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует