Вход | Регистрация
 

Программно заполнить КИ.

Программно заполнить КИ.
Я
   OldCondom
 
25.01.19 - 14:07
УТ 11.2, БСП 3.0.1
Кажется у меня больше не осталось идей.
Заполнять уже и руками табличную часть и старался разными способами через БСП.
Вот из последнего:
[1c]    ВидКИ = Справочники.ВидыКонтактнойИнформации.ФактАдресОрганизации;
    ТипКИ = ВидКИ.Тип;
    Представление = "РОССИЯ, таккк, новая инфа СПБ ПЛАНЕРНАЯ";
    Результат =     УправлениеКонтактнойИнформацией.КонтактнаяИнформацияПоПредставлению(представление, ВидКИ);
    УправлениеКонтактнойИнформацией.ДобавитьКонтактнуюИнформацию(Партнер, Результат, ВидКИ)[/1c]

Не хочет и все тут. При открытии справочника на вкладке КИ пусто. А вот запрос выдает все ок.

Необходимо в произвольном формате выводить просто строку адреса.
 
 
   OldCondom
 
1 - 25.01.19 - 14:07
ой, ут 11.4
   OldCondom
 
2 - 25.01.19 - 14:08
уже РОССИЯ с запятой ставил, может ему надо именно чтоб прям страна распознавалась, хз. Больше трех часов вожусь блин:(
   OldCondom
 
3 - 25.01.19 - 14:09
Справочники.ВидыКонтактнойИнформации.ФактАдресОрганизации - был и адресконтрагента. Не сработало
   toypaul
 
4 - 25.01.19 - 14:14
Нужен адрес в произвольном формате?
   OldCondom
 
5 - 25.01.19 - 14:16
(4)ДА!
   OldCondom
 
6 - 25.01.19 - 14:18
Но у меня и так в поле "значение" стоит
{
"value": "ул. красных тюленей 23",
"comment": "",
"type": "Адрес",
"country": "Россия",
"addressType": "ВСвободнойФорме",
"countryCode": "",
"ZIPcode": "",


Что ему еще надо, хз
   OldCondom
 
7 - 25.01.19 - 14:18
хм, а почему countryCode не заполнено..
   toypaul
 
8 - 25.01.19 - 14:22
БСП 3. упс. тогда не знаю. Для БСП 2 как раз небольшую статейку пишу.
   OldCondom
 
9 - 25.01.19 - 14:24
какая же ссанина эта БСП:(
   toypaul
 
10 - 25.01.19 - 14:31
в БПС 2 был метод в служебном СформироватьАдресПоПредставлению

может его попробовать?
 
 Рекламное место пустует
   Alexandr_U1982
 
11 - 25.01.19 - 14:31
Я вот так заполнял адрес в КИ

Для Каждого Строка Из ТаблицаКонтактнаяИнформация Цикл
    
    Тип = ПолучитьЗначениеПеречисления("ТипыКонтактнойИнформации", Строка.Тип);
    Если Не ЗначениеЗаполнено(Строка.Вид) Тогда
        Строка.Вид = ПолучитьВидКонтактнойИнформации();
    КонецЕсли;
    
    Представление = Строка.Представление;
    Представление = СтрЗаменить(Представление, "кв.", "квартира ");
    Представление = СтрЗаменить(Представление, "оф.", "офис ");
    ЗначенияПолей = УправлениеКонтактнойИнформацией.КонтактнаяИнформацияXMLПоПредставлению(Представление, Строка.Вид);
    СтруктураКИ   = УправлениеКонтактнойИнформацией.ПредыдущаяСтруктураКонтактнойИнформацииXML(ЗначенияПолей, Строка.Вид);

    Если Строка.ВключатьСтрануВПредставление Тогда
        Представление = СтруктураКИ.Страна + ", " + Представление;
    КонецЕсли;

    Значение      = УправлениеКонтактнойИнформацией.КонтактнаяИнформацияПоПредставлению(   Представление, Строка.Вид);
    ЗначенияПолей = УправлениеКонтактнойИнформацией.КонтактнаяИнформацияXMLПоПредставлению(Представление, Строка.Вид);
    
    НоваяСтрока = Объект.КонтактнаяИнформация.Добавить();
    НоваяСтрока.Тип           = Тип;
    НоваяСтрока.Вид           = Строка.Вид;
    НоваяСтрока.ВидДляСписка  = Строка.Вид;
    НоваяСтрока.Представление = Представление;
    НоваяСтрока.Значение      = Значение;
    НоваяСтрока.ЗначенияПолей = ЗначенияПолей;
    НоваяСтрока.Страна        = ?(СтруктураКИ.Свойство("Страна"), СтруктураКИ.Страна, "");
    НоваяСтрока.Регион        = ?(СтруктураКИ.Свойство("Регион"), СтруктураКИ.Регион, "");
    НоваяСтрока.Город         = ?(СтруктураКИ.Свойство("Город"),  СтруктураКИ.Город,  "");
    
КонецЕсли;
   toypaul
 
12 - 25.01.19 - 14:33
(11) мать моя женщина. в БСП 3 еще и Значение к ЗначенияПолей добавилось?
   Alexandr_U1982
 
13 - 25.01.19 - 14:36
(12)
ЗначенияПолей - КИ хранится в XML
Значение      - КИ хранится в JSON
   OldCondom
 
14 - 25.01.19 - 14:47
(11) не сработало. У меня кстати в "Значение" Не заполняет countryCode. Может в нем дело, что ли. Сейчас руками добавлю
   Alexandr_U1982
 
15 - 25.01.19 - 15:02
(14) Вот только что проверил.
В ЗУП КОРП 3.1.8.246 все работает (БСП 3.0.1.369).
   OldCondom
 
16 - 25.01.19 - 15:12
Момент, на типовой прогоню
   OldCondom
 
17 - 25.01.19 - 15:15
С******************КААААААААААААААААА!!!!!
Не работает только со справочником Партнеры. На контрагентах все отлично работает, даже это:
   ВидКИ = Справочники.ВидыКонтактнойИнформации.ФактАдресОрганизации;
    ТипКИ = ВидКИ.Тип;
     Результат =     УправлениеКонтактнойИнформацией.КонтактнаяИнформацияПоПредставлению("азазазазаза а", ВидКИ);
    УправлениеКонтактнойИнформацией.ДобавитьКонтактнуюИнформацию(Контр, Результат, ВидКИ)

   toypaul
 
18 - 25.01.19 - 15:28
дэк может надо 

Справочники.ВидыКонтактнойИнформации.АдресПартнера?

в нем только такой адрес предусмотрен. в БСП 2 по крайней мере
   OldCondom
 
19 - 25.01.19 - 15:36
(18) я ведь искал... Пипец глаза замылены уже. Столько времени вбухать. Спасибо, да, так и есть.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует