Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Комплексная автоматизация 2.4

Комплексная автоматизация 2.4
Я
   munchkin
 
24.01.19 - 15:43
Добрый день.
Задачка перенести функционал из измененной УТшки 10.3 в типовую КА 2.4 с помощью расширения.
Ситуация такая, начал разбираться с механизмом расширения 1С 8.3 последних релизов, требуется добавить "ФормаСпискаАукционов"(в котором есть условие изменения цвета строки при выборе определенного значения поля "СостояниеЗаказа" в этом списке) в модуль формы записал следующий Код:
Процедура ПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    Если ДанныеСтроки.СостояниеЗаказа = Перечисления.СостоянияЗаказов.ЗаявкаНаРассмотрении Тогда
        ОформлениеСтроки.ЦветФона = WebЦвета.СветлоЗеленый;
    ИначеЕсли ДанныеСтроки.СостояниеЗаказа = Перечисления.СостоянияЗаказов.ПодачаЗаявки Тогда
        ОформлениеСтроки.ЦветФона = WebЦвета.СветлоКоралловый;
    КонецЕсли;
    Если ДанныеСтроки.ТипЗаказа = Перечисления.ТипыЗаказов.Конкурент Тогда
        ОформлениеСтроки.ЦветТекста = WebЦвета.СветлоСерый;
    КонецЕсли;

Данную форму нужно добавить в документ "ЗаказКлиента" и сделать так, что бы она отображалась.
Второй момент это - добавить в ФормуДокумента этого самого ЗаказаКлиента новую страницу "Аукцион", содержащую определенные реквизиты, и сделать так, что бы она отображалась.
В конфигураторе добавлял реквизиты поля и формы в расширение по аналогии с УТ 10.3, но не понимаю в чем проблема, ни одно изменение в режиме пользователя не отображается. Страница "аукцион" на форме не отображается при добавлении.
Может кто пояснит в чем может быть проблема или может как решить задачу по другому.
 
 
   Shrike
 
1 - 24.01.19 - 16:54
Снять галки безопасный режим и защита от опасных действий в свойствах расширения
   Shrike
 
2 - 24.01.19 - 16:58
&Вместо("ПриВыводеСтроки")
Процедура Расш1_ПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
   munchkin
 
3 - 24.01.19 - 18:44
@Srike спасибо за подсказку. Появился еще один вопрос, я добавил страницу "Аукцион" на ФормуДокумента(ЗаказаКлиента) , добавил пару реквизитов с ссылкой на перечисления и пару с датами, но они при записи и проводке документа не записываются. Соответственно не отражаются в ФормеСпискаАукционов.
   palsergeich
 
4 - 24.01.19 - 21:19
(3) Модуль объекта - обработка проведения.
Движения формируются там.
   munchkin
 
5 - 25.01.19 - 11:28
(4) Я правда думал, о добавлении ОбработкиПроведения в модуле менеджера объекта. Только не знаю чем эту процедуру наполнить.
   munchkin
 
6 - 22.02.19 - 12:19
Примерно начал понимать, что бы реквизиты, добавленные в расширение, проводились, нужно добавить регистр накопления. Какие-то дополнительные обработки для данной задачи нужно писать? или все можно решить конфигурированием? Говоря обработки я имею ввиду ( ОбработкуПроведения в модуле объекта документ ЗаказКлиента и ОбработкуПолученияФормы в модуле менеджера объекта Заказа клиента)
   munchkin
 
7 - 27.02.19 - 15:23
Подскажет может кто, как обратиться к форме где необходимые мне реквизиты находятся, пробовал такое:

Процедура Расш1_ПриЗаписи(Отказ)
      ФормаТендер = ЭтотОбъект.ПолучитьФорму("ФормаДокумента");
      ДатаАукциона = ФормаТендер.ЭлементыФормы.Индекс("ДатаАукциона");
      ТипЗаказа = ФормаТендер.ЭлементыФормы.Индекс("ТипЗаказа");
      ДатаКонтракта = ФормаТендер.ЭлементыФормы.Индекс("ДатаКонтракта");
      СостояниеЗаказа = ФормаТендер.ЭлементыФормы.Индекс("СостояниеЗаказа");
КонецПроцедуры

Не работает. Писал этот метод в модуле документа.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует