Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

УФ, Новый ОписаниеОповещения, обработать результат открываемой формы.

УФ, Новый ОписаниеОповещения, обработать результат открываемой формы.
Я
   SkillUp
 
24.01.19 - 12:47
В документе ПоступлениеТоваров, при нажатии в подборе, открывается форма где укать надо количество шт., так вот, как в моем случае передать количествоШТ (открытой формы) в процедуру "ОбработатьРезультатФормы"? Если что-то не понятно, задавайте вопросы.

ОписаниеОповещ = Новый ОписаниеОповещения ("ОбработатьРезультатФормы",ЭтаФорма);
    ОткрытьФорму("Обработка.ПодборУФ.Форма.Форма",,,,,,ОписаниеОповещ);
    КонецЕсли;
    
КонецПроцедуры

&НаКлиенте
Процедура ОбработатьРезультатФормы (Результат, Параметры) Экспорт
    
  Как сюда передать результат формыц (Количество шт.)?        
КонецПроцедуры
 
 
   Вафель
 
1 - 24.01.19 - 12:48
в форме нужно делать
Закрыть(результат)
   SkillUp
 
2 - 24.01.19 - 12:48
(1) В самой форме, где указывают количество шт.?
   Василий Алибабаевич
 
3 - 24.01.19 - 12:55
(2) Йес.
   SkillUp
 
4 - 24.01.19 - 15:47
(3) Самое интересное ,что я нашел способ как передавать количество )))
   SkillUp
 
5 - 24.01.19 - 15:47
(3) И это все, в форме документа )
   Buster007
 
6 - 24.01.19 - 16:36
(5) похоже узнал о наличии ВвестиЗначение()?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует