Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

БП 3.0 Как программно включить режим учета больничных?

БП 3.0 Как программно включить режим учета больничных?
Я
   gp42
 
24.01.19 - 04:55
В настройках зарплаты не видно соответствующей галочки.
Численность сотрудников не превышает 60
Мне не понятно как снять ограничение.

Подскажите кто как победил?
 
 
   gp42
 
1 - 24.01.19 - 05:29
Вот что нашел
По регистрам сведений программа рассчитывает количество только работающих сотрудников. Необходимо проверить регистры сведений "Текущие кадровые данные" и "Кадровая история сотрудников" по этой организации. Удалить ошибочные записи. Найти регистры можно через команду "Все функции"

https://www.4dk.ru/1c/news/d/13013
   gp42
 
2 - 24.01.19 - 09:01
ну что как запрос на проверку количества устроенных сотрудников в конфигураторе найти?
Сразу станет понятно по какой организации ограничения действуют
   gp42
 
3 - 24.01.19 - 09:03
В моем случае всего 600 записей. Но не больше 30 сотрудников по каждой организации в отдельности по регистру "текущие кадровые данные".
   ДенисЧ
 
4 - 24.01.19 - 09:16
(2) Полуить это сообщение и поиском по конфигурации - не предлагать?
   gp42
 
5 - 24.01.19 - 17:30
Нашел функцию ПорогЗапрета()
изменил 60 на 600, т.е. условное ограничение количества сотрудников орг-ии поднял до 600

Теперь упираюсь в ПолучитьФункциональнуюОпцию("УчетЗарплатыИКадровСредствамиБухгалтерии") и ПолучитьФункциональнуюОпцию("РасчетЗарплатыДляНебольшихОрганизаций")

Как установить значение истина?
Перезапуск программы не помогает
   gp42
 
6 - 24.01.19 - 18:18
Сделал обработку в которой установил значения соответствующих констант примерно так:


&НаСервере
Процедура УстановитьКонстантыНаСервере()
    Если НЕ Константы.РасчетЗарплатыДляНебольшихОрганизаций.Получить() Тогда
        Сообщить("Устанавливаю РасчетЗарплатыДляНебольшихОрганизаций");
        Константы.РасчетЗарплатыДляНебольшихОрганизаций.Установить(Истина);
    КонецЕсли;
    Если НЕ Константы.УчетЗарплатыИКадровСредствамиБухгалтерии.Получить() Тогда
        Сообщить("Устанавливаю УчетЗарплатыИКадровСредствамиБухгалтерии");
        Константы.УчетЗарплатыИКадровСредствамиБухгалтерии.Установить(Истина);
    КонецЕсли;
    
КонецПроцедуры

&НаКлиенте
Процедура УстановитьКонстанты(Команда)
    УстановитьКонстантыНаСервере();
КонецПроцедуры


&НаСервере
Процедура ПриОткрытииНаСервере()
    Сообщить("УчетЗарплатыИКадровСредствамиБухгалтерии = "+Константы.УчетЗарплатыИКадровСредствамиБухгалтерии.Получить());
    Сообщить("РасчетЗарплатыДляНебольшихОрганизаций = "+Константы.РасчетЗарплатыДляНебольшихОрганизаций.Получить());
КонецПроцедуры


&НаКлиенте
Процедура ПриОткрытии(Отказ)
    ПриОткрытииНаСервере();
КонецПроцедуры

в общеммодуле РасчетЗарплатыДляНебольшихОрганизаций ищите Функция РасчетЗарплатыДляНебольшихОрганизацийВозможен() в ней есть всё.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует