Вход | Регистрация
 

Удалить строки из тч документа 8.3

[Волшебник, 23.01.19 - 09:11]
Удалить строки из тч документа 8.3
Я
   Обфускация
 
23.01.19 - 09:01
Подскажите, как это правильно сделать. Тупо строку удалить по условию не совсем правильно, там все хитрее как-то надо сделать, чтобы курсор не перескакивал.
 
 
   Fram
 
1 - 23.01.19 - 09:02
(0) а теперь сформулируй свой вопрос с примерами
   piter3
 
2 - 23.01.19 - 09:03
(1) пусть поиском уже пользуется
   Mankubus
 
3 - 23.01.19 - 09:03
(0) напиши цикл в котором обходишь строки начиная с последней
   Serg_1960
 
4 - 23.01.19 - 09:07
Вероятно автор уже научился удалять, - ему сейчас нужно "чтобы курсор не перескакивал"(цы) :)
   Волшебник
 
5 - 23.01.19 - 09:11
(4) "Научилась"
   Обфускация
 
6 - 23.01.19 - 09:14
вот если это по всем документам прогнать, то будет работать? В групповой обработке реквизитов запускаю. На одном сработало.

    МасСтрок = Новый Массив;
    
    Для каждого Строка из объект.товары Цикл
        Если Строка.сумма=0 Тогда
            МасСтрок.Добавить(Строка);
        КонецЕсли;
    КонецЦикла;
            
    Для каждого Строка из МасСтрок Цикл
        объект.товары.Удалить(Строка);
    КонецЦикла;
объект.записать()
   ДенисЧ
 
7 - 23.01.19 - 09:15
(6) А как связан твой код и "чтобы курсор не перескакивал" ?
   Serg_1960
 
8 - 23.01.19 - 09:16
(5) Оу. Мои извинения и соболезнования.

Моя плохо говорить по русская. Как сказать "автор" в женском роде? И ещё: как будет "бестолочь" в женском роде?
   Обфускация
 
9 - 23.01.19 - 09:20
(7)
ну это новый, улучшенный код, чем вначале был
   Serg_1960
 
10 - 23.01.19 - 09:22
(7) Эээ... чисто формально говоря, в некоторых языках "курсор" = "итератор" = "указатель".
   Ordnung
 
11 - 23.01.19 - 09:22
(8) Согласно новым феминистическим трендам - "авторка" :)

(10) Опередил. Итератор, ну.
   Ordnung
 
12 - 23.01.19 - 09:23
(6) Будет.
   Serg_1960
 
13 - 23.01.19 - 09:28
DelСтроки = Объект.Товары.НайтиСтроки(Новый Структура("Сумма", 0));

Для Каждого DelСтрока Из DelСтроки Цикл
   Объект.Товары.Удалить(DelСтрока);
КонецЦикла;
   Pro-tone
 
14 - 23.01.19 - 10:19
(13)

DelСтроки = Объект.Товары.НайтиСтроки(Новый Структура("Сумма", 0));


~М1: Для Каждого DelСтрока Из DelСтроки Цикл
   Объект.Товары.Удалить(DelСтрока);
   Перейти ~М1;
КонецЦикла;
   Fram
 
15 - 23.01.19 - 10:24
(14) это зачем?
   catena
 
16 - 23.01.19 - 10:29
(14)Какая-то личная неприязнь к концу цикла?
   ZDenis
 
17 - 23.01.19 - 10:29
А вот так нельзя?
Объект.Товары.Очистить();
   catena
 
18 - 23.01.19 - 10:30
(17)Можно, но пользователи вряд ли обрадуются.
   ZDenis
 
19 - 23.01.19 - 10:30
Аа догнал, по условию надо
   Exigo
 
20 - 23.01.19 - 10:54
Я бы сделал так:
ТЗКопия = ТЗИсходная.Скопировать();
ТЗИсходная.Очистить();
Для Каждого Стр ИЗ ТЗКопия Цикл
   Если УсловиеПроверки Тогда
      новСтр = ТЗИсходная.Добавить();
      ЗаполнитьЗначенияСвойств(Стр,НовСтр);
   КонецЕсли;
КонецЦикла

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.