Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Журнал, при переходе в документ - Переменная не определена (ТекущийДокумент)

v7: Журнал, при переходе в документ - Переменная не определена (ТекущийДокумент)
Я
   gugolovski
 
23.01.19 - 08:27
Есть журнал.
Работало ок: выбираешь документ - он открывается

Добавил текстовое поле, на нем функция для подсветки пиктограмм: ПоказыватьП()

В модуле журнала 1 функция:

Функция ПоказыватьП()
    Возврат ТекущийДокумент.Статус.ПорядковыйНомер();                                            
КонецФункции

//Статус - это перечисление

Теперь пиктограммы в журнале отображаются правильно, но при попытке перейти в документ из журнала ошибка:

Возврат ТекущийДокумент<<?>>.Статус.ПорядковыйНомер();                                            
{Документ.ПередачаВЗал.Форма.Модуль(8)}: Переменная не определена (ТекущийДокумент)

В прочих графах журнала не прописана эта функция, почему на нее ссылается, как отвязаться
 
 
   Масянька
 
1 - 23.01.19 - 08:34
(0)     Если ТекущийДокумент.Выбран() = 0 Тогда
        Возврат "";
    КонецЕсли;
   MadDAD
 
2 - 23.01.19 - 08:40
(0) Вот это "Документ.ПередачаВЗал.Форма.Модуль(8)" явно не из формы журнала. Это форма документа, а там естественно не определена переменная "ТекущийДокумент". Там есть функция "ТекущийДокумент()"
   gugolovski
 
3 - 23.01.19 - 08:53
(1) По всякому пытался приладить этот кусок в модуль журнала не выходит.
(2) Пока Функция ПоказыватьП() в модуле журнала не прописана, документ открывается. Зачем же тогда мне форма документа. Проблема тут, в журнале должна быть
   MadDAD
 
4 - 23.01.19 - 08:54
(3) У тебя в ошибке указана 8-я строка формы документа "ПередачаВЗал".
   Масянька
 
5 - 23.01.19 - 08:59
(3) На форме журнала в ТЧ текстовое поле, в формуле которого стоит ПоказатьКонтроль() (это у меня).
Журнал Общий.
Графы отбора не забудь.
В графах этого журнала есть: Контроль - один док-т.
//******************************************************************************

Функция ПоказатьКонтроль()
    
    Если ТекущийДокумент.Выбран() = 0 Тогда
        Возврат "";
    КонецЕсли;
    
    Если ТекущийДокумент.Вид() = "Реализация" Тогда 
        Возврат ТекущийДокумент.Контроль + 1;
    КонецЕсли;

    Если ТекущийДокумент.Вид() = "ДневнаяРеализация" Тогда
        Возврат "FONT[" + Системные.системПолучитьЦвет(128, 0, 128) + "] ";
    КонецЕсли;
    
КонецФункции
   gugolovski
 
6 - 23.01.19 - 09:00
(4) все, точно. #ЗагрузитьИзФайла использовал и там и здесь. и на один файл ссылался... спасибо

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует