Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Метод объекта не обнаружен (получить)

Метод объекта не обнаружен (получить)
Я
   user1104901
 
17.01.19 - 19:27
1С:Предприятие 8.3 (8.3.13.1644)
Бухгалтерия предприятия, редакция 3.0 (3.0.67.54)
Продажи-1С Маркировка - Уведомление о розничных возвратах при нажатии - ошибка "Метод объекта не обнаружен (получить)"
Чистил КЕШ, ТИИ, удалял в каталоге все файлы кроме базы не помогает. Что можно сделать?
 
 
   user1104901
 
1 - 17.01.19 - 19:27
Причем все остальное работает в том числе и Уведомление о розничных продажах
   OldCondom
 
2 - 17.01.19 - 19:38
А база типовая и без расширений/обоаботок, да?
   user1104901
 
3 - 17.01.19 - 19:42
да база типовая на поддержке без редактирования.
   Serg_1960
 
4 - 17.01.19 - 20:22
А нажать "Подробнее" и перейти на строку конфигурации с ошибкой, чтобы понять что происходит - не, никак нельзя?
   user1104901
 
5 - 17.01.19 - 20:29
А подробнее нет просто ОК
   palsergeich
 
6 - 17.01.19 - 20:33
(5) http://catalog.mista.ru/public/982008/ просветись падован
   user1104901
 
7 - 17.01.19 - 20:47
Спасибо. Не знал. вот подробная ошибка:

{ОбщийМодуль.ИнтеграцияГИСМКлиентСервер.Модуль(782)}: Метод объекта не обнаружен (Получить)
            Значение = Настройки.Получить(ИмяКолонки);

При нажатии на кнопку Конфигуратор получаю сообщение: Конфигуратор не найден. Пожалуйста запустите конфигуратор для используемой информационной базы.
   user1104901
 
8 - 17.01.19 - 21:02
Нашел процедуру:
// Устанавливает отбор в списке по указанному значению для нужной колонки

// с учетом переданной структуры быстрого отбора и переданных настроек.
//

// Параметры:
//  Список - динамический список, для которого треюуется установить отбор

//  ИмяКолонки - Строка - Имя колонки, по которой устанавливается отбор
//  Значение - устанавливаемое значение отбора

//  СтруктураБыстрогоОтбора - Неопределено, Структура - Структура, содержащая ключи и значения отбора
//  Настройки - настройки, из которых могут получаться значения отбора

//  Использование - Неопределено, Булево - Признак использования элемента отбора
//  ВидСравнения - Неопределено, ВидСравненияКомпоновкиДанных - вид сравнения, устанавливаемый для элемента отбора

//  ПриводитьЗначениеКЧислу - Булево - Признак приведения значения к числу.
//

Процедура ОтборПоЗначениюСпискаПриЗагрузкеИзНастроек(Список, ИмяКолонки, Значение, Знач СтруктураБыстрогоОтбора, 
            Настройки, Использование = Неопределено, ВидСравнения = Неопределено) Экспорт
    
    Если СтруктураБыстрогоОтбора = Неопределено Тогда
        Значение = Настройки.Получить(ИмяКолонки);
        ИспользованиеЭлементаОтбора = ?(Использование = Неопределено, ЗначениеЗаполнено(Значение), Использование);
        ОбщегоНазначенияКлиентСервер.УстановитьЭлементОтбораДинамическогоСписка(Список, ИмяКолонки, Значение, ВидСравнения,,ИспользованиеЭлементаОтбора);
    Иначе
        Если Не СтруктураБыстрогоОтбора.Свойство(ИмяКолонки) Тогда
            Значение = Настройки.Получить(ИмяКолонки);
            ИспользованиеЭлементаОтбора = ?(Использование = Неопределено, ЗначениеЗаполнено(Значение), Использование);
            ОбщегоНазначенияКлиентСервер.УстановитьЭлементОтбораДинамическогоСписка(Список, ИмяКолонки, Значение, ВидСравнения,,ИспользованиеЭлементаОтбора);
        КонецЕсли;
    КонецЕсли;
    
    Настройки.Удалить(ИмяКолонки);
    
КонецПроцедуры
   user1104901
 
9 - 17.01.19 - 21:03
Ошибка возникает на второй части цикла :
Если Не СтруктураБыстрогоОтбора.Свойство(ИмяКолонки) Тогда
            Значение = Настройки.Получить(ИмяКолонки);
   МимохожийОднако
 
10 - 17.01.19 - 21:53
(9) Проверь тип значения Настройки. Удивишься. И посмотри откуда этот объект появляется\заполняется\присваивается.
Для этого достаточно встать на эту точку и вычислить. Потом открыть стёк вызовов для анализа.
Долго думать )
 
 Рекламное место пустует
   user1104901
 
11 - 17.01.19 - 23:11
(10) Спасибо. Можно ли подробнее расписать как проделать описанную операцию. Буду очень благодарен.
   palsergeich
 
12 - 17.01.19 - 23:14
   МимохожийОднако
 
13 - 17.01.19 - 23:29
(11) Встань на строчку выше 782 и запусти в режиме отладки

Список тем форума
Рекламное место пустует  Рекламное место пустует
Требовать и эффективности, и гибкости от одной и той же программы — все равно, что искать очаровательную и скромную жену... по-видимому, нам следует остановиться на чем-то одном из двух.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует