Вход | Регистрация
 

Штрих М 33h некорректные параметры в команде

Штрих М  33h некорректные параметры в команде
Я
   Tarlich
 
16.01.19 - 19:17
Таких тем уже много, но ...
УТ 11.3.3.145 - старенькая переписанная .
4.14.744
Пробовал подсунуть shtrih-m_24 - Даже ДЛЛ не устанавливается - Возможно отсутствует компонента и т.д
shtrih-m_20 - добавил , связь есть но ругается  33 не корректные параметры


Тут больше вопрос : Обновлять или ковырять ?
 
 
   Tarlich
 
1 - 16.01.19 - 19:19
лог :
[16.01.2019 18:58:16.281] [00005880] [ERROR] TFiscalPrinter (51, 33h) Некорректные параметры в команде
[16.01.2019 18:58:16.281] [00005880] [DEBUG] TFiscalPrinter Повтор команды 3/3
[16.01.2019 18:58:16.281] [00005880] [DEBUG] TFiscalPrinter Unlock
[16.01.2019 18:58:16.281] [00005880] [DEBUG] TFiscalPrinter Send.3
[16.01.2019 18:58:16.281] [00005880] [DEBUG] TFiscalPrinter Send.4
[16.01.2019 18:58:16.281] [00005880] [DEBUG] TDrvFR GetFontMetrics: 51
[16.01.2019 18:58:16.281] [00005880] [DEBUG] TDrvFR Get_ResultCodeDescription
[16.01.2019 18:58:16.281] [00005880] [DEBUG] TDrvFR Get_ResultCodeDescription: Некорректные параметры в команде
[16.01.2019 18:58:16.281] [00005880] [DEBUG] TDrvFR UnlockPort
[16.01.2019 18:58:16.281] [00005880] [DEBUG] TFiscalPrinter UnlockPort
[16.01.2019 18:58:16.281] [00005880] [DEBUG] TFiscalPrinter Lock
[16.01.2019 18:58:16.281] [00005880] [DEBUG] TFiscalPrinter Unlock
[16.01.2019 18:58:16.281] [00005880] [DEBUG] TDrvFR UnlockPort: 0
[16.01.2019 18:58:16.281] [00005880] [DEBUG] TDrvFR Disconnect
[16.01.2019 18:58:16.281] [00005880] [DEBUG] TFiscalPrinter Disconnect
[16.01.2019 18:58:16.281] [00005880] [DEBUG] TFiscalPrinter IsModelType2 22
[16.01.2019 18:58:16.281] [00005880] [DEBUG] TFiscalPrinter ServerDisconnect
[16.01.2019 18:58:16.281] [00005880] [DEBUG] Close socket
[16.01.2019 18:58:16.281] [00005880] [DEBUG] TDrvFR Disconnect: 0
[16.01.2019 18:58:16.281] [00005880] [ERROR] TDriver1Cst17 Open Error
[16.01.2019 18:58:16.281] [00005880] [DEBUG] TDriver1Cst17 HandleException: 51, Некорректные параметры в команде
[16.01.2019 18:58:16.281] [00005880] [DEBUG] TDriver1Cst17 Open.end
[16.01.2019 18:58:16.281] [00005880] [DEBUG] TDrvFR1C17 Open: False
[16.01.2019 18:58:16.281] [00005880] [DEBUG] TDrvFR1C17 GetLastError
[16.01.2019 18:58:16.281] [00005880] [DEBUG] TDriver1Cst17 GetLastError 33h, Некорректные параметры в команде
   Pit0n_08
 
2 - 16.01.19 - 21:30
Аналогичная хрень после перепрошивки Штрих-М-01Ф на ТиС 7.7...
Смена драйвера от 4.14.721 до последнего не помогает.
   Pit0n_08
 
3 - 16.01.19 - 21:33
У кого эта замечательная ККМ заработала с новым НДС?
На каком драйвере, .dll и обработке (для 7.7)?
   yzimin
 
4 - 17.01.19 - 00:24
Мне на одной кассе помогло в таблицу с налогами прописать 2000, хотя с НДС не работает ККТ
   Масянька
 
5 - 17.01.19 - 10:14
(3) У меня штрих онлайн + ТиС = работает.
   Pit0n_08
 
6 - 17.01.19 - 15:53
(5) Настоящая женщина!!! Всё же в (3) есть и второй вопрос - может приоткроете тайну...
   Масянька
 
7 - 17.01.19 - 16:01
(6) Пошла рисовать... Жди...
   Pit0n_08
 
8 - 17.01.19 - 16:09
(+6) ККМ перепрошита?
   Масянька
 
9 - 17.01.19 - 16:09
Торговое оборудование - https://pastenow.ru/be19e22c848969f55a04520eb3e37663
Настройка параметров системы (вкладка "Драйвер ККТ") - https://pastenow.ru/3943779993bd25feac0e73ae18ccb909
Печать чека (из elves.etr):
Функция ПечататьЧек(Объект, Пароль, СписокТоваров, СуммаЧека, Получено, Скидка, ПризнВозврата, НомерСекции, НомерЧека, ЕстьНДС)
    
    Если (ПустоеЗначение(Объект) = 1) Тогда
        ОписаниеРезультата = "устройство не подключено";
        Возврат 0;
    КонецЕсли;
    
    Если  ((Получено > 0) И (Получено < СуммаЧека)) Тогда
        Предупреждение("Сумма чека больше полученных денег!");
        Возврат 0;
    КонецЕсли;

    Если (ПолучитьРежимККМ(Объект, 0) = 0) тогда
        ПолучитьРежимККМ(Объект, 1);
        Возврат 0;
    конецесли;
    
    Пока ("на экране окно вопроса" = "на экране окно вопроса") Цикл
        Объект.Password = Пароль;
        Объект.Connect();
        Результат = ОбработкаОшибокПриПечати(Объект);
        Если (Результат = "Отмена") Тогда 
            Объект.Disconnect();
            Возврат 0;
        ИначеЕсли (Результат = 0) Тогда
            Прервать;
        КонецЕсли;
    КонецЦикла;
    
    Пока ("на экране окно вопроса" = "на экране окно вопроса") Цикл
        Объект.GetECRStatus();
        Результат = ОбработкаОшибокПриПечати(Объект);
        Если (Результат = "Отмена") Тогда 
            Объект.Disconnect();
            Возврат 0;
        ИначеЕсли (Результат = 0) Тогда
            Прервать;
        КонецЕсли;
    КонецЦикла;
    
    Если (Объект.ECRAdvancedMode = 3) Тогда
        Объект.ContinuePrint();
        Пока ("на экране окно вопроса" = "на экране окно вопроса") Цикл
            Объект.GetECRStatus();
            Результат = ОбработкаОшибокПриПечати(Объект);
            Если (Результат = "Отмена") Тогда 
                Объект.Disconnect();
                Возврат 0;
            ИначеЕсли (Результат = 0) Тогда
                Прервать;
            КонецЕсли;
        КонецЦикла;
    КонецЕсли;  

    // чек на возврат

    Если (ПризнВозврата = 1) Тогда
        Объект.CheckType = 2;
    Иначе
        Объект.CheckType = 1;
    КонецЕсли;

    СписокТоваров.ВыбратьСтроки();
            
    ИтогСумма = 0;
    ИтогНДС   = 0;

    Пока (СписокТоваров.ПолучитьСтроку() = 1) Цикл
        
        Объект.Price                  = Окр(СписокТоваров.Цена, 2, 1);
        Объект.Quantity               = СписокТоваров.Количество;
        Объект.Department             = НомерСекции;
        Объект.StringForPrinting    = "//" + Лев(СписокТоваров.ТовНаим, 30);

        Объект.Summ1Enabled         = 1; 
        Объект.Summ1                 = Окр((СписокТоваров.Цена * СписокТоваров.Количество), 2, 1);
        Объект.PaymentTypeSign         = 4;
        Объект.PaymentItemSign         = СписокТоваров.Вид;
        
        СтрокаДляПечатиКолВаЦеныСуммы = "";
        СтрокаДляПечатиКолВаЦеныСуммы = СокрЛП(Формат(Окр(Объект.Quantity, 2, 1), "Ч15.2")) + " * " + 
                                        СокрЛП(Формат(Окр(Объект.Price, 2, 1), "Ч15.2")) + " =" +
                                        СокрЛП(Формат(Окр(Объект.Summ1, 2, 1), "Ч15.2"));
        
        СтрокаДляПечатиНДС         = "";
        СтрокаДляПечатиСуммыНДС    = "";
        Если (ЕстьНДС = 1) Тогда
            Объект.Tax1             = 1;
            СтавкаНДС                 = глПользователь.ОсновнаяСтавкаНДС;
            Объект.TaxValueEnabled     = 0;
            Объект.TaxValue1         = Окр((Объект.Summ1 * глВыделяемыйНДС(СтавкаНДС)), 2, 1);
            СтрокаДляПечатиНДС        = "НДС " + ОбработкаДанных.обрданПредставлениеСтавкиНДС(СтавкаНДС);
            СтрокаДляПечатиСуммыНДС = "=" + СокрЛП(Формат(Окр(Объект.TaxValue1, 2, 1), "Ч15.2"));
        Иначе
            Объект.Tax1         = 4;
            СтрокаДляПечатиНДС    = "Без НДС";
        КонецЕсли;
        
        Результат = ОбработкаОшибокПриПечати(Объект);

        Если (Результат = 0) Тогда
            Объект.НомерТега             = 1203;                        //TagNumber

            Объект.ТипТега                  = 7;                        //TagType

            Объект.ЗначениеТегаСтрока     = СокрЛП("231503734195");  //TagValueStr    

            Объект.FNSendTag();                                     // отправка тега

            Объект.FNOperation();

            // печать чека на чековой ленте

            Объект.StringForPrinting = "";
            Объект.PrintString();
            мШирина = 32;
            Объект.StringForPrinting = СокрЛП(СписокТоваров.НомерПП) + "." + Лев(СписокТоваров.ТовНаим, мШирина);
            Объект.PrintString();
            Объект.StringForPrinting = глРасположитьТекстПоКраям("", СтрокаДляПечатиКолВаЦеныСуммы, мШирина);
            Объект.PrintString();
            Объект.StringForPrinting = глРасположитьТекстПоКраям(СокрЛП(СтрокаДляПечатиНДС), СтрокаДляПечатиСуммыНДС, мШирина);
            Объект.PrintString();
            
            Если (СписокТоваров.Вид = 3) Тогда
                Объект.StringForPrinting = "  Работа";
            ИначеЕсли (СписокТоваров.Вид = 4) Тогда
                Объект.StringForPrinting = "  Услуга";
            Иначе
                Объект.StringForPrinting = "  Товар";
            КонецЕсли;
            Объект.PrintString();
            Объект.StringForPrinting = "  Полный расчет";
            Объект.PrintString();
        
        Иначе
            Объект.CancelCheck();
            Возврат 0;
        КонецЕсли;
        
        ИтогСумма = ИтогСумма + Объект.Summ1;
        ИтогНДС   = ИтогНДС + Объект.TaxValue1;
    КонецЦикла;
        
    Если ((Получено > 0) И (Получено > СуммаЧека)) Тогда
        Объект.Password = Пароль;
        Объект.Summ1     = Окр(Получено, 2, 1);
    иначе
        Объект.Password = Пароль;
        Объект.Summ1     = ИтогСумма;
    КонецЕсли;

    Объект.TaxValue1          = ИтогНДС;
    Объект.Summ1                = ИтогСумма;
    Объект.TaxType               = 1;
    Объект.StringForPrinting = "================================";

    Объект.FNCloseCheckEx();
    
    Результат = ОбработкаОшибокПриПечати(Объект);
    Если (Результат = "Отмена") Тогда 
        Объект.CancelCheck();
        Возврат 0;
    КонецЕсли;

    //// отрезаем чек

    //если ОтрезкаЧека=1 тогда

    //    Объект.Password=Пароль;

    //    Объект.CutType=0;

    //    Объект.CutCheck();

    //КонецЕсли;


    Если (ОбработкаОшибок(Объект) = 0) Тогда
        Объект.GetECRStatus();
        НомерЧека = Объект.OpenDocumentNumber + 1;
    Иначе
        Возврат 0;
    КонецЕсли;

    Возврат 1;

КонецФункции
   Масянька
 
10 - 17.01.19 - 16:09
(8) Есесьно.
 
 Рекламное место пустует
   Масянька
 
11 - 17.01.19 - 16:09
+ (10) С бубеном танцевала...
У меня такой розовый :)
   Pit0n_08
 
12 - 17.01.19 - 16:15
(11) настоящий девчоночный :-)
Драйвер 624 - фактически годичной давности! Печатает и передает в ОФД все данные?
   Масянька
 
13 - 17.01.19 - 16:16
(12) Василий! Вы мне не верите? (С)
   Масянька
 
14 - 17.01.19 - 16:16
+ (13) У меня штрих-онлайн (касса такая).
   tgu82
 
15 - 17.01.19 - 16:18
(12) у меня работают 8 касс из них 2 с НДС. Пока полет нормальный. ТИС 7.7 кассы Штрих-Лайт 01Ф
   Масянька
 
16 - 17.01.19 - 16:20
(12) ОФД - https://pastenow.ru/81baa4e44a9537b53ccbda01577a160d
PS Бубен мне клиент подарил :)
   Pit0n_08
 
17 - 17.01.19 - 16:26
(13) Это из мультика про попугая? Иногда бываю похож на того тракториста...)
Впрочем, как только меня не называли - но я старательно всех прошу "зовите меня просто Вася..."
   Масянька
 
18 - 17.01.19 - 16:28
(17) Нет. Это из "Любовь и голуби".
Там еще у Гурченко взгляд такой... Блондинистый :)
   Масянька
 
19 - 17.01.19 - 16:28
(17) И вообще - не отвлекайся!
   Pit0n_08
 
20 - 17.01.19 - 16:28
(15) прошу всё же уточнить "На каком драйвере, .dll и обработке (для 7.7)?"
   Pit0n_08
 
21 - 17.01.19 - 16:29
(19) Креплюсь из последних сил...
   Масянька
 
22 - 17.01.19 - 16:30
(20) У меня dll от 05.10.2017 (в эске).
   tgu82
 
23 - 17.01.19 - 16:35
(20) 4.14.722 drvfr.dll
   NikeArz
 
24 - 17.01.19 - 17:10
(9) Тег 1203 вынеси из цикла. Этот тег привязывается ко всему чеку, а не к позиции. Поставь сразу после цикла. Касса корректней работать будет.
   Pit0n_08
 
25 - 17.01.19 - 20:11
(24) А тег 1203 обязателен?
   Pit0n_08
 
26 - 17.01.19 - 20:21
(9) в другой ветке жалилась на двойные строки при печати товаров. Судя по бубну - победила! Но.
Неужели без такого количества ручной печати (.StringForPrinting) в части ТовНаим, количество, цена, налог, тип оплаты и т.д. ККМ сама это не выводит в чек?
   Масянька
 
27 - 18.01.19 - 08:42
(26) Я же написала - с бубеном плясала... И танго, и ламбаду, и краковяк...
Я не знаю, что они (разрабы кассового ПО) сделали, но после срабатывания этой прошивки начался треш и угар...
Признак предмета расчета у меня (лично) начался печататься сверху (первый раз). Признак способа расчета вообще не печатается. В общем, бред сивой кобылы.
А товарищ из (24) кинул обработку (для снеговика) - и там я увидела, что можно печатать не фискальными строками (я слышала, но примеров не видела, а методом тыка - дорого). Вот и сделала. Кстати, еще и шрифт заголовка чека уменьшила (в заголовке стало влезать в одну строку).
Сама касса выводит. Но после этой прошивки криво. Очень. Пробуй. Добьешься - делись.
   NikeArz
 
28 - 18.01.19 - 09:16
(25) Да обязателен
   Масянька
 
29 - 18.01.19 - 09:28
(25) Это ИНН кассира. Обязателен. Зачем нужен - риторический вопрос...
   tgu82
 
30 - 18.01.19 - 11:09
(29) Подскажите никак не врублюсь... Если опдлата товара когда его номенклатура еще неизвестна в точности - ПР="П", СР="Ав", Вид опдаты (наличные или электронные). А когда закрыватся сделка (то есть отдается товар) то ПР="Т" СР=ПР Вид оплаты ="Предоплата" ???
   tgu82
 
31 - 18.01.19 - 11:54
(29) А если накладная будет оплачена безнальным перечислением но позже по договору отсрочки платежа? Тоже надо чек пробивать при отгрузке с постоплатой? Бред какой-то?
   NikeArz
 
32 - 18.01.19 - 12:02
(31) На инфостарте есть примеры чеков. Тему не помню.
   tgu82
 
33 - 18.01.19 - 12:32
(32) Да не в них дело. При оплате между кем и кем используются эти примеры ?
А если платеж будет безналичный но позже
-Между двумя ЮЛ 
- между юл и ип
- между ип и юл
- между ип и ип
ИП = Физическое лицо или все-таки это именно ИП со своими нюансами как как бы у юр. лица ?
 
 
   Масянька
 
34 - 18.01.19 - 12:35
(33) Тут тебе и авторы закона не скажут.
Они писали, писали... Устали и запутались. :(
   tgu82
 
35 - 18.01.19 - 13:04
(34) Это Да )
Статья 2

Пункт 9

Контрольно-кассовая техника не применяется при осуществлении расчетов в безналичном порядке между организациями и (или) индивидуальными предпринимателями, за исключением осуществляемых ими расчетов с использованием электронного средства платежа с его предъявлением.

Понимай как хочешь для предоплат и постоплат
   DEG156
 
36 - 25.01.19 - 11:24
Мне помогла переустановка драйвера на DrvFR_4.14_721 !
   Rovan
 
37 - 25.01.19 - 11:38
(0) у меня у 1 клиента сейчас эта ошибка на базе 1С Бух 3.0
Переписываюсь с фирмой Штрих-М.
Результата пока нет.
   Rovan
 
38 - 25.01.19 - 11:40
(+37) ошибка идет при продаже товаров с НДС 20%
   Rovan
 
39 - 25.01.19 - 11:42
Дали мне драйвер 4.14.749 - такая же ошибка
   Garykom
 
40 - 25.01.19 - 11:42
(35) Если предоплата или постоплата идет не наличными (и не по карте через терминал) то ККТ применять не требуется.

По логике в случае взаимозачета это тоже безналичная оплата.

Потому что нет применения (движения) наличных денежных средств.
   Garykom
 
41 - 25.01.19 - 11:45
(40)+ Да возникновение дебета/кредита в случае передачи ТМЦ (или приема/оказания услуг или приема/выполнения работ) - это тоже "безналичная оплата".
   Rovan
 
42 - 25.01.19 - 14:58
(15) есть подозрение что обл. орг-я должна ставить свежую прошивку в сам аппарат, чтобы он поддерживал всё новое
   Масянька
 
43 - 25.01.19 - 15:02
(42) А кассу не прошивали?
   Rovan
 
44 - 25.01.19 - 15:07
(43) вижу что дата прошивки от октября 2018
   Масянька
 
45 - 25.01.19 - 15:12
(44) В налогах (на кассе) есть 20% НДС?
   Rovan
 
46 - 25.01.19 - 16:07
(45) да
   Масянька
 
47 - 25.01.19 - 16:32
(46) У меня 24.10.2018.
Нужно лезть и смотреть, на что ругается.
Смотри в логах, отладчике, обработке.
   Масянька
 
48 - 25.01.19 - 16:35
+ (47) Теперь обязательны: ИНН кассира, признак и предмет расчета.
   Масянька
 
49 - 25.01.19 - 16:38
+ (47) В параметрах (что на кассу передаются): сам НДС не изменился. То есть: был Tax1 и сейчас Tax1, но это уже 20%.
 
 Рекламное место пустует
   Rovan
 
50 - 25.01.19 - 16:46
(47) падает при вызове ОбработчикДрайвераМодуля.ВыполнитьКоманду( "CheckFiscalization", ....
   Rovan
 
51 - 25.01.19 - 16:47
(48) это в базе 1С надо указывать ?
   Масянька
 
52 - 25.01.19 - 17:04
(51) В обработке, которая передает данные в кассу.
(47) Тут я тебе ничего не скажу...
Теперь вместо CloseCheck они (разрабы касс) рекомендуют использовать FNCloseCheckEx. Это по поводу изменений.
   NikeArz
 
53 - 25.01.19 - 17:56
(51) Попробуй убрать автокоррекцию НДС. Таблица 17 поле не помню. Все делается перед открытием смены.
   g00d
 
54 - 25.01.19 - 20:45
знакомая история
   Rovan
 
55 - 26.01.19 - 14:37
(52) у клиента типовая БП 3.0
я могу менять только настройки оборудования в 1С
   Rovan
 
56 - 26.01.19 - 14:38
(53) пробные чеки из Драйвера ФР печатаются...
не работает именно вызов печати из 1С
   Данила180
 
57 - 27.01.19 - 11:00
при попытке решить одну задачу столкнулся с таким моментом, когда откатил платформу на старую версию  (8.3.10.2561) и чеки перестали печататься из УТ 11.3.4.162. Обновил на 8.3.13.1690 и чеки поехали. Я к тому, что может и Вам попробовать обратить внимание на версию платформы. Так же некоторые прошивку ККТ обновили, а лицензию загрузить не потрудились и поэтому тоже возникают проблемы.
   Rovan
 
58 - 29.01.19 - 16:12
Проблему решил!  В моем случае было
Значение "4968091  4967469  4967630" у контрагента-поставщика
превышает допустимое по спецификации 20 символов.
Решение: в поле "Телефон" я указал  1 телефон, остальные я перенес в поле "Комментарий".


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует