Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

УФ: порядок внешних печ.форм по кнопке "Печать"

УФ: порядок внешних печ.форм по кнопке "Печать"
Я
   dft2014
 
16.01.19 - 16:56
Подскажите, возможно как-то изменить порядок внешних печатных форм в форме документа, которая открывается при нажатии на кнопку Печать?

Ранее, у меня получалось упорядочивать (во встроенных печатных формах) таким образом:

КомандаПечати = КомандыПечати.Добавить();
КомандаПечати.Идентификатор = "МойМакет";
КомандаПечати.Представление = НСтр("ru = 'Приказ о досрочном выходе из декрета'");
КомандаПечати.Картинка = БиблиотекаКартинок.ПометкаНовостиФлагЖелтый32;
КомандаПечати.Порядок = 10;  //вот здесь задавала нужный порядок


Сейчас у меня внешняя печатная форма, можно ли в ней сделать что-то подобное? Вот мой код в модуле объекта внешней печ.формы:


Функция ПолучитьТаблицуКоманд()
    
    Команды = Новый ТаблицаЗначений;
    Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
    Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
    
    Возврат Команды;
    
КонецФункции

Функция ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")
    
    НоваяКоманда = ТаблицаКоманд.Добавить();
    
    НоваяКоманда. Представление = Представление;
    НоваяКоманда. Идентификатор= Идентификатор;
    НоваяКоманда. Использование= Использование;
    НоваяКоманда. ПоказыватьОповещение= ПоказыватьОповещение;
    НоваяКоманда. Модификатор= Модификатор;
    
КонецФункции

Функция СведенияОВнешнейОбработке() Экспорт
    
    ПараметрыРегистрации = Новый Структура;
    
    МассивНазначений = Новый Массив;
    МассивНазначений.Добавить("Документ.ПриемНаРаботу");
    
    ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма");  
    ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
    ПараметрыРегистрации.Вставить("Наименование", "Трудовой договор для северных подразделений");
    ПараметрыРегистрации.Вставить("Версия", "1.0");
    ПараметрыРегистрации.Вставить("БезопасныйРежим", ЛОЖЬ);
    ПараметрыРегистрации.Вставить("Информация", "Трудовой договор для северных подразделений");
    
    ТаблицаКоманд = ПолучитьТаблицуКоманд();
    ДобавитьКоманду(ТаблицаКоманд, "Трудовой договор для северных подразделений", "Макет", "ВызовКлиентскогоМетода", Истина, "");
    ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);
    
    Возврат ПараметрыРегистрации;
    
КонецФункции
 
 
   dft2014
 
1 - 16.01.19 - 17:08
Никто не знает?!
   dft2014
 
2 - 16.01.19 - 17:14
В ЗУП3, в типовом модуле УправлениеПечатью, есть функция СоздатьКоллекциюКомандПечати(). Из комментария к ней:

//Порядок       - Число             - (необязательный) Значение от 1 до 100, указывающее порядок размещения команды

//                                        по отношению к другим командам. Сортировка команд меню Печать осуществляется
//                                        сначала по полю Порядок, затем по представлению.

//                                        Значение по умолчанию: 50.
   dft2014
 
3 - 16.01.19 - 17:16
(2) Некрасиво вставилось, дублирую:

//Порядок - Число - (необязательный) Значение от 1 до 100, указывающее порядок размещения команды

// по отношению к другим командам. Сортировка команд меню Печать осуществляется
// сначала по полю Порядок, затем по представлению.

// Значение по умолчанию: 50.
   dft2014
 
4 - 16.01.19 - 17:19
Вобщем, как мне использовать этот "Порядок"?

В ЗУП3 типовой модуль УправлениеПечатью.СоздатьКоллекциюКомандПечати(), где:
Порядок - Число - (необязательный) Значение от 1 до 100, указывающее порядок размещения команды по отношению к другим командам. Сортировка команд меню Печать осуществляется сначала по полю Порядок, затем по представлению. Значение по умолчанию: 50.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует