Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Атол 55 в связке с ТиС 7.7 помогите разобраться с драйверами.

v7: Атол 55 в связке с ТиС 7.7 помогите разобраться с драйверами.
Я
   Ягуар
 
16.01.19 - 11:28
Есть фискальный регистратор Атол 55. Он работал в связке с конфигурацией написанной на 7.7.
Касса подключена к локальному компьютеру, база находится на сервере, к которому пользователь подключается по RDP.
Используется механизм уравления кассой из типовой ТиС 7.7. - FprnM1C82_54FZ.dll и внешняя обработка frATOL54_comm_105.ert.
В конце декабря кассу перепрошили. После чего перестала работать печать чека из 1с.
При попытке распечатать чек выдает сообщение "Версия удалённого объекта не соответствует версии локального!"

Подскажите что за ошибка. Версии чего с чем не совпадают?
 
 
   Ягуар
 
1 - 16.01.19 - 11:30
Нашел в обработке место, когда возникает эта ошибка.

Функция ПодключитьсяКФР(Объект)

    Рез = 0;
    // занимаем порт

      Объект.DeviceEnabled = 1;
      Если Объект.ResultCode = 0 тогда
          // получаем состояние ККМ

          Если Объект.GetStatus() = 0 тогда
              // если есть открытый чек, то отменяем его

              Если Объект.CheckState <> 0 тогда
                  Если Объект.CancelCheck() = 0 тогда
                      Рез = 1;
                  КонецЕсли;
              КонецЕсли;
          КонецЕсли;
      КонецЕсли;


Вот после 

Объект.DeviceEnabled = 1;
   Масянька
 
2 - 16.01.19 - 11:31
(1) Открывай и сравнивай настройки в драйвере и эске.
И версию драйвера тоже.
   Ягуар
 
3 - 16.01.19 - 11:41
(2) Я к кассе отношения мало имею, ее устанавливала и потом перепрошивала обслуживающая кассу организация. Можешь поподробней объяснить какие настройки сравнивать? Где их посмотреть?
   Масянька
 
4 - 16.01.19 - 11:45
(3) В семерке:
1. Сервис -> Настройка торгового оборудования -> Фискальный регистратор (может быть в одной из вкладок ККМ - маловерятно).
2. Кнопка "О" - редактировать данную модель.
В драйвере ККМ: я не помню, где у атола порт прописан и пр. Находишь и сравниваешь.
В семерке (п. 1) драйвер и обработка указаны.
   Garykom
 
5 - 16.01.19 - 11:54
(2) Плохой их тебя телепат, если про "служба FDSVC" не в курсе.

(0) Вы драйвер ККТ (8-й от атол да?) и на локальном компе и на rdp сервере обновили?
   Ягуар
 
6 - 16.01.19 - 11:55
(4) по п. в семерке 
Драйвер - FprnM1C82_54FZ.dll
Обработка - frATOL54_comm_105.ert
   Масянька
 
7 - 16.01.19 - 11:56
(5) Я в телепаты и не претендую.
   Garykom
 
8 - 16.01.19 - 11:57
(5)+ Если дело не в этом то не совпадают версии dll по стандарту 1С и нативной от атол.

Чистите от всех лишних дрова/dll и ставьте правильно.

Некоторые особо продвинутые личности умудряются эти dll насовать везде где не надо (в каталог 1С и даже в system в в windows) а потом удивляются в что это оно не работает.
   Garykom
 
9 - 16.01.19 - 11:57
(7) Как не претендуешь когда советуешь так смело ))
   Масянька
 
10 - 16.01.19 - 11:57
(9) У вас ПМС сегодня?
 
 Рекламное место пустует
   Garykom
 
11 - 16.01.19 - 11:59
(10) Угу на тупость
   Garykom
 
12 - 16.01.19 - 11:59
(11)+ чужую
   Масянька
 
13 - 16.01.19 - 12:05
(6) Передаю тебя в руки умнейшего телепата (12).
Теперь к нему вопросы и помощь от него же.
Удачи!
   Ягуар
 
14 - 16.01.19 - 12:08
(8)
На локальном компе в утилите "Управление драйверами" : 8.16.3.9007,   путь к библиотеке драйвера "c:\ProgramFiles\..\FprnM1C.dll"

а в 1с в настройках фискального регистратора FprnM1C82_54FZ.dll

Это же не правильно? Так не может работать?
   Garykom
 
15 - 16.01.19 - 12:15
(14) Там несколько dll

В 1С когда придумали БПО не захотели под каждого производителя ТО подстраиваться и выпустили свой "формат" для драйверов (dll) типа пусть производители делают так как нам надо.
И да этот формат периодически обновляется вместе с версией БПО, в результате и выходит путаница и дурдом.

FprnM1C82_54FZ - это ВК по формату 1С новая (интеграционаая компонента)
FprnM1C - это старая (нативная)


FprnM1C82_54FZ для работы использует общие dll которые идут с поставкой FprnM1C (можно сказать что без нативной не работает).
Для работы через нативную новая по стандарту 1С не нужна.

Эти ВК (dll) имеют разный интерфейс для использования, и внешняя обработка (или код в 1С) должны уметь работать с какой то ВК (с другими не умеют, поэтому нет смысла выбирать неправильную).
С чем оно умеет можно увидеть в коде по AddIn что там подключается.
   Garykom
 
16 - 16.01.19 - 12:19
   Garykom
 
17 - 16.01.19 - 12:23
Еще у атол есть служба FDSVC
https://i.paste.pics/9cafcfcf2169c0fbf5ad4ccc5973c912.png

Это для пробивки по сети (через tcp/ip) без проброски COM портов.
Драйвер ставится на два (и более) компа, на том где локально ККТ запускается эта служба а на других (например на RDP сервере) можно подключаться не через COM а через tcp/ip
https://i.paste.pics/6991b46434f8cda6a84112ab7c24216c.png

Указывая правильный ip адрес и порт.
   Ягуар
 
18 - 16.01.19 - 12:32
Спасибо, пока чуть чуть понятно, посмотрю.
Позже видимо еще что-то буду спрашивать.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует