Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Печатная форма не доступна КА2

Печатная форма не доступна КА2
Я
   StazherX
 
15.01.19 - 18:15
Помогите начинающему программисту. КА2 релиз 2.4.6.189 (платформа 8.3.13.1513). Типовая. После обновления не выводит заполненную печатную форму. (Ошибка: Печатная форма не доступна). Отладчиком уже 5-6 раз прошел... Данные получает, макет видит, но не выводит форму. Не хватает пока ума разобраться. Помогите пожалуйста.

#Область ВнешняяОбработка

Функция СведенияОВнешнейОбработке() Экспорт
    
    ПараметрыРегистрации = Новый Структура;
    МассивНазначений      = Новый Массив;

    МассивНазначений.Добавить("Документ.ПоступлениеТоваровУслуг"); //Указываем документ к которому делаем внешнюю печ. форму
    МассивНазначений.Добавить("Документ.ПеремещениеТоваров"); //Указываем документ к которому делаем внешнюю печ. форму
    ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма"); //может быть - ЗаполнениеОбъекта, ДополнительныйОтчет, СозданиеСвязанныхОбъектов...
    ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
    ПараметрыРегистрации.Вставить("Наименование",    "Акт о приеме ТМЦ (МХ-1) внешняя форма"); //имя под которым обработка будет зарегестрирована в справочнике внешних обработок
    ПараметрыРегистрации.Вставить("Версия", "1.0");
    ПараметрыРегистрации.Вставить("БезопасныйРежим", ложь);
    ПараметрыРегистрации.Вставить("Информация",        "Акт о приеме ТМЦ (МХ-1) внешняя форма");//так будет выглядеть описание печ.формы для пользователя

    ТаблицаКоманд = ПолучитьТаблицуКоманд();

    ДобавитьКоманду(
        ТаблицаКоманд,
        "Акт о приеме ТМЦ (МХ-1) внешняя форма",
        "ПФ_MXL_МХ1",
        "ВызовСерверногоМетода",
        Истина,
        "ПечатьMXL");
    
    ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);                                                                          
    Возврат ПараметрыРегистрации;

КонецФункции


Функция ПолучитьТаблицуКоманд()

    Команды = Новый ТаблицаЗначений;
    Команды.Колонки.Добавить("Представление",            Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("Идентификатор",            Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("Использование",             Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("ПоказыватьОповещение",    Новый ОписаниеТипов("Строка"));
    Команды.Колонки.Добавить("Модификатор",                Новый ОписаниеТипов("Строка"));          
    Возврат Команды;

КонецФункции


Функция ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")
    
    НоваяКоманда                       = ТаблицаКоманд.Добавить();
    НоваяКоманда.Представление           = Представление;
    НоваяКоманда.Идентификатор           = Идентификатор;
    НоваяКоманда.Использование          = Использование;
    НоваяКоманда.Модификатор          = Модификатор;
    НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;    

КонецФункции

#КонецОбласти

Функция СформироватьПечатнуюФормуМХ1(СтруктураТипов, ОбъектыПечати, ПараметрыПечати, КомплектыПечати = Неопределено) Экспорт
    
    УстановитьПривилегированныйРежим(Истина);
    
    ТабличныйДокумент = Новый ТабличныйДокумент;
    
    // Зададим параметры макета
    ТабличныйДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Портрет;
    
    ТабличныйДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_МХ1";
    
    НомерТипаДокумента = 0;
    
    Для Каждого СтруктураОбъектов Из СтруктураТипов Цикл
        
        НомерТипаДокумента = НомерТипаДокумента + 1;
        Если НомерТипаДокумента > 1 Тогда
            ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();
        КонецЕсли;
        
        МенеджерОбъекта = ОбщегоНазначенияУТ.ПолучитьМодульЛокализации(СтруктураОбъектов.Ключ);
        Если МенеджерОбъекта = Неопределено Тогда
            МенеджерОбъекта = ОбщегоНазначения.МенеджерОбъектаПоПолномуИмени(СтруктураОбъектов.Ключ);
        КонецЕсли;
        
        Попытка
            ДанныеДляПечати = МенеджерОбъекта.ПолучитьДанныеДляПечатнойФормыМХ1(ПараметрыПечати, СтруктураОбъектов.Значение);
            ЗаполнитьТабличныйДокументМХ1(ТабличныйДокумент, ДанныеДляПечати, ОбъектыПечати,КомплектыПечати);

        Исключение
        КонецПопытки;
        
    КонецЦикла;
    
    Возврат ТабличныйДокумент;
    
КонецФункции


Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт    
    
    СтруктураТипов = ОбщегоНазначенияУТ.СоответствиеМассивовПоТипамОбъектов(МассивОбъектов);
    ПараметрыПечати = Новый Структура;
    
    //Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "ПФ_MXL_МХ3") Тогда
        
        ТабДокумент = СформироватьПечатнуюФормуМХ1(
                СтруктураТипов,
                ОбъектыПечати,
                ПараметрыПечати,
                Неопределено);
        
        УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(
            КоллекцияПечатныхФорм,
            "ПФ_MXL_МХ1",
            НСтр("ru='Акт о возврате ТМЦ (МХ-3)'"),
            ТабДокумент );
    //КонецЕсли;
    
КонецПроцедуры // Печать()
 
 
   Winnie Buh
 
1 - 15.01.19 - 19:43
верни типовой макет
   StazherX
 
2 - 15.01.19 - 22:06
(1) Дык нужен измененный, а не типовой.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует