Вход | Регистрация
 

Как открыть форму нового не записанного документа? УФ 1С 8.3

Как открыть форму нового не записанного документа? УФ 1С 8.3
Я
   tabarigen
 
10.01.19 - 15:59
САБЖ парни, в гугле был. Ничего из найденного не подходит для управляемых форм.
 
 
   Fragster
 
1 - 10.01.19 - 16:01
ОткрытьФорму()
   tabarigen
 
2 - 10.01.19 - 16:02
(1) Ага..
   tabarigen
 
3 - 10.01.19 - 16:14
(1) &НаКлиенте
Процедура ОбработчикОпрос(Элемент) Экспорт
    
    Парам = Новый Структура("Респондент", Объект.Ссылка);
    ОткрытьФорму("Документ.Анкета.Форма.ФормаДокумента", Парам);
    
КонецПроцедуры


никанает
   stix2010
 
4 - 10.01.19 - 16:20
Читай еще
   Вафель
 
5 - 10.01.19 - 16:21
Парам = Новый Структура("Ключ", Объект.Ссылка);
   tabarigen
 
6 - 10.01.19 - 16:23
(5) Объект.Ссылка это ссысла на Справочник Партнеры, а мне нужно создать документ Анкета, но не записывать его.
   Вафель
 
7 - 10.01.19 - 16:24
(6) ввод на основании?
   tabarigen
 
8 - 10.01.19 - 16:25
(7) да нет, просто создание нового документа и автоматически установить в нем новые реквизиты.
   Deon
 
9 - 10.01.19 - 16:29
Можно вот так:
    МояФорма = ПолучитьФорму("Документ.Анкета.Форма.ФормаДокумента");
    МояФорма.Объект.Респондент = ВасяПупкин;
    МояФорма.Открыть();
   tabarigen
 
10 - 10.01.19 - 16:35
(9) так пробовал, не зашло
{Справочник.Партнеры.Форма.ФормаЭлемента.Форма(121)}: Значение не является значением объектного типа (Объект)
    МояФорма.Объект.Респондент = Объект.Ссылка;
 
 Рекламное место пустует
   Evgenchik
 
11 - 10.01.19 - 16:38
ты создаешь форму, собираешь параметры для заполнения объекта. Передаешь эти параметры в ОткрытьФорму. Либо структурой, либо адресом хранилища.
В обработке заполнения документа пишешь заполнение полей при параметрах структуры или адресом хранилища
   tabarigen
 
12 - 10.01.19 - 16:40
(11) Описанное вам проделать на ИЗИ могу, хочется сделать без создания и модификации (ну или минимальной модификации через модуль) типовой формы документа. Можно лии?
   Evgenchik
 
13 - 10.01.19 - 16:44
Обработка заполнения находится в модуле документа, форму создавать не нужно
   Saval1986
 
14 - 10.01.19 - 16:51
(1)
Форма = ПолучитьФорму("Документ.БольничныйЛист.ФормаОбъекта");
Форма.Открыть();

Проверил - работает
   Saval1986
 
15 - 10.01.19 - 16:52
(0) Это пример
   tabarigen
 
16 - 10.01.19 - 16:54
(14) на клиенте?
   tabarigen
 
17 - 10.01.19 - 16:58
Я че то не пойму..
Я пишу код такой..
    МояФорма = ПолучитьФорму("Документ.Анкета.Форма.ФормаДокумента");
    МояФорма.Открыть();

А ошибку получаю следующую
Значение не является значением объектного типа (Открыть)
    МояФорма.Открыть();

что за хрень происходит....
   Evgenchik
 
18 - 10.01.19 - 16:59
Парам = Новый Структура("Респондент", СюдаСобратьСтруктуруПараметров());
    ОткрытьФорму("Документ.Анкета.Форма.ФормаДокумента", Парам);
   Ns33
 
19 - 10.01.19 - 17:08
&НаКлиенте
Процедура Сформировать(Команда)
Форма=ПолучитьФорму("Документ.ПриходнаяНакладная.ФормаОбъекта");
ДанныеФормы=Форма.Объект;
ЗаполнитьДокНаСервере(ДанныеФормы);
КопироватьДанныеФормы(ДанныеФормы, Форма.Объект);
Форма.Открыть();
КонецПроцедуры
//----------------------------------------------------------------------------

&НаСервереБезКонтекста
Процедура ЗаполнитьДокНаСервере(ДанныеФормы)
    ДокОбъект=ДанныеФормыВЗначение(ДанныеФормы,Тип("ДокументОбъект.ПриходнаяНакладная") );
ДокОбъект.Клиент= Справочники.Клиенты.Тест;
НоваяСтрока=ДокОбъект.Материалы.Добавить();
НоваяСтрока.Материал= Справочники.Номенклатура.НайтиПоНаименованию("Шкаф");
ЗначениеВДанныеФормы(ДокОбъект,ДанныеФормы);
КонецПроцедуры
   tabarigen
 
20 - 10.01.19 - 17:10
(19) опять я накосячил..
В форме которую я пытался открыть в процедуру ПриСозданииНаСервере() устанавливалось Отказ=Истина, потому и не открывалась форма видать.
   Fragster
 
21 - 10.01.19 - 18:53
читать до просветления 
Синтакс помощник -> Интерфейс (управляемый) -> Управляемая форма -> Расширение объектов -> Параметры формы


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует