Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

1с упр.формы.Не видит изменения в печ форме в доп отчетах и обработках

1с упр.формы.Не видит изменения в печ форме в доп отчетах и обработках
Я
   Lily_1C
 
09.01.19 - 09:16
Добрый день!
Не пойму в чем дело,подскажите пожалуйста.
Есть внешняя печ.форма УПД,я ее изменила немного и подключила стандартным способом через доп.отчеты и обработки к документу Реализация товаров.
При нажатии на печать выходит неизмененный УПД.
Еси я открываю эту внеш.печ форму через файл-открыть и указываю документ реализации, то программа видит изменения и выводит верный УПД.

Что можно попробовать сделать?Подскажите,пожалуйста!
 
 
   famnam
 
1 - 09.01.19 - 09:17
макет сохранен. см. НСИ - Печатные формы - Макеты печатных форм
   yzimin
 
2 - 09.01.19 - 09:18
если конфигурация на БСП, то проверить настройки видимости печатных форм
   Lily_1C
 
3 - 09.01.19 - 09:28
(1),Я открываю через Конфигуратор,там в печатных формах изменения есть.
НСИ-Печ.формы это где???

Извините за глупый вопрос
   ВикторП
 
4 - 09.01.19 - 09:31
СведенияоВнешнейОбработке как заполнены?
   Lily_1C
 
5 - 09.01.19 - 09:37
Функция СведенияОВнешнейОбработке() Экспорт
    
    ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке();
    
    ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиПечатнаяФорма();
    ПараметрыРегистрации.Версия = "1";
    ПараметрыРегистрации.БезопасныйРежим = Ложь;
    
    ПараметрыРегистрации.Назначение.Добавить("Документ.РеализацияТоваровУслуг");
    
    НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
    НоваяКоманда.Представление = НСтр("ru = 'ВПФ_Универсальный_УПД'");
    НоваяКоманда.Идентификатор = "УПДСтатус1_981";
    НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();
    НоваяКоманда.ПоказыватьОповещение = Истина;
    НоваяКоманда.Модификатор = "ПечатьMXL";
    
    Возврат ПараметрыРегистрации;
    
КонецФункции
   ВикторП
 
6 - 09.01.19 - 09:43
Что в процедуре Печать?
   Lily_1C
 
7 - 09.01.19 - 09:47
Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
    
    СчетаФактуры = ПолучитьСчетФактуры(МассивОбъектов);
    
    Если НЕ ЗначениеЗаполнено(СчетаФактуры) тогда
        Сообщение = Новый СообщениеПользователю;
        Сообщение.Текст = "Не выписана счет фактура";
        Сообщение.Сообщить();
        Возврат;
    КонецЕсли;
    
    ДокументСчф = СчетаФактуры[0];
    ДатаДок = ДокументСчф.Дата;
    
    Если ДатаДок < Дата("20170701") тогда    
        
        УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "УПДСтатус1_981", "УПД (статус 1)",
            ПечатьУниверсальныхПередаточныхДокументов(СчетаФактуры, ОбъектыПечати, 
            ТекстЗапросаПечатьСчетовФактур(Истина, Истина, Ложь)),,
            "ПФ_MXL_УниверсальныйПередаточныйДокумент");
            
    ИначеЕсли ДатаДок >= Дата("20170701") И ДатаДок < Дата("20171001") тогда        
        
        УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "УПДСтатус1_981", "УПД (статус 1)",
            ПечатьУниверсальныхПередаточныхДокументов(СчетаФактуры, ОбъектыПечати, 
            ТекстЗапросаПечатьСчетовФактур(Истина, Истина, Ложь)),,
            "ПФ_MXL_УниверсальныйПередаточныйДокумент");
            
    ИначеЕсли ДатаДок >= Дата("20171001") тогда    
        
        УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "УПДСтатус1_981", "УПД (статус 1)",
            УчетНДС.ПечатьУниверсальныхПередаточныхДокументов981(СчетаФактуры, ОбъектыПечати, 
            ТекстЗапросаПечатьСчетовФактур(Истина, Истина, Истина)),,
            "ПФ_MXL_УниверсальныйПередаточныйДокумент981");
    КонецЕсли;
    
КонецПроцедуры
   ВикторП
 
8 - 09.01.19 - 10:07
Я так понимаю , надо УчетНДС.ПечатьУниверсальных... поменять на свою ПечатьУниверсальных... как вы сделали в двух условиях выше

и дальше искать в этой функции
   Lily_1C
 
9 - 09.01.19 - 10:12
Спасибо! Попробую
   Lily_1C
 
10 - 09.01.19 - 10:31
Не помогает(
 
 Рекламное место пустует
   Lily_1C
 
11 - 09.01.19 - 11:15
Помогло!!! Спасибо огромное, ВикторП!
   ВикторП
 
12 - 09.01.19 - 11:47
Что в итоге было?
Какая была конфа? Я попробовал в УТ 11 Поискать - понял, что не в ней, потом на свои дела отвлекся :)

Список тем форума
Рекламное место пустует  Рекламное место пустует
Независимо от того, куда вы едете — это в гору и против ветра!
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует