Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

ОбработкаВыбора() не работает

ОбработкаВыбора() не работает
Я
   Sun125
 
06.01.19 - 15:45
Есть внешняя обработка табличной части документа, при ее запуске открывается дополнительная форма подбора, выбираются значения и передаются обратно в обработку ТЧ:
&НаКлиенте
Процедура ВыполнитьКоманду(ИдентификаторКоманды, ОбъектыНазначенияМассив) Экспорт
    
    ПараметрыПодбора = Новый Структура("ЗакрыватьПриВыборе, МножественныйВыбор, Организация", Истина, Истина, ВладелецФормы.Объект.Организация);
    ОткрытьФорму("ВнешняяОбработка.ЗаполнениеТЧ.Форма.ФормаПодбора", ПараметрыПодбора, ЭтаФорма);
        
КонецПроцедуры

&НаКлиенте
Процедура ОбработкаВыбора(ВыбранноеЗначение, ИсточникВыбора)
    Сообщить("!!!");
    ОбработкаВыбораНаСервере();
КонецПроцедуры

В форме Подбора:

&НаКлиенте
Процедура ВыполнитьОтбор(Команда)
    
    СпВыбрЗначения = ПолучитьСпВыбрЗначения();
    
    ОповеститьОВыборе(Новый Структура("ВыбрЗначения", СпВыбрЗначения));
    
КонецПроцедуры

Так вот проблема в том, что программа не попадает в процедуру ОбработкаВыбора(). Подскажите, пожалуйста, что не так делаю?
 
 
   mikecool
 
1 - 06.01.19 - 16:58
а точно должна срабатывать ОбработкаВыбора?
   Dzenn
 
2 - 06.01.19 - 17:49
Ну в данном случае вместо процедуры ОбработкаВыбора должна быть процедура ОбработкаОповещения, ведь из твоей внешней обработки идёт оповещение
   Filin
 
3 - 06.01.19 - 21:45
(0) "ОбработкаВыбора" чье событие обрабатывает? Если в "ОткрытьФорму" ты указал владельцем открывамой формы "ЭтаФорма" то и обработчик должен быть от формы. Возможно у тебя к ТЧ привязан.
   Василий Алибабаевич
 
4 - 06.01.19 - 21:52
(3) +100500 К кому привязан обработчик "ОбработкаВыбора"?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует