Вход | Регистрация
 

Покрасить конкретную ячейку дерево значения.

Покрасить конкретную ячейку дерево значения.
Я
   antihacker
 
26.12.18 - 09:27
Всем привет !

Вот так я заполняю дерево.   //Цикл по организациям
   Для Каждого СЗ_ТекЗначение Из СписокОрганизации Цикл
      
       //Добавляем  ветку
       ВеткаДЗ1 = ВеткаДЗ0.Строки.Добавить();

       ВеткаДЗ1.Наименование = СЗ_ТекЗначение.Значение;
      
      
      
       //Цикл по Дате
       ТекДата = Объект.ПериодОт;

       Пока ТекДата <= Объект.ПериодПо Цикл
                
            ИмяПоля = "д" + СтрЗаменить(Формат(ТекДата,"ДЛФ=Д"),".","_");                
          
            //отбор
            Отбор = новый Структура;
            Отбор.Вставить("Организация",СЗ_ТекЗначение.Значение);
            Отбор.Вставить("ПЕРИОД",ТекДата);

            НайтиПоОтбору =  ТЗ_Запрос127.НайтиСтроки(Отбор);
            
            Если НайтиПоОтбору.Количество() > 0 Тогда
                
                 Если НайтиПоОтбору[0].СинхронизированССводной Тогда //Загружен и синхронизирован
                      ВеткаДЗ1[ИмяПоля] = 3;
                 Иначе
                      ВеткаДЗ1[ИмяПоля] = 2; //Загружен
                 КонецЕсли;
                  
            Иначе //Не занружен
                ВеткаДЗ1[ИмяПоля] = 1;  
            КонецЕсли;
            
            //Следующая дата
            ТекДата = ТекДата + 24*60*60;
            
       КонецЦикла;
      
   КонецЦикла;

Теперь мне нужно в зависимости от значения ячейки, покрасить эту же ячейку  на конкретный цвет. Не могу понять как.
 
 
   tty12
 
1 - 26.12.18 - 09:35
В событии ПриПолученииДанных есть Оформления строк.
Для каждого ТекСтрока из ОформленияСтрок Цикл
    Если УсловиеВыполняется Тогда
        ТекСтрока.Ячейки.МояЯчейка(имя колонки).ЦветФона = Новый Цвет(0,0,0);
    КонецЕсли;
КонецЦикла;

как-то так.
   tty12
 
2 - 26.12.18 - 09:36
(1) это для ОФ. Для УФ см. условное оформление.
   antihacker
 
3 - 26.12.18 - 09:37
У меня УФ. В Условных оформлениях нету возможности покрасить ячейку. Или я плохо искал.
   elCust
 
4 - 26.12.18 - 09:39
(3) Есть. В свойствах формы есть условное оформление. Там добавляешь условие и элементы.
   antihacker
 
5 - 26.12.18 - 09:48
Там нельзя указать,ю что нужно конкретную ячейку. Только строку целиком. Потом мои поля не статичные. Динамические.
   elCust
 
6 - 26.12.18 - 09:57
(5) Может быть я ошибаюсь, но мне кажется ты сам себе голову пудришь. (Без обид!)
   tty12
 
7 - 26.12.18 - 10:03
Свойства формы - Оформление - Условное оформление ОТКРЫТЬ - задать условия на оформляемые поля (ячейки).
   antihacker
 
8 - 26.12.18 - 10:07
Ты мне пришли скин где есть слово ячейки. А то у меня толкько поля написано.
   antihacker
 
9 - 26.12.18 - 10:07
скрин
   tty12
 
10 - 26.12.18 - 10:08
поле конкретной строки = ячейка.
другими словами, если условие оформления выполняется, то к полю строки(ячейки) применяется оформление.
 
 Рекламное место пустует
   antihacker
 
11 - 26.12.18 - 10:11
Так он сразу на строку выполняется. а не на конкретную ячейку. Потом этих ячеек не доступны в оформления, так как они создаются динамический программно.
   tty12
 
12 - 26.12.18 - 10:19
Не силен в УФ, но думается мне, что нужно программно и условное оформление тогда задавть на динамические колонки.
   hhhh
 
13 - 26.12.18 - 10:26
(11) еще раз, там список полей задаешь. Список КОНКРЕТНЫХ полей. Как это ты имудряешься задать поля? Что не их красит, а всю строку? Тебе нобелевку надо дать, типа покрасчик всей строки.
   Лодырь
 
14 - 26.12.18 - 10:29
(11) Оформляемые поля нужные (твою колонку) указывай. А не все подряд.
   tty12
 
15 - 26.12.18 - 10:29
(13) Он имел ввиду, что имя поля, на которое нужно оформление наложить, неизвестно, т.к. оно кодом добавляется.
   Лодырь
 
16 - 26.12.18 - 10:30
(15) Как это его сдерживает? Если оно добавляется кодом, то точно так же кодом добавляется и УО
   antihacker
 
17 - 26.12.18 - 10:46
Лодырь, можно примерчик. Помолюсь за тебя )
   Лодырь
 
18 - 26.12.18 - 10:49
(17) Мое искать долго, держи чужое http://catalog.mista.ru/public/181336/
   antihacker
 
19 - 26.12.18 - 10:51
Угу. Как раз читал здесь )
   antihacker
 
20 - 26.12.18 - 10:51
   antihacker
 
21 - 26.12.18 - 10:51
   Лодырь
 
22 - 26.12.18 - 10:53
(21) У вас в роду бледнолицых не было?
   antihacker
 
23 - 26.12.18 - 11:13
Ты о чем ?
   antihacker
 
24 - 26.12.18 - 12:50
Не ужели получаю ячейку таким образом

ВеткаДЗ1[ИмяПоля];

Нельзя здесь же сразу задать цвет фона ?
   catena
 
25 - 26.12.18 - 13:03
(24)А вручную без УО можешь задать ячейке цвет фона?
   antihacker
 
26 - 26.12.18 - 13:06
Нет. Просто не знаю как впихнуть УО в цикл....
   FIXXXL
 
27 - 26.12.18 - 13:13
(26) зачем УО в цикл?
   antihacker
 
28 - 26.12.18 - 13:16
Ну а как  ? Например мне нужно покрасить ячейку в красный цвет, если ВеткаДЗ1[ИмяПоля] = 3.
   catena
 
29 - 26.12.18 - 13:23
(27)Т.е., все "3" по всему дереву в этом "ИмяПоля" или только в конкретной строке?
   antihacker
 
30 - 26.12.18 - 13:25
В конкретной ячейке. По всему дереву, значение любой ячейки может принимать значение 3.
   antihacker
 
31 - 26.12.18 - 13:26
И эти ячейки нужно будет покрасить. А столбцы за ранее не известны. Создаются динамически программно.

//---Массив для список дат

МСВ_СписокДат = Новый Массив;
// 1. получаем дерево как програмный объект

ДеревоОбъект = РеквизитФормыВЗначение("ДЗ_РезАнализа");

//Цикл по дате

ТекДата = Объект.ПериодОт;

Пока ТекДата <= Объект.ПериодПо Цикл
    
    //Добавим в массив

     МСВ_СписокДат.Добавить(ТекДата);
     
    //Отформатированная дата

     ДатаКакСтрока = Формат(ТекДата,"ДЛФ=Д");
     
     ИмяПоле = "д" + СтрЗаменить(ДатаКакСтрока,".","_");
     
    //Заголовок

     ЗаголовокПоле = Лев(ДатаКакСтрока,10);
     
    // 2. добавляем колонку

     ДеревоОбъект.Колонки.Добавить(ИмяПоле, Новый ОписаниеТипов("Строка"));

    // 3. создаем РЕКВИЗИТ КОЛОНКИ (невидимая часть, справа в редакторе форм)

     МассивДобавляемыхРеквизитов = Новый Массив;

    // реквизит принадлежит дереву

     МассивДобавляемыхРеквизитов.Добавить(Новый РеквизитФормы(ИмяПоле, Новый ОписаниеТипов("Строка"), "ДЗ_РезАнализа"));

    // добавляем реквизит в форму (невидимая часть, справа в редакторе форм)

     ИзменитьРеквизиты(МассивДобавляемыхРеквизитов);

    // 4. заполняем дерево (реквизит формы) занчением

     ЗначениеВРеквизитФормы(ДеревоОбъект, "ДЗ_РезАнализа");

    // 5. добавляем НА ФОРМУ (видимая часть, слева в редакторе форм)

    // назовем ДеревоУзел, принадлежит элементу дерева, связан с добавленной колонкой «Узел»

     ДеревоУзел = СокрЛП(ДеревоУзел)+ИмяПоле;
     НовыйЭлемент = Элементы.Добавить(ДеревоУзел, Тип("ПолеФормы"), Элементы.ФДЗ_РезАнализа);
     НовыйЭлемент.Заголовок = ЗаголовокПоле;
     НовыйЭлемент.Ширина = 10;
     НовыйЭлемент.ГоризонтальноеПоложение = ГоризонтальноеПоложениеЭлемента.Центр;
     НовыйЭлемент.Шрифт = Новый Шрифт(НовыйЭлемент.Шрифт,,72,Истина,,,,30);                            
     НовыйЭлемент.Вид = ВидПоляФормы.ПолеВвода;
     НовыйЭлемент.ПутьКДанным = "ДЗ_РезАнализа."+ИмяПоле;

      
     ТекДата = ТекДата + 24*60*60;
     
КонецЦикла;
   catena
 
32 - 26.12.18 - 13:31
(30)Ты не понял. УО накладывается на всё дерево целиком. Еще до существования дерева. Нельзя наложить УО на одну строчку. Если ты хочешь, чтобы 3 в колонке ИмяПоля в одной строке раскрашивалось, а в другой не раскрашивалось, тебе для УО нужно дополнительное значение фильтра, которое идентифицирует строку однозначно. Например, скрытый столбец, в который в своем цикле пишешь "раскрасить в черный", "раскрасить в красный".
А в УО ~отдельно от дерева~ добавляешь элементы "допстолбец="раскрасить в черный"; ЦветФона=красный; оформляемые поля=ИмяПоля"
   antihacker
 
33 - 26.12.18 - 13:39
Это как до существования ? Это в каком жизненном цикле формы надо установить привалы ?
 
 
   catena
 
34 - 26.12.18 - 13:43
(33)Вот есть у тебя список документов. Ты установил отбор, например, по какой-то организации. Потом создаешь документ из этого же списка, но с другой организацией, что будет? Он не появится в списке. Потому что отбору все равно в какой момент ты этот документ создал, он обрабатывает и новые и старые.

УО - это как отбор, только не скрывает, а раскрашивает.
   catena
 
35 - 26.12.18 - 13:45
Ты же не можешь отбору сказать: в пятой строке филиал 5 показать, а в восьмой скрыть. Потому что отбору насрать на строки, он с таблицей целиком работает. А вот условие "номерСтроки=5 И филиал=5" - будет работать.
   FIXXXL
 
36 - 26.12.18 - 13:45
(33) ты видимо плохо представляешь как работает УО...
примерно:
ты описываешь по какому условию и что нужно сделать
платформа на каждый чих списка крутит цикл по видимым строкам и применяет твои, к примеру, раскраски к указанным областям, если строка подпадает под указанное условие
   antihacker
 
37 - 26.12.18 - 13:49
Думал вот так можно.
        СтруктурныйОбзорДЗ_РФЗ = РеквизитФормыВЗначение("ДЗ_РезАнализа"); 
 

Для Каждого СтрокаДанных Из СтруктурныйОбзорДЗ_РФЗ.Строки Цикл
// Условное оформление - Номер первой строки

//СтрокаДанных.ВерсияППОтображение = ПолучитьНомерВерсииПП(СтрокаДанных.НоваяВерсия);

НовыйЭлементУсловногоОформления = УсловноеОформление.Элементы.Добавить();
//НовыйЭлементУсловногоОформления.ИдентификаторПользовательскойНастройки = ""Стр.НомерСтроки;


НовыйЭлементУсловногоОформления.Оформление.УстановитьЗначениеПараметра("ЦветФона", WebЦвета.Красный);

//НовыйЭлементУсловногоОформления.Представление = "СозданоПрограммно";

НовыйЭлементУсловногоОформления.Использование = Истина;

ЭлементОтбора = НовыйЭлементУсловногоОформления.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
ЭлементОтбора.Использование = Истина;

ЭлементОтбора.ЛевоеЗначение  = Новый ПолеКомпоновкиДанных("ДЗ_РезАнализа.Наименование");
ЭлементОтбора.ВидСравнения   = ВидСравненияКомпоновкиДанных.Равно;
ЭлементОтбора.ПравоеЗначение = "Документ127";

КонецЦикла; 


ЗначениеВРеквизитФормы(СтруктурныйОбзорДЗ_РФЗ, "ДЗ_РезАнализа");


Не работает. Это применяю я после того как все строчки добавились и дерево готовое с данными.
   antihacker
 
38 - 26.12.18 - 13:50
Ой извините. цикл тут ни причем )
   antihacker
 
39 - 26.12.18 - 13:57
Вот следую примеру

http://catalog.mista.ru/public/181336/


Вижу строку

ЭлементОформления = Список.УсловноеОформление.Элементы.Добавить();

В моем случае должно быть так

ЭлементОформления = ДЗ_РезАнализа.УсловноеОформление.Элементы.Добавить();

ДЗ_РезАнализа - это объект дерево.

Пишет что УсловноеОформление не существует.
и сразу же здесь проблема
   FIXXXL
 
40 - 26.12.18 - 14:03
(39) ну напиши ЭтотОбъект.УсловноеОформление
   antihacker
 
41 - 26.12.18 - 14:46
Получилось вот так

    ЭлементОформления = ЭтотОбъект.УсловноеОформление.Элементы.Добавить();
    ЭлементУсловногоОформления = УсловноеОформление.Элементы.Добавить();
    ЭлементОтобора = ЭлементОформления.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    ЭлементОтобора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("ДЗ_РезАнализа.Наименование");
    ЭлементОтобора.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
    ЭлементОтобора.ПравоеЗначение = "Документ127";
    ЭлементОформления.Оформление.УстановитьЗначениеПараметра("ЦветТекста", WebЦвета.Красный);
    ЭлементОтобора.Использование = Истина;
    
    ПолеОформления = ЭлементОформления.Поля.Элементы.Добавить();
    ПолеОформления.Поле = Новый ПолеКомпоновкиДанных("ФДЗ_РезАнализа.Наименование");
    ПолеОформления.Использование = Истина;


Зараза не работает
   antihacker
 
42 - 26.12.18 - 15:01
Кажись не работает из за этого.
ЭлементОформления = ЭтотОбъект.УсловноеОформление.Элементы.Добавить();

Но так так можно ЭтотОбъект.ДЗ_РезАнализа.УсловноеОформление.Элементы.Добавить();


если ДЗ_РезАнализа динамический список.
   antihacker
 
43 - 27.12.18 - 07:19
Вроде решил так !
   antihacker
 
44 - 27.12.18 - 07:20
//Отформатированная дата

    ЭлементОформления = ЭтотОбъект.УсловноеОформление.Элементы.Добавить();     
    ЭлементУсловногоОформления = УсловноеОформление.Элементы.Добавить();
    ЭлементОтобора = ЭлементОформления.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    ЭлементОтобора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("ДЗ_РезАнализа.Наименование");
    ЭлементОтобора.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
    ЭлементОтобора.ПравоеЗначение = "Документ127";
    ЭлементОформления.Оформление.УстановитьЗначениеПараметра("ЦветФона", WebЦвета.Красный);
    ЭлементОтобора.Использование = Истина;
    
    ПолеОформления = ЭлементОформления.Поля.Элементы.Добавить();
    ПолеОформления.Поле = Новый ПолеКомпоновкиДанных("Наименование");
    ПолеОформления.Использование = Истина;
    
    
//Цикл по дате

ТекДата = Объект.ПериодОт;

Пока ТекДата <= Объект.ПериодПо Цикл
    
    //Отформатированная дата

     ДатаКакСтрока = Формат(ТекДата,"ДЛФ=Д");
     
     ИмяПоле = "д" + СтрЗаменить(ДатаКакСтрока,".","_");  
     
     ЭлементОформления = ЭтотОбъект.УсловноеОформление.Элементы.Добавить();
     ЭлементУсловногоОформления = УсловноеОформление.Элементы.Добавить();
     ЭлементОтобора = ЭлементОформления.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
     ЭлементОтобора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("ДЗ_РезАнализа."+ИмяПоле);
     ЭлементОтобора.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
     ЭлементОтобора.ПравоеЗначение = "-";
     ЭлементОформления.Оформление.УстановитьЗначениеПараметра("ЦветФона", WebЦвета.Красный);
     ЭлементОтобора.Использование = Истина;
    
     ПолеОформления = ЭлементОформления.Поля.Элементы.Добавить();
     ПолеОформления.Поле = Новый ПолеКомпоновкиДанных(ИмяПоле);
     ПолеОформления.Использование = Истина;
    
     ТекДата = ТекДата + 24*60*60;
    
 КонецЦикла;

Но работает только на первый столбец. Помогите.
   Лодырь
 
45 - 27.12.18 - 07:53
Первый столбец - наименование? )))
   antihacker
 
46 - 27.12.18 - 08:02
Ога ! Но его можно и убрать. Прикол в том что строку ТекДата = ТекДата + 24*60*60; переместить на начало цикла, то даже первый столбец не красится )
   antihacker
 
47 - 27.12.18 - 08:05
Хотя по идее должен покрасится второй столбец )
   catena
 
48 - 27.12.18 - 08:05
(46)Ну пройдись отладчиком, не ладно что-то с именем поля значит. Загляни в УО после установки в режиме предприятия, посмотри, что там наваялось.
   Лодырь
 
49 - 27.12.18 - 08:06
(47) все верно, ищи косяк в имени поля.
 
 Рекламное место пустует
   antihacker
 
50 - 27.12.18 - 08:17
В том то и дело, что с именами полей нет проблем.
   antihacker
 
51 - 27.12.18 - 08:20
Я даже пробовал вот так. Все равно второе поле не красится
ТекДата = Объект.ПериодОт;

//Пока ТекДата <= Объект.ПериодПо Цикл

    
    //Отформатированная дата

     ДатаКакСтрока = Формат(ТекДата,"ДЛФ=Д");
     
     ИмяПоле = "д" + СтрЗаменить(ДатаКакСтрока,".","_");  
     
     ЭлементОформления = ЭтотОбъект.УсловноеОформление.Элементы.Добавить();
     ЭлементУсловногоОформления = УсловноеОформление.Элементы.Добавить();
     ЭлементОтобора = ЭлементОформления.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
     ЭлементОтобора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("ДЗ_РезАнализа."+ИмяПоле);
     ЭлементОтобора.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
     ЭлементОтобора.ПравоеЗначение = "-";
     ЭлементОформления.Оформление.УстановитьЗначениеПараметра("ЦветФона", WebЦвета.Красный);
     ЭлементОтобора.Использование = Истина;
    
     ПолеОформления = ЭлементОформления.Поля.Элементы.Добавить();
     ПолеОформления.Поле = Новый ПолеКомпоновкиДанных(ИмяПоле);
     ПолеОформления.Использование = Истина;
    
     ТекДата = ТекДата + 24*60*60;
     
     
     //Отформатированная дата

     ДатаКакСтрока = Формат(ТекДата,"ДЛФ=Д");
     
     ИмяПоле1 = "д" + СтрЗаменить(ДатаКакСтрока,".","_");  
     
     ЭлементОформления = ЭтотОбъект.УсловноеОформление.Элементы.Добавить();
     ЭлементУсловногоОформления = УсловноеОформление.Элементы.Добавить();
     ЭлементОтобора = ЭлементОформления.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
     ЭлементОтобора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("ДЗ_РезАнализа."+ИмяПоле1);
     ЭлементОтобора.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
     ЭлементОтобора.ПравоеЗначение = "-";
     ЭлементОформления.Оформление.УстановитьЗначениеПараметра("ЦветФона", WebЦвета.Красный);
     ЭлементОтобора.Использование = Истина;
    
     ПолеОформления = ЭлементОформления.Поля.Элементы.Добавить();
     ПолеОформления.Поле = Новый ПолеКомпоновкиДанных(ИмяПоле1);
     ПолеОформления.Использование = Истина;
   antihacker
 
52 - 27.12.18 - 08:32
Косяк нашел. Здесь

     ДеревоУзел = СокрЛП(ДеревоУзел)+ИмяПоле;
     НовыйЭлемент = Элементы.Добавить(ДеревоУзел, Тип("ПолеФормы"), Элементы.ФДЗ_РезАнализа);

Это ДеревоУзел = СокрЛП(ДеревоУзел)+ИмяПоле;
переделал на это 

ДеревоУзел = ИмяПоле;
   antihacker
 
53 - 27.12.18 - 08:42
А теперь так

//Цикл по дате

ТекДата = Объект.ПериодОт;

Пока ТекДата <= Объект.ПериодПо Цикл
    
        
    //Отформатированная дата

     ДатаКакСтрока = Формат(ТекДата,"ДЛФ=Д");
     
     ИмяПоле = "д" + СтрЗаменить(ДатаКакСтрока,".","_");  
     
     ЭлементОформления = ЭтотОбъект.УсловноеОформление.Элементы.Добавить();
     ЭлементУсловногоОформления = УсловноеОформление.Элементы.Добавить();
     
     ЭлементОтобора = ЭлементОформления.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
     ЭлементОтобора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("ДЗ_РезАнализа."+ИмяПоле);
     ЭлементОтобора.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
     ЭлементОтобора.ПравоеЗначение = "-";
     ЭлементОформления.Оформление.УстановитьЗначениеПараметра("ЦветФона", WebЦвета.Красный);
     ЭлементОтобора.Использование = Истина;
     
     ЭлементОформления1 = ЭтотОбъект.УсловноеОформление.Элементы.Добавить();
     ЭлементУсловногоОформления1 = УсловноеОформление.Элементы.Добавить();
     
     ЭлементОтобора1 = ЭлементОформления1.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
     ЭлементОтобора1.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("ДЗ_РезАнализа."+ИмяПоле);
     ЭлементОтобора1.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
     ЭлементОтобора1.ПравоеЗначение = "++";
     ЭлементОформления1.Оформление.УстановитьЗначениеПараметра("ЦветФона", WebЦвета.Зеленый);
     ЭлементОтобора1.Использование = Истина;
     
     ПолеОформления = ЭлементОформления.Поля.Элементы.Добавить();
     ПолеОформления.Поле = Новый ПолеКомпоновкиДанных(ИмяПоле);
     ПолеОформления.Использование = Истина;
    
      ТекДата = ТекДата + 24*60*60;

 КонецЦикла;


Почему то работает только условие ЭлементОтобора.ПравоеЗначение = "-";

А условие  ЭлементОтобора.ПравоеЗначение = "++"; не работает
   catena
 
54 - 27.12.18 - 08:46
А чего поле оформления только в ЭлементОформления добавлено?
   antihacker
 
55 - 27.12.18 - 09:25
catena, Красавчик  !

Итого получился. Кому если пригодится.  

&НаСервере
Процедура ЛегендаНаСервере()
    
//Цикл по дате

ТекДата = Объект.ПериодОт;

Пока ТекДата <= Объект.ПериодПо Цикл
    
        
    //Отформатированная дата

     ДатаКакСтрока = Формат(ТекДата,"ДЛФ=Д");
     
     ИмяПоле = "д" + СтрЗаменить(ДатаКакСтрока,".","_");  
     
    //Отметка как НЕ загружен

     ЭлементОформления = ЭтотОбъект.УсловноеОформление.Элементы.Добавить();
     ЭлементУсловногоОформления = УсловноеОформление.Элементы.Добавить();
     
     ЭлементОтобора = ЭлементОформления.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
     ЭлементОтобора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("ДЗ_РезАнализа."+ИмяПоле);
     ЭлементОтобора.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
     ЭлементОтобора.ПравоеЗначение = "-";
     ЭлементОформления.Оформление.УстановитьЗначениеПараметра("ЦветФона", WebЦвета.Красный);
     ЭлементОтобора.Использование = Истина;
     
     ПолеОформления = ЭлементОформления.Поля.Элементы.Добавить();
     ПолеОформления.Поле = Новый ПолеКомпоновкиДанных(ИмяПоле);
     ПолеОформления.Использование = Истина;
     
    //Отметка как загружен

     ЭлементОформления1 = ЭтотОбъект.УсловноеОформление.Элементы.Добавить();
     ЭлементУсловногоОформления1 = УсловноеОформление.Элементы.Добавить();
     
     ЭлементОтобора1 = ЭлементОформления1.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
     ЭлементОтобора1.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("ДЗ_РезАнализа."+ИмяПоле);
     ЭлементОтобора1.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
     ЭлементОтобора1.ПравоеЗначение = "+";
     ЭлементОформления1.Оформление.УстановитьЗначениеПараметра("ЦветФона", WebЦвета.Оранжевый);
     ЭлементОтобора1.Использование = Истина;
     
     ПолеОформления1 = ЭлементОформления1.Поля.Элементы.Добавить();
     ПолеОформления1.Поле = Новый ПолеКомпоновкиДанных(ИмяПоле);
     ПолеОформления1.Использование = Истина;
     
    //Отметка как загружен и синхронизирован

     ЭлементОформления1 = ЭтотОбъект.УсловноеОформление.Элементы.Добавить();
     ЭлементУсловногоОформления1 = УсловноеОформление.Элементы.Добавить();
     
     ЭлементОтобора1 = ЭлементОформления1.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
     ЭлементОтобора1.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("ДЗ_РезАнализа."+ИмяПоле);
     ЭлементОтобора1.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
     ЭлементОтобора1.ПравоеЗначение = "++";
     ЭлементОформления1.Оформление.УстановитьЗначениеПараметра("ЦветФона", WebЦвета.ЗеленаяЛужайка);
     ЭлементОтобора1.Использование = Истина;
     
     ПолеОформления1 = ЭлементОформления1.Поля.Элементы.Добавить();
     ПолеОформления1.Поле = Новый ПолеКомпоновкиДанных(ИмяПоле);
     ПолеОформления1.Использование = Истина;
     
      ТекДата = ТекДата + 24*60*60;

 КонецЦикла;

КонецПроцедуры


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует