Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Заполнить табличную часть документа

Заполнить табличную часть документа
Я
   nAPACEHAK
 
25.12.18 - 14:36
Доброго

Чего то торможу, подскажите плз

Документ. Реквизит - ТЧ (ТабРасход). На форму не вынесен. На форме реквизит тип ДеревоЗначений

При записи дока надо заполнить ТЧ документа из Дерева

В ПередЗаписью" ТЧ вроде заполняется (в отладчике есть данные)
в ПриОткрытии - данных нет

Уже всё вроде перепробовал...
Как правильно заполнить то?

&НаСервере
Процедура ДеревоВТаблицуЗначений()
    Объект.ТабРасход.Очистить();
    _Дерево = ДанныеФормыВЗначение(ДетальноДерево, Тип ("ДеревоЗначений"));
    
    //ДанныеФормыВЗначение(Элементы.ТабРасход, Тип ("ТаблицаЗначений"));

    //Таб = РеквизитФормыВЗначение ("Объект.ТабРасход");

    //Таб = ДанныеФормыВЗначение(Объект.ТабРасход, Тип ("ТаблицаЗначений"));

    //Таб = Объект.ТабРасход.Выгрузить();

    //Таб = Объект.ТабРасход;

    //ДокОбъект = РеквизитФормыВЗначение("Объект");

    //Таб = ДокОбъект.ТабРасход;

    
    Для каждого СтрокаРодитель Из _Дерево.Строки Цикл
        ЦФО = СтрокаРодитель.ЦФО_СписаниеВид;
        Для каждого Строка Из СтрокаРодитель.Строки Цикл
            ТабСтрока = Таб.Добавить();
            ТабСтрока.ЦФО = ЦФО;
            ЗаполнитьЗначенияСвойств(ТабСтрока, Строка);
        КонецЦикла; 
    КонецЦикла; 
    
    //Объект.ТабРасход.Загрузить(Таб);

    //ЗначениеВРеквизитФормы(Таб, Объект.ТабРасход);

    //ЗначениеВДанныеФормы(Таб, Объект.ТабРасход);

    //ЗначениеВРеквизитФормы(ДокОбъект, "Объект");

КонецПроцедуры


 
 
   nAPACEHAK
 
1 - 25.12.18 - 14:54
Трасировка
ПередЗаписью
https://prnt.sc/lzbenn

ПриОткрытии
https://prnt.sc/lzbevh

Документ точно записывается, все реквизиты формы сохраняются.
Не сохраняется только ТЧ дока

ЧЯДНТ?
   Mankubus
 
2 - 25.12.18 - 15:07
Заполняй передЗаписьюНаСервере в переменную ТекущийОбъект
   nAPACEHAK
 
3 - 25.12.18 - 15:40
(2) спс. получилось

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует