Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Вышла 114 УПП. Изменено перечисление СтавкиНДС

Вышла 114 УПП. Изменено перечисление СтавкиНДС
Я
   Базис
 
24.12.18 - 15:13
Мы будем ждать БИТовское обновление, но если кто скажет - что изменилось в перечислении, буду благодарен. Вроде бы все возможные ставки давно есть:
18, 18_118, 10, 10_110, 20, 20_120, БезНДС и НДС0.
 
 
   Гипервизор
 
1 - 24.12.18 - 15:36
Изменения в модуле менеджера.
   Базис
 
2 - 24.12.18 - 15:56
Спасибо. Никогда не пользовался модулем менеджера перечисления. И вот опять.
   Гипервизор
 
3 - 24.12.18 - 15:58
Функция СтавкиПоОперациямОтражаемымВКнигеПродаж(ВерсияПостановленияНДС1137) Экспорт
    
    МассивСтавок = Новый Массив;
    
    МассивСтавок.Добавить(Перечисления.СтавкиНДС.НДС0);
    МассивСтавок.Добавить(Перечисления.СтавкиНДС.НДС10);
    МассивСтавок.Добавить(Перечисления.СтавкиНДС.НДС10_110);
    МассивСтавок.Добавить(Перечисления.СтавкиНДС.НДС18);
    МассивСтавок.Добавить(Перечисления.СтавкиНДС.НДС18_118);
    МассивСтавок.Добавить(Перечисления.СтавкиНДС.НДС20);// Вот это добавили

    МассивСтавок.Добавить(Перечисления.СтавкиНДС.НДС20_120);// И вот это

        
    Если ВерсияПостановленияНДС1137 < 3 Тогда
        МассивСтавок.Добавить(Перечисления.СтавкиНДС.БезНДС);
    КонецЕсли;
    
    Возврат МассивСтавок;
    
КонецФункции
   Базис
 
4 - 24.12.18 - 16:20
Плохо, когда платят построчно.
Ленивый перебрал бы значения перечисления.
   Azverin
 
5 - 24.12.18 - 16:23
а у кого лохматые УПП, тем, полагаю, не рыпаться со ставкой НДС 20%?
например 1.3.67.1
   Базис
 
6 - 24.12.18 - 16:42
Сравнить последнюю типовую с пред-предпоследней, дифф глазками и ручками перенести в лохматую.
   shuhard
 
7 - 24.12.18 - 16:43
(0)[Вроде бы все возможные ставки давно есть]

a.    Общий модуль  УчетНДСПереопределяемый Процедуры:
i.    ЗаполнитьСписокВыбораСтавокНДС     2 точки изменения
ii.    УстановитьУсловноеОформлениеДляНДСпоСтавкам4и2  1 точка изменения
b.    Общий модуль  ЦенообразованиеКлиентСервер Процедуры:
i.    ПолучитьСтавкуНДСЧислом 1 точка изменения
   ИС-2
 
8 - 24.12.18 - 16:47
видел, что в новых конфах появился мастер перехода на НДС 20. Кто-то его использовал?
   Базис
 
9 - 24.12.18 - 16:50
(7) С тобой всё проще :)

(8) Использовали. На заполненной - изменил 18 на 20. На пустой (да, немножко есть и такое) не трогал. Жалоб не было.
   shuhard
 
10 - 24.12.18 - 16:52
(8) на тесте использовал
в продуктиве 3.01.2019
 
 Рекламное место пустует
   shuhard
 
11 - 24.12.18 - 16:53
(9) это модули от ERP =)
важен принцип
   Базис
 
12 - 24.12.18 - 16:56
(11) Ты хочешь сказать, что поиск по 18_118 не даст рулон кода?
   Симпатяга
 
13 - 24.12.18 - 17:03
(0) что то я не понял. в описании изменений куча документов, а запустил обновление - показал только чек ккм и отчет комисионера.хм
   Базис
 
14 - 25.12.18 - 11:44
Глянул разницу между выходом обновления от 1С и от БИТа. Удивился. Видимо, будем собирать своё обновление.
   Джинн
 
15 - 25.12.18 - 11:46
(14) Не так уж и сложно. БиТовкие довески не обновляются уже триста лет. Мне это добавляет часов 20 лишней работы с учетом тестирования. Но иногда приходится.
   Базис
 
16 - 25.12.18 - 11:52
(15) Тестирование не автоматизировал?
   Джинн
 
17 - 25.12.18 - 11:57
(16) Нет. Все время вокруг этой мысли кручусь, но вечно не хватает времени плотно заняться :( Идея хорошая, но требует серьезной проработки, т.к. даже в голове у меня нет целостной картины как это сделать.
   Azverin
 
18 - 26.12.18 - 00:34
(8) (9) (10) этот помощник перехода меняет ставку НДС в карточке номенклатуры и всё?
   Лодырь
 
20 - 26.12.18 - 04:15
(18) не только. Ещё договора и виды номенклатуры если память не подводит
   vis_tmp
 
21 - 26.12.18 - 04:45
(20)А там что?
   Azverin
 
22 - 26.12.18 - 09:45
(20) Нет там связи со ставкой НДС.
   shuhard
 
23 - 26.12.18 - 09:50
(22) конечно есть
   oslokot
 
24 - 26.12.18 - 09:58
(7) [i.    ЗаполнитьСписокВыбораСтавокНДС     2 точки изменения ]

Можно уточнить пару моментов?
1 точка - понятно, просто добавил в список выбора ндс20
2 точка - добавил в список выбора, но не понятно какое значение списка ставить для ставки НДС20_120?

(У НДС18_118 там единичка, а для НДС20_120 что чтавить?)
   Azverin
 
25 - 26.12.18 - 10:03
(23) какой? расскажите
   NorthWind
 
26 - 26.12.18 - 12:28
А в 114-м релизе встроен помощник перехода? Я что-то навскидку не вижу.
   ИС-2
 
27 - 26.12.18 - 12:33
что-то не понимаю. 1C забыли ставку НДС 20 добавить в эту функцию или в этом есть тайный смысл (тестирую печать чеков НДС20)
Функция ПолучитьСтавкуНДСДляФискализацииЧека(СтавкаНДС, ПорядокНалогообложения = "") Экспорт
    
    Если СтавкаНДС = ПредопределенноеЗначение("Перечисление.СтавкиНДС.БезНДС") 
        ИЛИ СтавкаНДС = ПредопределенноеЗначение("Перечисление.СтавкиНДС.ПустаяСсылка")
        ИЛИ ВРег(ПорядокНалогообложения) = "ЕНВД" Тогда
        Результат = "";
    ИначеЕсли СтавкаНДС = ПредопределенноеЗначение("Перечисление.СтавкиНДС.НДС10") Тогда
        Результат = 10;
    ИначеЕсли СтавкаНДС = ПредопределенноеЗначение("Перечисление.СтавкиНДС.НДС18") Тогда
        Результат = 18;
    ИначеЕсли СтавкаНДС = ПредопределенноеЗначение("Перечисление.СтавкиНДС.НДС10_110") Тогда
        Результат = 110;
    ИначеЕсли СтавкаНДС = ПредопределенноеЗначение("Перечисление.СтавкиНДС.НДС18_118") Тогда
        Результат = 118;
    КонецЕсли;
        
    Возврат Результат;
    
КонецФункции
   la luna llena
 
28 - 26.12.18 - 12:38
(27) я думаю, что забыли, выпустят исправление релиза
   NorthWind
 
29 - 26.12.18 - 12:41
(27) ну дык нечетный релиз же! :)
   zippygrill
 
30 - 26.12.18 - 12:47
(27) это в какой конфы?
   gantonio
 
31 - 26.12.18 - 13:00
(27) они за это по 2000 рублей собираются срубить.
   Serg_1960
 
32 - 26.12.18 - 13:13
(30) Не знаю как у автора, но так было в 113 (114-ый ещё не ставил). В 113-ом релизе много ещё где методисты "забыли" внести изменения.
   shuhard
 
33 - 26.12.18 - 13:15
(32) и верно не ставил
правильный будет 1.3.115 =)
 
 
   NorthWind
 
34 - 26.12.18 - 13:22
так что насчет помощника перехода на 20%? Или это только для новых конф (не для УПП)?
   Serg_1960
 
35 - 26.12.18 - 13:27
(34) Эээ... в УПП есть "Помощник замены ставки НДС на 20%" или Вы о чём-то другом?
   shuhard
 
36 - 26.12.18 - 13:38
(34) есть и не понятно, что тебе мешает отрыть конфигуратор и позырить
   Поток сознания
 
37 - 26.12.18 - 13:39
Порядок ставок изменен. Первая теперь 20%
   shuhard
 
38 - 26.12.18 - 13:40
(37) бред
   d4rkmesa
 
39 - 26.12.18 - 14:38
(37) Черт побери, опять в ККМ-оффлайн порядок ставок слетит во Фронтоле. =))
   NorthWind
 
40 - 26.12.18 - 14:44
(35),(36) мешало отсутствие точного названия. Теперь нашел в списке обработок в меню "Операции". Все получилось, спасибо
   Spieluhr
 
41 - 26.12.18 - 14:52
(27) Раньше в драйвер ККМ ставка 18% передавалась как 1800, теперь просто 18
   d4rkmesa
 
42 - 28.12.18 - 08:18
Кстати, обновились обработки обслуживания ATOLkkt.epf(под драйвер 10.4) и ShtrihMkkt.epf. Интересно, без обновления на 1.3.108 взлетит, с небольшими изменениями в виде ставок?
   shuhard
 
43 - 28.12.18 - 08:27
(42)1.3.108 = 1.3.115 ?
   NorthWind
 
44 - 28.12.18 - 08:46
Кстати - кто не видел - 114.2 вчера вывалили.
   d4rkmesa
 
45 - 28.12.18 - 08:54
(44) Что там поправили, не в курсе, случаем?
   Admin_Net_1C
 
46 - 28.12.18 - 09:22
(45) см. описание измененных объектов:

Версия 1.3.114.2        
 
Комментарий:    Исправление ошибки 00-00190106
Ошибка 1С при обновлении, при отсутствии записей в РС 
"ПрисоединенныеФайлы" для элемента справочника 
"ПакетЭДПрисоединенныеФайлы"        
 
Изменены:    Справочник.ПакетЭДПрисоединенныеФайлы
   d4rkmesa
 
47 - 28.12.18 - 09:31
(46) Спасибо. Руки не доходили еще скачать.
   ИС-2
 
48 - 29.12.18 - 08:13
(25) так не добавили НДС20 в ПолучитьСтавкуНДСДляФискализацииЧека ...

но в структуру параметров включили организацию и ТНВЭД


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует