Вход | Регистрация
 

Как найти по имени есть ли колонка в табличной части 1с управляем?

Как найти по имени есть ли колонка в табличной части 1с управляем?
Я
   gabd_marat
 
24.12.18 - 14:22
Как найти по имени есть ли колонка в табличной части 1с управляем?
 
 
   gabd_marat
 
1 - 24.12.18 - 14:23
Только перебором и выгрузкой табличной части в тз?
   gabd_marat
 
2 - 24.12.18 - 14:24
Пока ВыборкаЗапроса.Следующий() Цикл
        
        ВыборкаДетали = ВыборкаЗапроса.Выбрать();
        СтрокаТЧ = ТекущаяТаблицаОбработки.Добавить();
        Пока ВыборкаДетали.Следующий() Цикл
            
            СтрокаТЧ.Сотрудники = ВыборкаДетали.Сотрудник; 
            //Если ТекущаяТаблицаОбработки.Колонки.Найти(ВыборкаДетали.Участок) <> Неопределено Тогда  

                СтрокаТЧ[ВыборкаДетали.Участок] = ВыборкаДетали.Допуск;
            //КонецЕсли;

            
        КонецЦикла; 
        
    КонецЦикла;
   SUA
 
3 - 24.12.18 - 14:24
форма.объект.табчасть.колонки
примерно
   SUA
 
4 - 24.12.18 - 14:25
и что тут не так?
   gabd_marat
 
5 - 24.12.18 - 14:25
ТекущаяТаблицаОбработки = Объект.ОПРиСМП;
   gabd_marat
 
6 - 24.12.18 - 14:26
Ругается на метод колонки
   SUA
 
7 - 24.12.18 - 14:27
>>
Объект.ОПРиСМП

и ХЗЧ

>>СтрокаТЧ = ТекущаяТаблицаОбработки.Добавить();

а это тогда что?
   gabd_marat
 
8 - 24.12.18 - 14:28
(7) Это строка
   Mort
 
9 - 24.12.18 - 14:28
ПолучитьРеквизиты("Объект.Товары") чот вроде того
   gabd_marat
 
10 - 24.12.18 - 14:28
(7) У нее есть метод найти ?
   SUA
 
11 - 24.12.18 - 14:29
(8) это ответ
в строке нет колонок
   gabd_marat
 
12 - 24.12.18 - 14:31
Значит в табличной части в1с штатными методами не найти колонку? только в тз или обходить циклом?
   SUA
 
13 - 24.12.18 - 14:33
ОбщегоНазначения.ЕстьРеквизитИлиСвойствоОбъекта()
Если типовые
   СвинТуз
 
14 - 24.12.18 - 17:27
Попытка
ТекущаяТаблицаОбработки.Колонки.ДОбавить("ИмяРек");
Сообщить("Теперь есть колонка");
Исключение
Сообщить("Есть колонка");
КонецПопытки;

Шутка

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.