Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Вывод на печать 2 ТЗ

Вывод на печать 2 ТЗ
Я
   alexsandrinia
 
24.12.18 - 08:15
Как можно реализовать вывод на печать двух ТЗ с разным количеством строк? Платформа 8.2.
 
 
   shadow_sw
 
1 - 24.12.18 - 08:33
использовать разные макеты
   alexsandrinia
 
2 - 24.12.18 - 08:43
их потом в 1 можно объединить?
   shadow_sw
 
3 - 24.12.18 - 08:45
(2) если в один макет - два цикла, по двум ТЗ, е сли я правильно понимаю
   alexsandrinia
 
4 - 24.12.18 - 08:50
(3) я так и делаю, только у меня получается, что в первой таблице первые 3 строки заполнены, а оставшиеся 3 пустые. во второй таблице первые 3 строки пустые, а оставшиеся заполнены
   МимохожийОднако
 
5 - 24.12.18 - 09:01
(4) Не стесняйся. Сними со своего кода покровы тайны. Сюда выкладывай. Или включи отладчик и отследи алгоритмы по шагам.
   alexsandrinia
 
6 - 24.12.18 - 09:05
Для Индекс = 1 По Макс Цикл
    Если ТабличноеПоле_1.Количество() >= Индекс Тогда
        ОбластьМакета = МакетДокумента.ПолучитьОбласть("Область_Строка1");
        ОбластьМакета.Параметры.ФИО_1 = ТабличноеПоле_1[Индекс-1].КолонкаФИО;
        ТабДокумент.Вывести(ОбластьМакета);
    КонецЕсли;
КонецЦикла;
    
Для Индекс = 1 По Макс Цикл
    Если ТабличноеПоле_2.Количество() >= Индекс Тогда
        ОбластьМакета = МакетДокумента.ПолучитьОбласть("ОбластьНД_Строка1");
        ОбластьМакета.Параметры.ФИО_2 = ТабличноеПоле_2[Индекс-1].КолонкаФИО;
        ТабДокумент.Вывести(ОбластьМакета);
    КонецЕсли;
КонецЦикла;
   Базис
 
7 - 24.12.18 - 09:24
Эта бездушная тварь делает то, что сказано.
А не то, что нужно.

На бумажке в клеточку отладь это.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.