Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Помогите исправить ошибку {Обработка.ЖурналДокументовПродажи.Форма.КОформлениюНакладных.Фо

Помогите исправить ошибку {Обработка.ЖурналДокументовПродажи.Форма.КОформлениюНакладных.Фо
Я
   FFTeam
 
22.12.18 - 16:27
Здравствуйте!
После тестирования и исправления информационной базы возникла ошибка при открытии обработки "Накладные к оформлению" 1С УТ
Процедура ОбновитьТаблицуПлотностей(ТаблицаПлотностей,ТабНоменклатураЗаказа,Заказ)
    
    // ищем строки заказа в таблице плотностей, если не нашли, добавляем
    ПараметрыОтбора = Новый Структура("Заказ",Заказ);
    Для каждого СтрЗаказа Из ТабНоменклатураЗаказа Цикл
        Если СтрЗаказа.Заказ <> Заказ Тогда
            Продолжить;
        КонецЕсли;
        ПараметрыОтбора.Вставить("КодСтроки",СтрЗаказа.КодСтроки);
        СтрокиТабПлотностей = ТаблицаПлотностей.НайтиСтроки(ПараметрыОтбора);
        Если СтрокиТабПлотностей.Количество() = 0 Тогда
            СтрокаТабПлотностей = ТаблицаПлотностей.Добавить();
            ЗаполнитьЗначенияСвойств(СтрокаТабПлотностей,СтрЗаказа);
        Иначе
            Для Каждого ТекСтрокаПлотности Из СтрокиТабПлотностей Цикл
                ТекСтрокаПлотности.КодСтрокиНовый = СтрЗаказа.КодСтрокиНовый;
            КонецЦикла;
        КонецЕсли;
    КонецЦикла;
 
 
   FFTeam
 
1 - 22.12.18 - 16:27
ошибка:
{Обработка.ЖурналДокументовПродажи.Форма.КОформлениюНакладных.Форма(2582)}: Значение не является значением объектного типа (НайтиСтроки)
        СтрокиТабПлотностей = ТаблицаПлотностей.НайтиСтроки(ПараметрыОтбора);
   ДенисЧ
 
2 - 22.12.18 - 16:32
ЭлементыФОрмы.НайтиСтроки...
   Василий Алибабаевич
 
3 - 22.12.18 - 16:34
(2) Если я правильно понял ТС - все терки на управляемых формах. И там не будет "ЭлементыФормы". Скорее нужно искать через "Объект". Типа : Объект.ТаблицаПлотностей...
   mexanik_96
 
4 - 22.12.18 - 16:37
ТаблицаПлотностей=Неорпделено на входе? вангую проблема не здесь, смотри стек трейс
   FFTeam
 
5 - 23.12.18 - 06:16
Спасибо, тем, кто откликнулся, я не понял ничего, буду искать профессионалов

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.