Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

1C-сервер. Как удалить сеансы пользователей.

1C-сервер. Как удалить сеансы пользователей.
Я
   bvn-2005
 
21.12.18 - 07:52
Серверная 1С, БД - postgreSQL. На сервере 1С остаются висеть сеансы пользователей, хотя пользователи давно отключились. В обычной работе это не мешает, а, например, при выгрузке базы - мешает. Как АВТОМАТИЧЕСКИ удалить сеансы? Пока помогает только ручное удаление...
 
 
   МимохожийОднако
 
1 - 21.12.18 - 08:10
(0) Консоль Администрирования напрягает? Там секунд на 20 работы
   Kuzmich123
 
2 - 21.12.18 - 08:13
(1) Он про автоматически спрашивает.

(0) Некоторое время назад в зазеркалье была статья про программное управление сервером 1С. Думаю, нужно оттуда начать.
   Галахад
 
3 - 21.12.18 - 09:08
(0) 1С сервер на Винде?
   Smile 8D
 
4 - 21.12.18 - 09:13
(0) 1. Есть скрипты удаления пользователей
2. В последних версиях платформы есть механизмы управления сеансами из кода 1с
3. Можно настроить автоматическое отключение спящих сеансов (в панели администрирования 1с есть колонка "спящий", посмотрите стоит ли "да" у ваших сеансов). По умолчанию спящие сеансы удаляются через сутки. Можно уменьшить значение в настройках базы (там же в панели).
   МимохожийОднако
 
5 - 21.12.18 - 09:18
Если подобная ситуация возникает достаточно часто, то я бы предпринял не только технические, но и административные меры. Обрубание сеансов не лечение, а пластыри.
   МимохожийОднако
 
6 - 21.12.18 - 09:23
   PuhUfa
 
7 - 21.12.18 - 09:24
(0) можно настроить таймауты завершения сеансов, а можно программно выгонять всех
(4) почему в последних? это давно уже есть.

Например в одной базе у меня так:

    ТекущийНомерСеансаИнформационнойБазы = НомерСеансаИнформационнойБазы();
    
    СеансыИнформационнойБазы = ПолучитьСеансыИнформационнойБазы();
    Для Каждого СеансИБ Из СеансыИнформационнойБазы Цикл
        НачалоРаботы = СеансИБ.НачалоСеанса;
        Компьютер    = СеансИБ.ИмяКомпьютера;
        Сеанс        = СеансИБ.НомерСеанса;
        Соединение   = СеансИБ.НомерСоединения;
        
        Если Сеанс <> ТекущийНомерСеансаИнформационнойБазы Тогда
            
            Сообщение = "";
            Отключено = СоединенияИБКлиентСервер.ОтключитьСеанс(Сеанс, Сообщение);
            //Если НЕ ПустаяСтрока(Сообщение) и Не Отключено Тогда

            //    //Предупреждение(Сообщение);

            //КонецЕсли;

            
            Если НЕ Отключено Тогда
                ВсеОтключены = Ложь;
            КонецЕсли;
        КонецЕсли;
    КонецЦикла;


А в УТ 11 вот смотрю, там:

// Удаляет все сеансы информационной базы кроме текущего.

//
Процедура УдалитьВсеСеансыКромеТекущего(ПараметрыАдминистрирования) Экспорт
    
    ВсеКромеТекущего = Новый Структура;
    ВсеКромеТекущего.Вставить("Свойство", "Номер");
    ВсеКромеТекущего.Вставить("ВидСравнения", ВидСравнения.НеРавно);
    ВсеКромеТекущего.Вставить("Значение", СоединенияИБВызовСервера.НомерТекущегоСеанса());
    
    Фильтр = Новый Массив;
    Фильтр.Добавить(ВсеКромеТекущего);

    АдминистрированиеКластераКлиентСервер.УдалитьСеансыИнформационнойБазы(ПараметрыАдминистрирования,, Фильтр);
    
КонецПроцедуры

Видимо от версии БСП зависит
   Smile 8D
 
8 - 21.12.18 - 09:45
(7) Я говорю вот об этом https://wonderland.v8.1c.ru/blog/razvitie-klastera-serverov/
Появилось в 8.3.14

Список тем форума
Рекламное место пустует  Рекламное место пустует
Программист всегда исправляет последнюю ошибку.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.