Вход | Регистрация
 

Обмен между ЗУП3 и УПП

Обмен между ЗУП3 и УПП
Я
   Tamiko
 
18.12.18 - 07:00
Доброе утро, при обмене в документе реквизит Подразделение остается пустой, хотя передаю подразделение, для которого есть соответствие в базе приемнике (по коду и владельцу). Подскажите, пожалуйста, почему он не находится?
 
 
   Amra
 
1 - 18.12.18 - 07:03
Нам отсюда не видно, как передаешь
   Jofa
 
2 - 18.12.18 - 07:42
Вроде должны быть типовые правила?
   ИС-2
 
3 - 18.12.18 - 08:45
(2) нет типовых нету
   Tamiko
 
4 - 18.12.18 - 08:46
Нет, типовых правил нет.
Записывается в НачисленнаяЗарплатаИВзносы  точно ссылка на нужное подразделение
А  при чтении в СтрТЧ.ПодразделениеСсылка оказывается ссылка на сам документ, а не нужное подразделение.

    
НачисленнаяЗарплатаИВзносы    = Новый ТаблицаЗначений;
    ХР    = ПараметрыОбъекта.Получить("ТабЧасть_НачисленнаяЗарплатаИВзносы");
    
    Если ТипЗнч(ХР) = Тип("ХранилищеЗначения") Тогда
        
        НачисленнаяЗарплатаИВзносы    = ХР.Получить();
        Если ТипЗнч(НачисленнаяЗарплатаИВзносы) = Тип("ТаблицаЗначений") Тогда 
            НачисленнаяЗарплатаИВзносы.Колонки.Добавить("ПодразделениеСсылка");
            
            
            Для Каждого СтрТЧ Из НачисленнаяЗарплатаИВзносы Цикл
                Если ЗначениеЗаполнено(СтрТЧ.Подразделение) Тогда
                    ЧтениеСсылки    = Новый ЧтениеXML;
                    ЧтениеСсылки.УстановитьСтроку(СтрТЧ.Подразделение);
                    Если ЧтениеСсылки.Прочитать() Тогда
                        НппСсылки    = одАтрибут(ЧтениеСсылки, одТипЧисло, "Нпп");
                        Если ЗначениеЗаполнено(НппСсылки) Тогда
                            СтрТЧ.ПодразделениеСсылка = НайтиОбъектПоНомеру(НппСсылки);
                            
                        КонецЕсли;
                    КонецЕсли;
                КонецЕсли;
                
                
            КонецЦикла;
   Tamiko
 
5 - 18.12.18 - 08:54
Для Каждого СтрТЧ Из НачисленнаяЗарплатаИВзносы Цикл
                Если ЗначениеЗаполнено(СтрТЧ.Подразделение) Тогда
                    ЧтениеСсылки    = Новый ЧтениеXML;
                    ЧтениеСсылки.УстановитьСтроку(СтрТЧ.Подразделение); 
                    Сообщить("757 " + строка(СтрТЧ.Подразделение));

                    Если ЧтениеСсылки.Прочитать() Тогда
                        НппСсылки    = одАтрибут(ЧтениеСсылки, одТипЧисло, "Нпп");
                        Если ЗначениеЗаполнено(НппСсылки) Тогда
                            СтрТЧ.ПодразделениеСсылка = НайтиОбъектПоНомеру(НппСсылки);
                            Сообщить("777 " + строка(СтрТЧ.ПодразделениеСсылка));
                        КонецЕсли;
                    КонецЕсли;
                КонецЕсли;
                
                
            КонецЦикла;

!!! Вывод при загрузке:
757 <Ссылка Нпп="26" НеСоздаватьЕслиНеНайден="true">
    <Свойство Имя="{УникальныйИдентификатор}" Тип="Строка">
        <Значение>f31346db-d642-11e6-ad63-00155d007500</Значение>
    </Свойство><Свойство Имя="Владелец" Тип="СправочникСсылка.Организации"><Ссылка Нпп="2" НеСоздаватьЕслиНеНайден="true">
    <Свойство Имя="{УникальныйИдентификатор}" Тип="Строка">
        <Значение>b7a697d3-0717-11e8-82cc-0017318d8469</Значение>
    </Свойство>
    <Свойство Имя="ИНН" Тип="Строка">
        <Значение>5503170093</Значение>
    </Свойство>
    <Свойство Имя="Наименование" Тип="Строка">
        <Значение>ООО "ГЛАССПРОМ-СПК"</Значение>
    </Свойство>
</Ссылка>
</Свойство>
    <Свойство Имя="Код" Тип="Строка">
        <Значение>ПГ-000005</Значение>
    </Свойство>
</Ссылка>
777 Отражение зарплаты в регл учете ОТК-000011 от 30.11.2018 12:00:00

Как такое может быть, было подразделение, стал документ????!!!
   Tamiko
 
6 - 18.12.18 - 09:04
Помогите, пожалуйста, разобраться, как может быть такой сбой при загрузке, второй день бьюсь....

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует