Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

1С 8 3 УТП - при чтении файла Excel на одном компе вс' ок, на другом - возникает ошибка ((

1С 8 3 УТП - при чтении файла Excel на одном компе вс' ок, на другом - возникает ошибка ((
Я
   Nysha1210
 
17.12.18 - 12:38
Добрый день.
Дома написала программу по чтению и обработе Эксель файла. Всё работало норм. После запуска єтой же программі на работе - выдаёт ошибку "Ошибка при открытии файла с помощью Excel! Загрузка не будет произведена!
{Обработка.ЗагрузкаОстаткиЦены.Форма.Форма.Форма(6)}: Error calling constructor (COMОбъект): -2147221005(0x800401F3): Недопустимая строка с указанием класса
".

Попытка
        Excel = Новый COMОбъект("Excel.Application");
        Excel.WorkBooks.Open(ИмяФайла);
        Состояние("Обработка файла Microsoft Excel...");
    Исключение
        Сообщить("Ошибка при открытии файла с помощью Excel! Загрузка не будет произведена!");
        Сообщить(ОписаниеОшибки());
    Возврат;
    КонецПопытки;
В чём может быть проблема? Спасибо
 
 
   MaxS
 
1 - 17.12.18 - 12:39
1С может читать файлы не используя Excel.
   shuhard
 
2 - 17.12.18 - 12:40
(0) бяда
   Nysha1210
 
3 - 17.12.18 - 12:42
Как переделать код? Спасибо.
   tesseract
 
4 - 17.12.18 - 12:55
(3) Тд = Новый ТабличныйДокумент();
Тд.Открыть(ИмяФайла);
   Nysha1210
 
5 - 17.12.18 - 12:57
Как тогда выглядит строка : Excel.Cells(ТекСтрока, 26).Value?
   dka80
 
6 - 17.12.18 - 13:00
СокрЛП(ТД.Область(ТекСтрока, 26, ТекСтрока, 26).Текст)
   Nysha1210
 
7 - 17.12.18 - 13:03
Тд = Новый ТабличныйДокумент();
Тд.Открыть(ИмяФайла);

не работает, не найден метод "Открыть"
   dka80
 
8 - 17.12.18 - 13:10
Тд.Прочитать(ИмяФайла);
   Nysha1210
 
9 - 17.12.18 - 13:11
пробовала - тоже ругается (((
   Nysha1210
 
10 - 17.12.18 - 13:12
Тд = Новый ТабличныйДокумент();
Тд.Прочитать(ИмяФайла);

не работает, не найден метод "Прочитать", тоже самое и с ПрочитатьФайл и ОткрытьФайл ((((
   dka80
 
11 - 17.12.18 - 13:13
Доступность:

Сервер, толстый клиент, внешнее соединение, мобильное приложение(сервер).
   Chameleon1980
 
12 - 17.12.18 - 13:14
(11) ++
   dka80
 
13 - 17.12.18 - 13:15
&НаКлиенте
Процедура ПрочитатьФайл(Команда)
    
    Оп = Новый ОписаниеОповещения("НачатьПомещениеФайлаОкончание", ЭтотОбъект);
    Сообщить("Начало чтения: " + ТекущаяДата());
     АдресВременногоХранилища = "";
    НачатьПомещениеФайла(Оп, АдресВременногоХранилища, ПутьКФайлу,Ложь, ЭтаФорма.УникальныйИдентификатор);
     
    
КонецПроцедуры

&НаКлиенте
Процедура НачатьПомещениеФайлаОкончание(Результат, АдресВременногоХранилища, ВыбранноеИмяФайла, ДополнительныеПараметры) Экспорт
    
    
    Если Прав(ПутьКФайлу, 4) = ".xls" Тогда
        Объект.РасширениеФайла = "xls"
    Иначе
        Объект.РасширениеФайла = "xlsx"
    КонецЕсли;
    ПрочитатьФайлНаСервере(АдресВременногоХранилища);
    Сообщить("Окончание чтения: " + ТекущаяДата());

КонецПроцедуры


&НаСервере
Процедура ПрочитатьФайлНаСервере(АдресВременногоХранилища)
    
    ДвоичныеДанные = ПолучитьИзВременногоХранилища(АдресВременногоХранилища);
    ИмяВременногоФайла = ПолучитьИмяВременногоФайла(Объект.РасширениеФайла);
    ДвоичныеДанные.Записать(ИмяВременногоФайла);
    
    ИмяТД = Сред(Элементы.Страницы.ТекущаяСтраница.Имя, 9);
    ТД = ЭтаФорма[ИмяТД];
    Попытка
        ТД.Прочитать(ИмяВременногоФайла);
        УдалитьФайлы(ИмяВременногоФайла);
    Исключение
        Сообщить(ОписаниеОшибки());
    КонецПопытки;
    
КонецПроцедуры
   dka80
 
14 - 17.12.18 - 13:15
+13 под свою задачу немного подпили
   Nysha1210
 
15 - 17.12.18 - 13:16
ОК, спс сейчас попробую.
   dka80
 
16 - 17.12.18 - 13:16
ну и к (0): возможно у тебя эксель не стоит на СЕРВЕРЕ, возможно, эксель стоит, но ниже версии ПРОФ (тогда он COM не поддерживает)
   Nysha1210
 
17 - 17.12.18 - 13:20
У меня пока на Сервере базы нет, так что делаю разработку у себя на компе, база в файловом варианте. Excel на компе не стоит - пользуемся Libre Office
   Nysha1210
 
18 - 17.12.18 - 13:21
Что дома стоит - не помню
   dka80
 
19 - 17.12.18 - 13:22
(17) ха ха ха. Тогда как ты хочешь создать объект эксель, если у тебя нет эксель?
Тогда делай как в (13)
   Nysha1210
 
20 - 17.12.18 - 13:29
Как-то не сообразила (((

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.