Вход | Регистрация
 

Передача результата выборки между клиентом и сервером

Передача результата выборки между клиентом и сервером
Я
   TolstiyBeremenniy
 
17.12.18 - 11:41
Выполняю на сервере запрос. Получаю выборку.
Подскажите как мне передать её на клиент?
 
 
   Alexandr_U1982
 
1 - 17.12.18 - 11:42
Никак. Что хотел делать с выборной на клиенте?
   TolstiyBeremenniy
 
2 - 17.12.18 - 11:43
(1) Добавлять в список поля выбора формы.
   TolstiyBeremenniy
 
3 - 17.12.18 - 11:44
(1) Как тогда это сделать?????
   Alexandr_U1982
 
4 - 17.12.18 - 11:44
Массив передай
   TolstiyBeremenniy
 
5 - 17.12.18 - 11:46
(4) На массив тоже ругается.
   Alexandr_U1982
 
6 - 17.12.18 - 11:47
(5)Заполни список выбора на сервере.

Расширение поля формы для поля ввода (Form field extension for a text box)
СписокВыбора (ChoiceList)
Использование:

Только чтение.
Описание:

Тип: СписокЗначений.
Содержит список значений для осуществления выбора по нажатию кнопки списка выбора.

Доступность:

Тонкий клиент, веб-клиент, мобильный клиент, сервер, толстый клиент, мобильное приложение(клиент), мобильное приложение(сервер).
Примечание:

Изменение состава списка на клиенте не требует обращения к серверу.
   TolstiyBeremenniy
 
7 - 17.12.18 - 11:58
(6) Данные, выборку я же могу получить только на сервере.
   TolstiyBeremenniy
 
8 - 17.12.18 - 11:59
(6) Как я вот это могу получить на клиенте????

    Запрос      = Новый Запрос;
    Запрос.Текст = "
        |ВЫБРАТЬ
        |    ПродуктыНаСкладахОстатки.Номенклатура      КАК Номенклатура,
        |    ПродуктыНаСкладахОстатки.Партия            КАК Партия,
        |    ПродуктыНаСкладахОстатки.КоличествоОстаток КАК Остаток,
        |    ПродуктыНаСкладахОстатки.ЦенаОстаток       КАК Цена
        |ИЗ
        |    РегистрНакопления.ПродуктыНаСкладах.Остатки(, Номенклатура = &Номенклатура) КАК ПродуктыНаСкладахОстатки
        |
        |УПОРЯДОЧИТЬ ПО
        |    Партия";
   Timon1405
 
9 - 17.12.18 - 12:02
(0)
Функция ТаблицаЗначенийВМассив(ТаблицаЗначений) Экспорт
    
    Массив = Новый Массив();
    СтруктураСтрокой = "";
    НужнаЗапятая = Ложь;
    Для Каждого Колонка Из ТаблицаЗначений.Колонки Цикл
        Если НужнаЗапятая Тогда
            СтруктураСтрокой = СтруктураСтрокой + ",";
        КонецЕсли;
        СтруктураСтрокой = СтруктураСтрокой + Колонка.Имя;
        НужнаЗапятая = Истина;
    КонецЦикла;
    Для Каждого Строка Из ТаблицаЗначений Цикл
        НоваяСтрока = Новый Структура(СтруктураСтрокой);
        ЗаполнитьЗначенияСвойств(НоваяСтрока, Строка);
        Массив.Добавить(НоваяСтрока);
    КонецЦикла;
    Возврат Массив;

КонецФункции
   FIXXXL
 
10 - 17.12.18 - 12:02
(2) добавляй НаСервере
   Вафель
 
11 - 17.12.18 - 12:05
во временное хранилище положить
   Alexandr_U1982
 
12 - 17.12.18 - 12:07
(8) Никак.
Если ты вызываешь серверную функцию без контекста, то формируй на сервере массив структур и возвращай его на клиент, на клиенте заполняй список выбора.
Если у тебя контекстный вызов (на сервере существует вся форма), то список выбора заполняй на сервере.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.