Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Ошибка при групповом перепроведении

Ошибка при групповом перепроведении
Я
   KindLion
 
17.12.18 - 11:31
Воюю с сильно измененной БП - 3.0
При групповом перепроведении выдает ошибку при записи документа "Корректировка реализации".
Провожу этот документ руками - ошибки нет.

Подскажите - где копать? Сам не допру.
Ставлю в отладке "останавливаться по ошибке" - не останавливается ни при групповом проведении, ни при ручном.
Правда, в начале группового перепроведения останавливается по ошибке закрытия месяца. В ручном - все закрытие проводит.
 
 
   Галахад
 
1 - 17.12.18 - 11:38
ЖР, что-нибудь полезно говорит?
   KindLion
 
2 - 17.12.18 - 11:57
(1) Увы. Ничего полезного.
"Ошибка при записи документа. В этой транзакции уже были ошибки". - Стандартная отмаза.
   dka80
 
3 - 17.12.18 - 12:15
(2) отмазка не стандартная, а говорящая о неправильности архитектуры модулей документа.
   dka80
 
4 - 17.12.18 - 12:17
Напиши простейший код и выполни его в режиме отладки

Выборка = Документы.ТвойДокумент.Выбрать(началопериода, конецпериода);
Пока выборка.следующий() Цикл
Если Выборка.Проведен Тогда
Док = Выборка.ПолучитьОбъект();
Док.Записать(РежимЗаписи.проведение);
КонецЕсли;
КонецЦикла;
   KindLion
 
5 - 17.12.18 - 12:26
(4) Спасибо огромное. Попробую.
Вполне вероятно, что архитектура модулей не верна. Что бы это ни значило. :)
   dka80
 
6 - 17.12.18 - 12:38
(5) Например, у тебя в обработке проведения написано (а в обработка проведения, как мы знаем, выполняется в транзакции):

Попытка
твой код
вызвать твою процедуру
исключение
конецпопытки
Процедура ТвояПроцедура()
Попытка
Твойкод
Исключение
КонецПопытки
КонецПроцедуры

Так вот, если возникнет исключительная ошибка в твоейПроцедуре, а потом возникнет исключительная ошибка в конструкции Попытка процедуры обработки проведения, то возникнет именно такая ошибка, которую сейчас тебе пишет программа
   KindLion
 
7 - 11.01.19 - 16:56
(4) Здравствуйте, тезка!

Вынужден поднять тему.
При групповом перепроведении - ошибка:
Обработка Возврат товаров от покупателя PO000001715 от 02.07.2018 0:00:00 не выполнена по причине:
{Обработка.ГрупповоеПерепроведениеДокументов.МодульМенеджера(1990)}: Ошибка при вызове метода контекста (Записать): В данной транзакции уже происходили ошибки!

В ручном режиме, или с помощью обработки, что вы предложили - проводится на ура.

В чем может быть причина?..

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует