Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Переход ЗУП с 2.5 на 3.1

Переход ЗУП с 2.5 на 3.1
Я
   Neron49
 
14.12.18 - 19:32
Здравствуйте.
Я нуб в 1С. Меня взяли на производственную практику в одну фирму.
Суть в том, что есть ЗУП версии 2.5;
И одновременно с этим стоит ЗУП 3.1, которую поставил другой человек в марте и перенёс туда базу данных, и которой не пользовались вообще, ничего не заполняли;
Но эта 3.1 работает некорректно, особенно когда надо сформировать какой-нибудь отчёт вроде 2-НДФЛ и т.д. Потому что перенесено не всё, как я понял;

Возможно ли будет в ЗУП 2.5 сдать 2-НДФЛ по новой форме в 2019 году?
На официальном сайте, где обновления форм отчётов, пишут, что для 2.5: "обновление не требуется" Что это значит?
http://v8.1c.ru/lawmonitor/lawchanges.jsp?regReportOnly=true¤tYear=2018

Как лучше и наиболее полно перенести данные из 2.5 в 3.1 с наименьшим риском?
 
 
   Доминошник
 
1 - 14.12.18 - 19:43
(0) Я первый предложу позвать специалиста?

И да - на ЗУП 2.5 сдать 2-НДФЛ за 2018 год "просто так" - нельзя.
http://1c.ru/news/info.jsp?id=23891
   VitShvets
 
2 - 14.12.18 - 20:14
(0) + к (1) В сааамом низу ссылки есть ещё вариант. Можно  перейти на ЗУП 2.5 Корп, это может быть проще, но требует покупки лицензии ЗУП КОРП за 109 000 руб.
   d4rkmesa
 
3 - 14.12.18 - 20:21
(0) Беги оттуда, глупец. Изучайте лучше Javascript или Python.
   d4rkmesa
 
4 - 14.12.18 - 20:26
(0) Если по теме, то ЗУП 3.1 лучше развернуть заново и загрузить туда данные. Что касается 2НДФЛ в ЗУП 2.5... Если есть лицензия на Комплексную, можно, когда появится подходящий релиз(1.1.110), дернуть то что нужно оттуда. Если есть желание испортить себе новогодние выходные, можно попробовать.
   d4rkmesa
 
5 - 14.12.18 - 20:30
(4) Если фирма небольшая, скажем, до 100 человек, можно просто загрузить данные в новый ЗУП и оставить их с этим разбираться в 2019 году. Как показывает практика, при таких объемах перейти труда не составляет, как правило. В любом случае, как практикант вы там никому ничему не должны.
   Фрэнки
 
6 - 17.12.18 - 10:40
Вопрос по поводу перехода - чтоб не создавать новую ветку

Смотрю видео, где рассказывают о том. как переходить.

https://its.1c.ru/video/lector20181213-1

Не запомнил на какой минуте, но там четко видно и много раз повторялось лектором, что надо делать перенос через выгрузку в файл. Отличная идея, мне понравилась.
Однако, выгрузка в файлы возможна помощником, который не совместим с версией 2.5.130.2 и требует версию 2.5.134

Ну и где эту версию брать-то простому гражданину?!
   Amra
 
7 - 17.12.18 - 10:43
(6) 2.5.134 - только КОРП. ПРОфовцы должны были перйти год назад, тем функционалом что был
   d4rkmesa
 
8 - 17.12.18 - 10:46
(6) В помощнике вообще то:

Функция ВерсииПравил()
    КонфигурацияИсточникДанных();
    ВерсииПравил = Новый Структура;
    ВерсииПравил.Вставить(мЗУП,        "2.5.130.2");
    ВерсииПравил.Вставить(мЗУПКОРП,    "2.5.134.1");
    ВерсииПравил.Вставить(мЗБУ,        "1.0.121.2");
    ВерсииПравил.Вставить(мМЗКБУ,    "1.0.121.2");    
    Возврат ВерсииПравил;
КонецФункции

Или в новой версии все поменялось?
   Фрэнки
 
9 - 17.12.18 - 10:57
Ну вот я в наглую попробовал что сделать:
поправил ручками в ЗУП (обычной) на 2.5.134.1 и стал запускать выгрузку. Ну и ... полезли ошибки. Т.е. в 2.5.134.1 есть измененные метаданные, которые в правилах описаны.

КОРП не подставлял. Но я бы ничему не удивился, если бы лектор не пропихивал пользователям этот перенос.

(8) Версии правил для выгрузки в файлы или как?
   d4rkmesa
 
10 - 17.12.18 - 11:30
(9) Это из обработки ПомощникВыгрузки_V8.epf, правила там вроде одни, но в некоторых местах специфично для версии алгоритмы работают. А вы точно уверены, что ошибки с этим связаны? По идее то все должно работать с 2.5.130.2, если не работает - явно ошибка, а не фича.
   Фрэнки
 
11 - 17.12.18 - 11:56
(10) просто я нарочно сейчас перепроверил, что этот помощник доступен только если обновиться до 3.1.8.х
   Фрэнки
 
12 - 17.12.18 - 12:03
(10) и сразу после запуска ее в базе Источнике - горит красным надпись, что должна быть версия 2.5.134.1

Может в самом деле просто баг словили и получится подравить код, чтоб прошла выгрузка
   Фрэнки
 
13 - 17.12.18 - 12:53
Нашел в чем баг - кто-то давно-давно воткнул самостоятельно документ с совпадением имени метаданных. УченическийДоговор
---
Функция КонфигурацияИсточникДанных() Экспорт
    
    Если КонфигурацияИсточникДанных = Неопределено Тогда
        
        мЗУП = "ЗУП";
        мЗУПКОРП = "ЗУПКОРП";
        мЗБУ = "ЗБУ";
        мМЗКБУ = "МЗКБУ";
        
        КонфигурацияИсточникДанных = "ЗУП";
        Если Метаданные.Документы.Найти("а_ПриказПоПодработкамИДоплатам") <> Неопределено Тогда
            КонфигурацияИсточникДанных = "МЗКБУ";
        ИначеЕсли Метаданные.Перечисления.Найти("ОтношениеКДенежномуСодержанию") <> Неопределено Тогда
            КонфигурацияИсточникДанных = "ЗБУ";
        //ИначеЕсли Метаданные.Документы.Найти("УченическийДоговор") <> Неопределено Тогда

        //    КонфигурацияИсточникДанных = "ЗУПКОРП";

        ИначеЕсли Метаданные.Перечисления.Найти("ОсновныеНачисленияРаботниковОрганизаций") <> Неопределено Тогда
            КонфигурацияИсточникДанных = "ЗУП";
        КонецЕсли;
        
    КонецЕсли;    
    
    Возврат КонфигурацияИсточникДанных; 
    
КонецФункции

Закомментировал пару строк - буду дальше пробовать
   d4rkmesa
 
14 - 17.12.18 - 12:59
(13) Код, конечно, охренеть в помощнике. =))
   timurhv
 
15 - 17.12.18 - 13:03
(0) Сколько сотрудников в организации? Мне просто интересно что за финт ушами? Данные перенесли, пролюбили 9 месяцев, взяли на практику человека без опыта...скупердяи\хитропопые
   kzot
 
16 - 17.12.18 - 13:15
(15) Писано же, нуб на практике. Может он просто там красивым помогает. )

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.