Вход | Регистрация
 

Передача ИНН кассира в ОФД

Передача ИНН кассира в ОФД
Я
   kupec
 
14.12.18 - 10:19
Всем доброго дня. Имеется вот такой код

FR.Password=ПарольКассира;
FR.CheckType=0;
FR.OpenCheck();
FR.Password=ПарольКассира;
FR.TagNumber = 1203;
FR.TagType = 7;
FR.TagValueStr = СокрЛП(Кассир.ИНН);
FR.FNSendTag();
//строка продажи фискальная
FR.Password=ПарольКассира;
FR.Quantity=ПлатноеКоличество;
FR.Price=ЦенаПокупателя;                  
FR.PaymentItemSign=ОпределитьПризнакПредметаРасчета();
FR.PaymentTypeSign=4;
FR.StringForPrinting=Товар;
FR.Department=1;
FR.FNOperation();
FR.Password=ПарольКассира;
FR.Summ1=Оплата;                            
FR.StringForPrinting="";
FR.FNCloseCheckEX();

Чек попадает в ОФД, но почему то информация о ИНН кассира не отображается в электронном виде чека на сайте ОФД. ОФД Такском. Что не так с тегом? Может я не правильно его передаю? В ответе драйвера после передачи тега ошибок нет.
 
 
   Масянька
 
1 - 14.12.18 - 10:20
(0) В поиск. Недавно была похожая ветка.
   kupec
 
2 - 14.12.18 - 10:23
(1) там для АТОЛа, а по поводу ШТРИХа сказали Вы по ним мастер, может есть какие то мысли по моей проблеме?
   Масянька
 
3 - 14.12.18 - 10:24
(2) Если бы ты читал ту ветку, то понял бы, что дело не в штрихах и атолах.
   d4rkmesa
 
4 - 14.12.18 - 10:24
(0) Конфигурация то какая?
   kupec
 
5 - 14.12.18 - 10:26
(4) своя
   kupec
 
6 - 14.12.18 - 10:26
   kupec
 
7 - 14.12.18 - 10:30
Запросил через тест драйвера документ в виде строки, там ИНН есть, а в ОФД почему то нет
   d4rkmesa
 
8 - 14.12.18 - 10:31
(5) Ну ок, своя, что у вас там, прямая работа через драйвер вендора, БПО, подсистема "Торговое оборудование" из УТ10/КА1.1/УПП1.3 ?
   kupec
 
9 - 14.12.18 - 10:33
(8) работа через драйвер, 1С7.7, пример кода в шапке
   d4rkmesa
 
10 - 14.12.18 - 10:35
(7) Если Штрих, прочитайте содержимое фискального документа:
https://forum.shtrih-m-partners.ru/index.php?topic=32351.0
Если там все ок, нужно теребить ОФД.
 
 Рекламное место пустует
   kupec
 
11 - 14.12.18 - 10:37
(10) я это проделал, в тесте драйвера все ОК, инн есть, вчера спрашивал у такскома в поддержке, сказали что они данные такого типа не получают от кассы, сказали что дело с моей стороны
   kupec
 
12 - 14.12.18 - 10:48
(3) в чем в итоге дело? Я не нашел такой информации
   d4rkmesa
 
13 - 14.12.18 - 12:39
(11) Что техподдержка написала, какой-то пруф был с их стороны? Написали какой тэг/атрибут не заполнен? Не, ну можно, конечно, еще трафик при отправке чека помониторить, отловить запрос, но по-моему это уже дурная затея. Пинайте дальше.
   NikeArz
 
14 - 14.12.18 - 13:12
(0) Вы используете передачу ИНН кассира в теле опреации. Попробуйте вынести из тела операции в тело чека.

FR.Password=ПарольКассира;
FR.CheckType=0;
FR.OpenCheck();
//строка продажи фискальная


FR.Password=ПарольКассира;
FR.Quantity=ПлатноеКоличество;
FR.Price=ЦенаПокупателя;                   
FR.PaymentItemSign=ОпределитьПризнакПредметаРасчета();
FR.PaymentTypeSign=4;
FR.StringForPrinting=Товар;
FR.Department=1;
FR.FNOperation();

FR.Password=ПарольКассира;
FR.TagNumber = 1203;
FR.TagType = 7;
FR.TagValueStr = СокрЛП(Кассир.ИНН);
FR.FNSendTag();

FR.Password=ПарольКассира;
FR.Summ1=Оплата;                             
FR.StringForPrinting="";
FR.FNCloseCheckEX();
   kupec
 
15 - 14.12.18 - 13:42
(13) техподдержка ответила следующее.

Благодарю за обращение и предоставленную информацию.



В фискальном документе с ФПД 0166538498 имеется реквизит 1208 (ИНН Кассира) и его значение равно 3ххххххх0475

На вопрос, почему нет информации на сайте, они пока молчат
   d4rkmesa
 
16 - 14.12.18 - 13:46
(15) Ну то что на сайте нет - это, в сущности, ерунда. У Астрала просмотр чеков через сайт отваливается через раз. Главное, что в ОФД все данные есть.
   d4rkmesa
 
17 - 14.12.18 - 13:47
(16) Астрал для примера привел.
   kupec
 
18 - 14.12.18 - 13:47
(14) я пытался сделать так, результат тот же
   kupec
 
19 - 14.12.18 - 13:48
В общем буду ждать результат от поддержки ОФД
   Kigo_Kigo
 
20 - 14.12.18 - 14:36
(19) Отписаться не забудь, тоже штрихи и тоже такском, на сл неделе буду дописывать тег ИНН кассира, кстати, про емайл и смс кто делал, работает? реально на почту приходит или смс? а то у меня после вот этого кода только пичет в чеке емаил или номер телефона в чеке, но на почту и смс не приходит, как это вообще должно работать?
КорректноКудаОтправитьЧек = -1//-1 не ввден, 1- корректно,0 не корректно

    Если ПустоеЗначение(КудаОтправитьЧек) = 0 Тогда 
        Если Найти(СокрЛП(КудаОтправитьЧек),"@") <> 0 Тогда
            КорректноКудаОтправитьЧек = 1;
        ИначеЕсли Лев(СокрЛП(КудаОтправитьЧек),2) = "+7" Тогда
            КорректноКудаОтправитьЧек = 1;
        Иначе
            КорректноКудаОтправитьЧек = 0;
            Если Вопрос("Не корректно введен email или номер телефона клиента, пробить обычный чек?",4) = 6 Тогда
                КорректноКудаОтправитьЧек = -1;
            Иначе
                Предупреждение("Проверте  email или номер телефона клиента, номер телефона должен начинаться на +7");
                Возврат 0;    
            КонецЕсли;
            
        КонецЕсли;
    КонецЕсли;
    

Если ПустоеЗначение(КудаОтправитьЧек) = 0 Тогда
        Объект.CustomerEmail  = СокрЛП(КудаОтправитьЧек);
        Объект.FNSendCustomerEmail();
        
    КонецЕсли;


   kupec
 
21 - 14.12.18 - 15:06
(20) я делал и СМС и MAIL все уходит и приходят электронные версии чеков, главное адрес передавать в драйвер после команды открытия чека
   kupec
 
22 - 14.12.18 - 15:07
(20) кстати СМС отправляется при оплаченном СМС пакете у оператора фискальных данных
   Kigo_Kigo
 
23 - 14.12.18 - 15:10
(21) Этой командой?
Объект.CustomerEmail  = СокрЛП(КудаОтправитьЧек);
Объект.FNSendCustomerEmail();

в ККТ какие то особые настройки нужны?
   kupec
 
24 - 14.12.18 - 15:11
(23) да этой, в ККМ ничего не настраивал, как её с ЦТО мне отдали в таком виде и работает
   Kigo_Kigo
 
25 - 14.12.18 - 15:11
(22) ТО есть еще ОФД надо и за пакет СМС платить?
   Масянька
 
26 - 14.12.18 - 15:12
(25) Приплыли... А ты думал бесплатно?
   Kigo_Kigo
 
27 - 14.12.18 - 15:12
(24) А в чеке печатает email покупателя: ххх@ххх.хх ?
У меня печатает, но на мыло ничего не приходит
   Kigo_Kigo
 
28 - 14.12.18 - 15:14
(26) есть плата за годовое обслуживание и если закон требует иметь возможность отправки СМС и возлагает его на ОФД, то ОФД обязано обеспечить эту возможность за оговоренную с ней абонентскую плату, не?
   Kigo_Kigo
 
29 - 14.12.18 - 15:16
(28) или давать кокой то базовый пакет, к примеру 100 смс в месяц
   Масянька
 
30 - 14.12.18 - 15:16
(28) Не.
Всего очень демократично: любой каприз за Ваши деньги. (С)
Кстати, по поводу мыла - узнавай у своего ОФД. Тоже может идти отдельным пакетом.
   Масянька
 
31 - 14.12.18 - 15:17
(29) Прошивки (изменения закон-ства) тоже должны быть бесплатны.
Не?
   kupec
 
32 - 14.12.18 - 15:17
(30) у него такском. Там бесплатно
   kupec
 
33 - 14.12.18 - 15:20
(27) только что проверил отправку чека на мыло. Все пришло моментально
 
 
   Kigo_Kigo
 
34 - 14.12.18 - 15:21
(31) Должны, но сча прецедентов пока нет, а вот если кокой нить агрегатор полезет в суд и ФАС трещать будет у всех
   Kigo_Kigo
 
35 - 14.12.18 - 15:23
(33) будем проверять. спс
   Kigo_Kigo
 
36 - 14.12.18 - 15:25
(33) Стати я его отправляю перед закрытием чека, но в чеке то печатается, может тут опять какая то неведомая определенная последовательность?
   Масянька
 
37 - 14.12.18 - 15:25
(34) Ха (3 раза).
Значит, 1С имеет право брать за обновления бабки, а производители касс нет?
   kupec
 
38 - 14.12.18 - 15:26
(36) у меня сразу после открытия чека идет передача адреса
   Масянька
 
39 - 14.12.18 - 15:30
(36) В ЦТО сказали - в любом месте от открытия до закрытия. Главное, чек должен быть открыт.
Не проверяла.
   kupec
 
40 - 14.12.18 - 15:34
Ответ от поддержки ОФД

В сервисе «Такском-Касса» электронный чек отображается только в обычной форме.



Есть ли у Вас еще какие-нибудь вопросы?
   Kigo_Kigo
 
41 - 14.12.18 - 15:53
(40) А это как ?
   kupec
 
42 - 14.12.18 - 15:55
(41) ну я так понял, что в сокращенном варианте
   NikeArz
 
43 - 14.12.18 - 17:00
(15) Запроси из тест драйвера информацию по номеру ФД из ФН и посмотри, если ИНН кассира есть, тогда возможно проблема ОФД.
   hhhh
 
44 - 14.12.18 - 17:05
(42) ну инн этот пока необязательный параметр, поэтому имеют право не включать.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует