Вход | Регистрация
 

Активировать поле ввода в Мобильном приложении 1С

Активировать поле ввода в Мобильном приложении 1С
Я
   Nik_Zzz
 
13.12.18 - 13:40
Проблема в активизации поля ввода.
Делаю так, при открытии:
    ЭтаФорма.ТекущийЭлемент = Элементы.ПолеВвода1;
    #Если МобильноеПриложениеКлиент Тогда
    ЭтаФорма.НачатьРедактированиеЭлемента();
    #КонецЕсли
Все работает, но когда активирую другое поле, а потом заново ПолеВвода1, активизация не  срабатывает , хотя тот же код прописан  в событии при изменении
 
 
   Nik_Zzz
 
1 - 14.12.18 - 08:01
Может надо как то форму обновлять ?
   Cyberhawk
 
2 - 14.12.18 - 08:19
#Если МобильноеПриложениеКлиент Тогда

        ПодключитьОбработчикОжидания("НачатьРедактированиеТекущегоЭлемента", 0.1, Истина);
    #КонецЕсли 

    
КонецПроцедуры

#Если МобильноеПриложениеКлиент Тогда

&НаКлиенте
Процедура НачатьРедактированиеТекущегоЭлемента()
    
    ЭтотОбъект.НачатьРедактированиеЭлемента();
    
КонецПроцедуры
#КонецЕсли
   Cyberhawk
 
3 - 14.12.18 - 08:20
Кусок первого метода - это ПриОткрытии
   Nik_Zzz
 
4 - 14.12.18 - 10:07
(3) При открытии работает и так все замечательно , до того момента пока я не переведу курсор в другое поле ввода и обратно, в то которое должно быть изначально.
После этого данная конструкция не отрабатывает как прежде
   Nik_Zzz
 
5 - 14.12.18 - 11:13
написал так :

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    #Если МобильноеПриложениеКлиент Тогда

        ПодключитьОбработчикОжидания("НачатьРедактированиеТекущегоЭлемента", 0.1, Истина);
    #КонецЕсли 

КонецПроцедуры

&НаКлиенте
Процедура НачатьРедактированиеТекущегоЭлемента()
     ЭтотОбъект.НачатьРедактированиеЭлемента();
     #Если МобильноеПриложениеКлиент Тогда

    ЭтаФорма.НачатьРедактированиеЭлемента(); 
#КонецЕсли


 КонецПроцедуры

но почему-то не срабатывает(
   Вафель
 
6 - 14.12.18 - 11:22
А зачем так
     ЭтотОбъект.НачатьРедактированиеЭлемента();
     #Если МобильноеПриложениеКлиент Тогда
    ЭтаФорма.НачатьРедактированиеЭлемента();
#КонецЕсли 

если можно просто так
ЭтаФорма.НачатьРедактированиеЭлемента();

   Nik_Zzz
 
7 - 14.12.18 - 11:28
(6) Описался , да ,достаточно одного раза.
Но сути это не меняет , почему то поле не активируется.
Если что я сохраняю конфу в моб. приложение (xml).
И потом собираю конфигурацией сборщик мобильных приложений 1с , в apk
   Nik_Zzz
 
8 - 14.12.18 - 14:00
(2) ПодключитьОбработчикОжидания("НачатьРедактированиеТекущегоЭлемента", 1, ложь); 
и норм.
спасибо!
   Cyberhawk
 
9 - 23.12.18 - 11:04
Это ты не норм, это ты УГ какое-то каждосекундное сделал

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует