Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Работа с метаданными

Работа с метаданными
Я
   demiurggig
 
13.12.18 - 13:16
Есть документ, я перебираю реквизиты табличных частей этого документа и ищу реквизит, тип значения которого - перечисление.СтавкиНДС.

ТабличныеЧасти = ДокументОбъект.Метаданные().ТабличныеЧасти;
Для Каждого ТабличнаяЧасть Из ТабличныеЧасти Цикл
    Реквизиты = ТабличнаяЧасть.Реквизиты;
    Для Каждого Реквизит Из Реквизиты Цикл
        Если Реквизит.Тип.СодержитТип(Тип("ПеречислениеСсылка.СтавкиНДС")) Тогда
            Для Каждого Строка Из ДокументОбъект[ТабличнаяЧасть.Имя] Цикл
                // какие - то действия
            КонецЦикла;
        КонецЕсли;
    КонецЦикла;
КонецЦикла;


А можно ли как - то сразу выяснить есть среди реквизитов данной ТЧ нужный мне реквизит, не перебирая их по одному в цикле?
 
 
   Волшебник
 
1 - 13.12.18 - 13:18
Один раз перебери и сохрани
   exwill
 
2 - 13.12.18 - 13:19
(0) Интуиция?
   Buster007
 
3 - 13.12.18 - 13:28
в конфигураторе выделяешь перечисление "СтавкиНДС", жмешь правой кнопкой и выбираешь "Поиск ссылок на объект"
результат куда-нибудь копируешь и обрабатываешь
   SleepyHead
 
4 - 13.12.18 - 13:28
(0)

Реквизиты = ТабличнаяЧасть.Реквизиты;
Если Реквизиты.Найти(ИмяРеквизитыТабличной)<>Неопределено Тогда
    // есть такой реквизит
   demiurggig
 
5 - 13.12.18 - 13:37
(4) Мне так нельзя сделать. Я обрабатываю много документов, и кто его знает как в данном документе называется нужный мне реквизит: "СтавкаНДС "или "НДССтавка".

А мне нужно узнать без перебора элементов коллекции есть ли там элемент с типом значения Перечисление.СтавкаНДС.
   demiurggig
 
6 - 13.12.18 - 13:39
5+ Имеется в виду много видов документов
   Мыш
 
7 - 13.12.18 - 13:39
(5) > узнать без перебора элементов
Такого функционала в платформе нет. Только перебор.
   demiurggig
 
8 - 13.12.18 - 13:41
(7) Спасибо, понятно
   Сияющий в темноте
 
9 - 13.12.18 - 13:44
В чем проблема перебора метаданных,вы же не на каждом документе перебираете,а выбрали тип документа,узнали,что там есть ндс и потом можно выбирать и обрабатывать.
   Serg_1960
 
10 - 13.12.18 - 13:59
(8) Если Вы обрабатываете много разнотипных документов "за один раз", то результаты ранее сделанного поиска в метаданных можно сохранять и накапливать в какой-либо структуре и многократно использовать.
 
 Рекламное место пустует

Список тем форума
Рекламное место пустует  Рекламное место пустует
Здесь можно задать вопрос "Как сделать?" и получить кучу ответов, что тебе это делать не надо. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует