Вход | Регистрация
 

Передача выбранного значения в тч документа

Передача выбранного значения в тч документа
Я
   TolstiyBeremenniy
 
13.12.18 - 09:52
У документа есть форма подбора, с заполненной табличной частью.
Как при выборе значения в табличной части перенести её в табличную
часть документа? Так как не получается получить к ней доступ.
Интерфейс такси.
 
 
   TolstiyBeremenniy
 
1 - 13.12.18 - 10:07
Сейчас нахожусь в модуле формы, формы подбора документа.
Ни через, ЭтаФорма, ни через Объект. ни Этотобъект,
не могу получить доступ к табличной части документа самого.
   Tonik992
 
2 - 13.12.18 - 10:13
"Так как не получается получить к ней доступ"
Как пытаетесь это сделать и какая ошибка возникает?
   Василий Алибабаевич
 
3 - 13.12.18 - 10:16
(2) Это ливингстар. Он не пытается. Он ждет код. Причем такой чтоб копи-пасте и все заработало.
   TolstiyBeremenniy
 
4 - 13.12.18 - 10:16
(2) У документа создал форму подбора.
в ней процедура

&НаКлиенте
Процедура ТзНоменклатураДокумнетовДляПодбораВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
    й=1;
КонецПроцедуры
//



А как от сюда к табличной части документа то получить доступ?
   TolstiyBeremenniy
 
5 - 13.12.18 - 10:17
(4+) От сюда видна нужная табличная часть

ЭтотОбъект.ВладелецФормы.Имя

Её название, а как в неё строку перенести?
   TolstiyBeremenniy
 
6 - 13.12.18 - 10:19
Вот наверное строка в этой Тч

ЭтотОбъект.ВладелецФормы.текущиеданные

но как в неё добавлять данные?
   TolstiyBeremenniy
 
7 - 13.12.18 - 10:23
Подскажите пожалуйста!
   TolstiyBeremenniy
 
8 - 13.12.18 - 10:29
Никто не подскажет?
   Василий Алибабаевич
 
9 - 13.12.18 - 10:29
(7)
1. Открыть форму подбора :
ОткрытьФорму("...", , ЭтаФорма);

Параметр ЭтаФорма указывать обязательно.

2. В Форме подбора 
&НаКлиенте
Процедура ТзНоменклатураДокумнетовДляПодбораВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
  //й=1;

  //Для иерархического справочника

  //выбор группы обрабатываем стандартным образом

  Если НЕ ВыбраннаяСтрока.ЭтоГруппа Тогда
    СтандартнаяОбработка = Ложь;
    ОповеститьОВыборе(ВыбраннаяСтрока);
  КонецЕсли;
КонецПроцедуры
   Василий Алибабаевич
 
10 - 13.12.18 - 10:32
+ (9) 
3. В форме документа, в ОбработчикеВыбора :

Процедура ОбработкаВыбора(ВыбранноеЗначение, СтандартнаяОбработка)
Сообщить("Выбран " + ВыбранноеЗначение);
КонецПроцедуры
 
 Рекламное место пустует
   Василий Алибабаевич
 
11 - 13.12.18 - 10:33
+ (10) Вот здесь : https://1c-programmer-blog.ru/programmirovanie/podbor-v-upravlyaemyx-formax.html
не в спешке, с примерами, в стиле для больших и маленьких.
   TolstiyBeremenniy
 
12 - 13.12.18 - 10:34
(9) У меня так, -

    ПараметрыПодбора = Новый Структура("ЗакрыватьПриВыборе, МножественныйВыбор, НачДата, КонДата", Ложь, Истина, НачалоМесяца(Объект.Дата), КонецМесяца(Объект.Дата));
    ОткрытьФорму("Документ.Поступление.Форма.ФормаПодбора", ПараметрыПодбора, Элементы.СписокНоменклатуры);     
    
КонецПроцедуры
   Василий Алибабаевич
 
13 - 13.12.18 - 10:35
(12) Тогда обработчик выбора должен быть не у формы, а у Элементы.СписокНоменклатуры. Пункт 2 остается в силе.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует