Вход | Регистрация
 

Как посчитать общую сумму в печатной форме

Как посчитать общую сумму в печатной форме
Я
   dos
 
12.12.18 - 09:40
Добрый день. Помогите плиз новечку. Нужно сделать печатную форму, чтобы, чтобы в печатной форме считалась общая сумма. Я не понимаю что и куда вставлять....На макете параметр создал...А вот как подсчет суммы сделать хз...Как только не пробывал
Функция  Печать() Экспорт
    
        Запрос = Новый Запрос();
    Запрос.УстановитьПараметр("Ссылка", СсылкаНаОбъект);
    Запрос.Текст =
    "ВЫБРАТЬ
    |    КорректировкаДолга.Организация,
    |    КорректировкаДолга.Номер,
    |    КорректировкаДолга.Дата,
    |    КорректировкаДолга.Комментарий
    |ИЗ
    |    Документ.КорректировкаДолга КАК КорректировкаДолга
    |ГДЕ
    |    КорректировкаДолга.Ссылка = &Ссылка";
    
    Док = Запрос.Выполнить().Выбрать();
    Док.Следующий();
    Макет = ПолучитьМакет("БухгалтерскаяСправка");
    
    
    ШапкаДокумента   = Макет.ПолучитьОбласть("Шапка");
    ЗаголовокТаблицы = Макет.ПолучитьОбласть("ЗаголовокТаблицы");
    СтрокаТаблицы    = Макет.ПолучитьОбласть("СтрокаТаблицы");
    ПодвалТаблицы    = Макет.ПолучитьОбласть("ПодвалТаблицы");
    ПодвалДокумента  = Макет.ПолучитьОбласть("Подвал");
    
    ТабДокумент = Новый ТабличныйДокумент;

    
    Запрос = Новый Запрос();
    Запрос.УстановитьПараметр("Регистратор", СсылкаНаОбъект);
    Запрос.Текст =
    "ВЫБРАТЬ
    |    ХозрасчетныйДвиженияССубконто.НомерСтроки КАК НомерСтроки,
    |    ХозрасчетныйДвиженияССубконто.СчетДт,
    |    ХозрасчетныйДвиженияССубконто.ПодразделениеДт,
    |    ХозрасчетныйДвиженияССубконто.СубконтоДт1,
    |    ХозрасчетныйДвиженияССубконто.СубконтоДт2,
    |    ХозрасчетныйДвиженияССубконто.СубконтоДт3,
    |    ХозрасчетныйДвиженияССубконто.СчетКт,
    |    ХозрасчетныйДвиженияССубконто.ПодразделениеКт,
    |    ХозрасчетныйДвиженияССубконто.СубконтоКт1,
    |    ХозрасчетныйДвиженияССубконто.СубконтоКт2,
    |    ХозрасчетныйДвиженияССубконто.СубконтоКт3,
    |    ХозрасчетныйДвиженияССубконто.Организация,
    |    ХозрасчетныйДвиженияССубконто.Сумма,
    |    ХозрасчетныйДвиженияССубконто.Содержание
    |ИЗ
    |    РегистрБухгалтерии.Хозрасчетный.ДвиженияССубконто(, , Регистратор = &Регистратор, , ) КАК ХозрасчетныйДвиженияССубконто
    |
    |УПОРЯДОЧИТЬ ПО
    |    НомерСтроки";
    
    ВыборкаДвижений = Запрос.Выполнить().Выбрать();

    
    
    ТабДокумент.ПолеСверху              = 2;
    ТабДокумент.ПолеСлева               = 0;
    ТабДокумент.ПолеСнизу               = 0;
    ТабДокумент.ПолеСправа              = 0;
    ТабДокумент.РазмерКолонтитулаСверху = 2;
    ТабДокумент.ОриентацияСтраницы      = ОриентацияСтраницы.Ландшафт;
    
    
    ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ОперацияБух_БухгалтерскаяСправка";

    
    СведенияОбОрганизации = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Док.Организация, Док.Дата);
    
    ШапкаДокумента.Параметры.Организация    = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОбОрганизации);
    ШапкаДокумента.Параметры.НомерДокумента = ОбщегоНазначения.ПолучитьНомерНаПечать(Док);
    ШапкаДокумента.Параметры.ДатаДокумента  = Формат(Док.Дата, "ДЛФ=D");
    ШапкаДокумента.Параметры.Комментарий     = Док.Комментарий;
    
    ТабДокумент.Вывести(ШапкаДокумента);
    
    ТабДокумент.Вывести(ЗаголовокТаблицы);
    ТабДокумент.Вывести(ПодвалТаблицы);
    
        Пока ВыборкаДвижений.Следующий() Цикл
        
        СтрокаТаблицы.Параметры.Заполнить(ВыборкаДвижений);
        
        АналитикаДт = Строка(ВыборкаДвижений.СубконтоДт1) + Символы.ПС
                    + Строка(ВыборкаДвижений.СубконтоДт2) + Символы.ПС
                    + Строка(ВыборкаДвижений.СубконтоДт3);
                    
        АналитикаКт = Строка(ВыборкаДвижений.СубконтоКт1) + Символы.ПС
                    + Строка(ВыборкаДвижений.СубконтоКт2) + Символы.ПС
                    + Строка(ВыборкаДвижений.СубконтоКт3);
                    
        СтрокаТаблицы.Параметры.АналитикаДт = АналитикаДт;
        СтрокаТаблицы.Параметры.АналитикаКт = АналитикаКт;
                                    
        СтрокаСПодвалом = Новый Массив;
        СтрокаСПодвалом.Добавить(СтрокаТаблицы);
        СтрокаСПодвалом.Добавить(ПодвалТаблицы);
        СтрокаСПодвалом.Добавить(ПодвалДокумента);
        
        Если  ФормированиеПечатныхФорм.ПроверитьВыводТабличногоДокумента(ТабДокумент, СтрокаСПодвалом) Тогда
            
                        ТабДокумент.Вывести(ПодвалТаблицы);
                
                        ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();

            
            ТабДокумент.Вывести(ЗаголовокТаблицы);
            
        КонецЕсли;
        
        ТабДокумент.Вывести(СтрокаТаблицы);
        
    КонецЦикла;
    
    
    ТабДокумент.Вывести(ПодвалТаблицы);
    
    
    ПодвалДокумента.Параметры.РасшифровкаПодписиИсполнителя = ?(НЕ ЗначениеЗаполнено(СсылкаНаОбъект.Ответственный), "", ОбщегоНазначения.ФамилияИнициалыФизЛица(СсылкаНаОбъект.Ответственный.ФизЛицо));
    ТабДокумент.Вывести(ПодвалДокумента);
    
    Возврат ТабДокумент;
        
КонецФункции
 
 
   eklmn
 
1 - 12.12.18 - 09:42
Ну это надо стать программистом.
   shadow_sw
 
2 - 12.12.18 - 09:44
волшебное слово ИТОГИ!
   VladZ
 
3 - 12.12.18 - 09:44
(0) "Я не понимаю что и куда вставлять. Как только не пробывал." - открой любую печ.форму, в которой есть вывод  итога по сумме, и сделай так же.
   Галахад
 
4 - 12.12.18 - 09:44
...
Сумма = 0;
Пока ВыборкаДвижений.Следующий() Цикл
Сумма = Сумма + ВыборкаДвижений.Сумма;
...
   eklmn
 
5 - 12.12.18 - 09:45
(3) И будет у нас еще один 1000000+1 быдлокодер-копипастер
   Гипервизор
 
6 - 12.12.18 - 09:49
Общая сумма в бух.справке - это сильно.
   dos
 
7 - 12.12.18 - 09:50
eklmm Ну чтож ты так прям....я же только учусь еще... ты же не сразу стал прогером как родился...
   eklmn
 
8 - 12.12.18 - 09:52
(7) я в детстве чтоб научится, книжки умные читал.
   dos
 
9 - 12.12.18 - 09:53
ну иногда проще спросить, чем искать в инете....время очень дорого

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует