Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Обработать ПоказатьВыборИзСписка и в зависимости от выбр. знач. вернуться к станд. поведен

Обработать ПоказатьВыборИзСписка и в зависимости от выбр. знач. вернуться к станд. поведен
Я
   ixijixi
 
11.12.18 - 15:44
Процедура РасчетыЗначениеПоказателяНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка, ЭтоПоказательВремени = Ложь)
    
    Меню = ВозможныеЗначенияПоказателя();
    Если ЭтоПоказательВремени Тогда
        Меню.Добавить(-1, "Калькулятор");
    КонецЕсли;
    
    Если Меню.Количество() + ?(ЭтоПоказательВремени, 1, 0) > 0 Тогда
        СтандартнаяОбработка = Ложь;
    КонецЕсли;
    
    ОпОп = Новый ОписаниеОповещения("ОбработатьВыборПоказателя", ЭтотОбъект);
    ПоказатьВыборИзСписка(ОпОп, Меню, Элемент);
    
КонецПроцедуры

Процедура ОбработатьВыборПоказателя(ВыбранныйЭлемент, ПараметрыОповещения) Экспорт
    
    Если ВыбранныйЭлемент = Неопределено Тогда
        Возврат;
    КонецЕсли;
    
    Если ВыбранныйЭлемент.Значение = -1 Тогда
        // Здесь нужно отказаться от выбранного значения и показать калькулятор
    КонецЕсли;
    
    // Здесь производятся вычисления в зависимости от выбр. значения
    
КонецПроцедуры
 
 
   ixijixi
 
1 - 11.12.18 - 15:56
В общем, после выбора из списка в числовом поле если пользователь выбрал из списка значение -1, то нужно показать калькулятор
   Numerus Mikhail
 
2 - 11.12.18 - 15:57
(1) Ну покажи, в чем проблема-то?
    Если ВыбранныйЭлемент.Значение = -1 Тогда
        
          ПоказатьКалькулятор();

    КонецЕсли;
   ixijixi
 
3 - 11.12.18 - 16:29
(2) Смешно
   ixijixi
 
4 - 11.12.18 - 16:29
Управляемые формы без использования модальности, режим совместимости 8.3.12. Вдруг это важно.
   Numerus Mikhail
 
5 - 11.12.18 - 16:49
(3) Я абсолютно серьезен. Что не получается? Как пытался?
По тому описанию что я вижу - никаких проблем с показом какого-то калькулятора нет
   ixijixi
 
6 - 11.12.18 - 16:53
(5) Нет такого метода - ПоказатьКалькулятор()
   ixijixi
 
7 - 11.12.18 - 16:54
(5) Если в обработчике события "НачалоВыбора" установить СтандартнаяОбработка = Ложь, то калькулятор не увидишь)
   Вафель
 
8 - 11.12.18 - 16:55
(5) не какого-то, а платформенного
   ixijixi
 
9 - 11.12.18 - 17:01
(8) Йес!
   hhhh
 
10 - 11.12.18 - 18:01
(9) ну, 10 кнопок без нас нарисуешь. В чем вопрос-то?
 
 Рекламное место пустует
   ixijixi
 
19 - 12.12.18 - 08:41
(17) По сабжу есть чо?
   ixijixi
 
20 - 12.12.18 - 14:43
апну

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует