Вход | Регистрация
 

Какую версию PostgreSQL ставить?

Какую версию PostgreSQL ставить?
Я
   first_may
 
10.12.18 - 15:52
Добрый день.

На диске 1с предприятие сервер мини есть папка PostgreSQL, в которой есть два файла
postgresql-9.3.4-1.1C.msi
postgresql-9.3.4-1.1C-int.msi

Подскажите пожалуйста, чем они отличаются и какой надо запускать?
На сайте 1С есть версия 10.5-6.1C, стоит ли ставить последнюю версию?
 
 
   Mr_Best
 
1 - 10.12.18 - 15:53
postgresql-9.3.4-1.1C-int.msi
   Mr_Best
 
2 - 10.12.18 - 15:58
9.6.7 стоит у меня, полет нормальный, более новые версии не тестил. Но учитываю глючный интерфейс 9.6.7, возможно будет лучше попробывать последнюю версию. Так же тюнинг немного изменился, стоит учитывать. На 9.6.7 перешли чисто из-за того, что в начиная с этой версии запросы с множественным внутренним соединением стали отрабатыватся так же быстро как и MSSQL
   unregistered
 
3 - 10.12.18 - 15:59
(0) А вы точно уверены, что оно вам вообще надо? Может лучше по-старинке - MS SQL?
Если уж ставить сервер, то лучше, наверное ставить более свежие релизы. Быть может не 10.5, но и не древний 9.3.4.
   lodger
 
4 - 10.12.18 - 15:59
(0) postgresql-9.3.4 что-то старовата. не?
   Mr_Best
 
5 - 10.12.18 - 16:01
(4) точно не ставь эту версию, там проблемы с некторыми запросами
   Mr_Best
 
6 - 10.12.18 - 16:01
(4) ставь начиная с 9.6.7
   Mr_Best
 
7 - 10.12.18 - 16:02
(3) после версии 9.6.7 доволен как мамонт ))) Нехватает только что инструментов анализ запросов и плана запросов удобного, но это дело привычки
   Фрэнки
 
8 - 10.12.18 - 16:03
(0) если будешь качать соотв. этому релизу свежую платформу 1С , то ставь вот самый свежий постгрес и платформу.
   lodger
 
9 - 10.12.18 - 16:04
(0) на юзерсе не последняя версия постгри. это последняя прошедшая аттестацию под нужды платформы 1с.
т.е. можно ее ставить достаточно смело.
   Mr_Best
 
10 - 10.12.18 - 16:05
(8)(9) я б не рубил так с гореча, может падать, бывало, не все релизы одинаково стабильны. Но мы будем рады, ели ты поюзаешь и дашь отзыв сообществу ))))
 
 Рекламное место пустует
   Mr_Best
 
11 - 10.12.18 - 16:06
мы сначало тестим на одной из баз 3 месяца, потом потихоньку переводим все остальное
   Mr_Best
 
12 - 10.12.18 - 16:06
для каждой новой версии
   unregistered
 
13 - 10.12.18 - 16:11
(9) Выражайся точнее.
"это последняя прошедшая аттестацию" - это про какую версию? Про ту, что указана в (0) - 9.3.4? Тогда это не так.
Если про ту, что указана на сайте 1С в разделе для скачивания дистрибутивов https://releases.1c.ru/total то там последняя - 10.5. Но прежде чем её ставить надо знать о какой версии платформы идёт речь. На более старых версиях чем 8.3.12 может не взлететь.
   DrLekter
 
14 - 10.12.18 - 17:28
msi - это на винду ставить? У старых версий на винде были проблемы с обновлением статистики, выливающиеся в жуткие тормоза. Решено вроде только в последних версиях, после 9.6.
На линуксе можно и старую поставить, только зачем? )
   first_may
 
15 - 10.12.18 - 18:27
(4) вот диск пришел из 1С, держу коробку в руках :)

попробую скачать
postgresql-10.5-6.1C-int.msi
   Фрэнки
 
16 - 10.12.18 - 18:41
(15) так там и платформа на диске будет старая. Ты посмотри, для какой программы нужна установка Платформы. Если это для БП 3, к примеру, то обязательно платформу обнови тоже. Соотв. и скл бери свежий.
   lodger
 
17 - 10.12.18 - 18:42
(15) платформу и субд ставь с юзерса.
если там же найдешь свежий установщик конфы - тоже используй его. иначе сиди и обновляй.
версию платформы бери минимально совместимую к последней версии твоей конфы.
   lodger
 
18 - 10.12.18 - 18:43
(17) хотя бы минимально совместимую. можно выше в пределах ревизии. 8.3.12.ххх или 8.3.13.ххх
   first_may
 
19 - 10.12.18 - 22:30
Спасибо всем :), буду брать последний 10.5-6.1.

А в чем все таки разница
...msi
...-int.msi

?
   first_may
 
20 - 16.02.19 - 20:00
Добрый вечер.

Подниму тему.
Сейчас работает связка
windows server 2008 r2 + postgresql 9.3.4 + 1С:Предприятие 8.3 (8.3.13.1690).

Подскажите пожалуйста, надо ли менять postgresql 9.3.4 на postgresql 10.5?
Если да, то как это делается, так как никогда postgresql не обновлял еще ни разу?
   Наблюдающий
 
21 - 16.02.19 - 20:14
(20) на 10.5 есть проблемы 8.3.13.1644 и PosgreSQL: ошибка "variable not found in subplan target lists"
Получается лбио как советовали 9.6.7 либо 10.3.
Базы выгрузить из конфигуратора, удалить postgres, установить новый, загрузить базы.
Но был случай когда я не удалял постгрес, а просто сразу запустил новый инсталятор и чего то у меня после это не стартовал он, хорошо бэкап всей системы перед этим сделал, восстановил и все норм, поэтому тоже на всякий случай сделать образ всей системы с выключенными службами сервера постгреса и агнета 1с. И да на 10 версии постгреса вход в pgadmin последней версии через бразуер, какуто ошибку выдает, не запускается, разбираться не стал, поставил старый pgadmin 2.1 вроде работает.
   Наблюдающий
 
22 - 16.02.19 - 20:21
И еще неплохо бы батник на каждую базу сделать и поставить на автозапуск по утрам. Например:

SET PGPASSWORD=test1
"C:\Program Files\PostgreSQL\9.6.5-4.1C\bin\psql.exe" --dbname unf_tr --host 127.0.0.1 --port 5432 --username postgres --command analyze
   first_may
 
23 - 16.02.19 - 20:31
(22) то есть, обновление заключается в том, что делаем архив в старой версии, устанавливаем новую и в ней разворачиваем архив.

"Базы выгрузить из конфигуратора" - а как то можно сделать выгрузку сразу всех баз с помощью постгри?
   Наблюдающий
 
24 - 16.02.19 - 20:54
(23) Я имел ввиду выгрузку в файл .dt
В конфигураторе: администрирование -> выгрузить информационную базу.
Есть вариант просто поставить новый постгрес и выполнить pg_upgrade, но во первых не стал вникать, во вторых как он там базы обновить не ясно, как бы не было проблем. Надежней через конфигуратор, но если баз много то надо тестировать на виртуалке https://postgrespro.ru/docs/postgresql/9.6/pgupgrade

Про бекап сразу всех баз кластера постгреса не слыхал. Возможно есть, надо читать документацию.
   first_may
 
25 - 16.02.19 - 20:59
(24) "но если баз много " - да, я это и имел ввиду, если их много, то придется каждую выгружать..

но в целом понятно, значит
1 делаем бэкап баз (дт-шки)
2 ставим postgresql 10.5 (например)
3 восстанавливаем базы на новом сервере из дт

Так?
   Наблюдающий
 
26 - 16.02.19 - 21:05
(25) Да, верно. Вот даже 1С пишет что после перехода на 10.3 и выше:

"Если переход на версию PostgreSQL 10.3 выполняется с помощью утилиты pg_upgrade, то рекомендуется выполнить переиндексацию таблиц базы данных для того, чтобы работа с буквой «ё» стала соответствовать правилам русского языка. Переиндексацию рекомендуется выполнять с помощью механизма тестирования и исправления конфигуратора, указав режим Реиндексация таблиц информационной базы.

Источник: https://dl03.1c.ru/content/AddCompPostgre/10_3_3_1C/postgreUpdate_ru.htm#3681676d-5e75-11e8-a3f7-0050569f678a";

В вашем случае тогда проще выполнить pg_upgrade, главное потестить на виртуалке хотя бы на одной базе как это работает.
   first_may
 
27 - 16.02.19 - 21:07
(26) спасибо
   first_may
 
28 - 21.02.19 - 23:21
Добрый вечер.

Скачал с сайта 1С версию PostgreSQL, версия 10.3-3.1C.
Установил все по умолчанию.

При запуске pgAdmin 4 выдается ошибка
"the application server could not be contacted"

Делал, но не помогло
- запустить PgAdmin отмени администратора.
- добавьте путь к bin-папке Postgresql в переменные окружения.
- очистите папку C:\Users\%USERNAME%\AppData\Roaming\pgAdmin

Подскажите пожалуйста, что можно сделать, что бы запустить pgAdmin?

Или все таки ставить еще один pgAdmin4 и мириться с тем, что их будет два, как сказано в одной из веток форума?
   first_may
 
29 - 22.02.19 - 10:28
При запуске pgAdmin 4 выдается ошибка
"the application server could not be contacted"


Подскажите по поводу ошибки? Как ее исправить?
   ansh15
 
30 - 22.02.19 - 10:33
(29) Написать в 1С, чтобы собрали pgAdmin правильно.
PostgreSQL, версия 10.5-24.1C выложили вчера, посмотри, может там что изменилось.
   Вафель
 
31 - 22.02.19 - 10:37
на винду - ни каккую
   first_may
 
32 - 22.02.19 - 10:52
(31) я качал и ставил отдельно
pgAdmin 4 v4.2 (released Feb. 7, 2019)
https://www.pgadmin.org/download/pgadmin-4-windows/

все работает, но просто хотелось бы лишний софт не ставить :).
   Вафель
 
33 - 22.02.19 - 10:59
(32) хлебнешь ты горюшка с пг на винде еще
 
 
   arsik
 
34 - 22.02.19 - 11:07
(33) Это пук в лужу. Подробности давай.
   first_may
 
35 - 22.02.19 - 11:10
(30) в 1с написал.. жду ответа..
   Aleksey
 
36 - 22.02.19 - 11:12
(34) Знал бы, где упасть, соломки бы подостлал
   first_may
 
37 - 22.02.19 - 11:14
Сейчас работает на винде 9.3.4. И уже достаточно давно. База не маленькая. Никаких особых проблем не замечаем.

Вот решили просто идти вперед и пробуем новую версию. Сразу столкнулись вот с ошибкой.
   first_may
 
38 - 23.02.19 - 13:10
Может кому то интересно, то поддержка 1с ответила
"Попробуйте использовать PgAdmin4 1.6 с сайта."
   first_may
 
39 - 23.02.19 - 13:11
То есть так и получается, что надо качать и ставил отдельно pg Admin 4.
   first_may
 
40 - 25.02.19 - 12:52
   vitkhv
 
41 - 25.02.19 - 13:33
(2) УПП на 9.6.7 можно юзать без тормозов по отношению к MSSQL?
   dmrjan
 
42 - 26.02.19 - 13:41
   first_may
 
43 - 01.03.19 - 09:31
(42) а можно качать отсюда? а тогда на сайте 1С что за версии?
   unregistered
 
44 - 01.03.19 - 09:45
(43) На сайте 1С версии официально протестированные самой 1С на их стендах.
На сайте PostgresPro версии прошедшие тестирование только самими разработчиками PostgresPro.
Фактически о случаях, чтобы сборки от PostgresPro не работали, я не слышал. Хотя естественно сама 1С официально поддерживает только те, что опубликованы только на её сайте.

Единственный нюанс - надо уточнять совместимость версий платформы 1С и версий PostgreSQL (вне зависимости от того чьей сборки).
   first_may
 
45 - 01.03.19 - 09:53
(44) спасибо
   ll13
 
46 - 17.05.19 - 20:50
   dmrjan
 
47 - 18.05.19 - 12:25
Я бы тоже поставил 10.5-24.1C или с сайта https://postgrespro.ru/products/postgrespro/standard 10 релиз. Они в ней ошибки поправили серьезные с backup. И реализовали лучшую совместимость со сложными выборками 1С.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует