Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Новый ОписаниеОповещения избавился от модальн. окна, но теперь как обновл. данные формы?

Новый ОписаниеОповещения избавился от модальн. окна, но теперь как обновл. данные формы?
Я
   SkillUp
 
10.12.18 - 14:21
Новый ОписаниеОповещения избавился от модальн. окна, но теперь как обновлять данные открываемой формы? Все заполнение формы,  было завязано на процедуре -  "ПриСозданииНаСервере"? Теперь каждый раз форма не создается, и там остаются старые данные. Как  обойти эту проблему?
 
 
   Numerus Mikhail
 
1 - 10.12.18 - 14:25
(0) а теперь на чем завязано?
   SkillUp
 
2 - 10.12.18 - 14:28
Понял... (1) 

При нажатии на элементе номенклатуры открывается форма, со списком характеристик и цен, на тонком клиенте форма заполнялась в процедуре "ПриСозданииНаСервере" (открытьМодально). Потом потребовалось перевести на веб интерфейс, там модальное окно убрал с помощью -ОписаниеОповещения, теперь форма каждый раз не создается и соответственно не заполняются новыми данными...
   SkillUp
 
3 - 10.12.18 - 16:04
Все так акктивно помогали, что я сам нашел віход из ситуации ,мож. кому- топригодится:

Окна = ПолучитьОкна();
    Для Каждого Окно Из Окна Цикл
        Форма = Окно.ПолучитьСодержимое();
        Если Окно.Заголовок = "Характеристики и цена номенклатуры" Тогда
            Форма.Закрыть();
        КонецЕсли;    
    КонецЦикла;   

далее код и вызов ПриСозданииНаСервере...
   palsergeich
 
4 - 10.12.18 - 16:09
(3) ТЗ требует телепата.
Но решение - костыль.
Сформулируй точнее и получишь ответ, это ты перед глазами код видишь, а нам постановка задачи в (0) не ясна
   SkillUp
 
5 - 10.12.18 - 16:10
(4) ок.
   SkillUp
 
6 - 10.12.18 - 16:16
Ой, НЕ!! Вот так!

Окна = ПолучитьОкна();
    Для Каждого Окно Из Окна Цикл
        //Форма = Окно.Содержимое;

        Если Окно.Заголовок = "Характеристики и цена номенклатуры" Тогда
            ФормаХарЦен = Окно.ПолучитьСодержимое();
            ФормаХарЦен.Закрыть();
        КонецЕсли;    
    КонецЦикла;
   SkillUp
 
7 - 10.12.18 - 16:17
(6) Хотя...
   Сияющий в темноте
 
8 - 11.12.18 - 00:40
обычно,открывается дочерняя форма,чтобы что то сделать,а потом,когда нужно передать что то родителю,то можно сделать вызов метода в родительской форме или оповестить ее о чем то,ну или обработка выбора.

Список тем форума
Рекламное место пустует  Рекламное место пустует
Глупец, лишенный способности посмеяться над собой вместе с другими, не сможет долго выносить программирование.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует