Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Вывод сообщений пользователю из внешней обработки создания связанных объектов

Вывод сообщений пользователю из внешней обработки создания связанных объектов
Я
   cons24
 
10.12.18 - 11:33
Задача: добавить ввод комплектации на основании ПТУ.
Сделал внешку, документы создает и проводит как надо. Но еще надо чтоб выводился список созданных документов и ошибок.
Вижу есть параметр "СозданныеОбъекты", но он нигде явно не обрабатывается.
 
 
   Очевидно
 
1 - 10.12.18 - 11:37
После создания документа :
Сообщение = Новый СообщениеПользователю();
        Сообщение.Текст = "Создан : "+ЗаказНаПроизводствоОбъект.Ссылка;
        Сообщение.КлючДанных = ЗаказНаПроизводствоОбъект.Ссылка;
        Сообщение.УстановитьДанные(ЗаказНаПроизводствоОбъект.Ссылка);
        Сообщение.Сообщить();
   cons24
 
2 - 10.12.18 - 11:50
(1) не фурычит. Как и прежде совсем ничего не выводит.
   Очевидно
 
3 - 10.12.18 - 12:01
(2) УФ или Обычные формы ?
   Очевидно
 
4 - 10.12.18 - 12:04
(2) из СП :
СообщениеПользователю (UserMessage)

Описание:

Предназначен для хранения параметров сообщения, которые необходимо вывести пользователю.
Если сообщение еще не было показано пользователю (такое может быть при работе на стороне сервера, в фоновом задании, внешнем соединении или Web-сервисах), можно получить накопленные сообщения методом ПолучитьСообщенияПользователю.
   cons24
 
5 - 10.12.18 - 12:05
УФ
   Очевидно
 
6 - 10.12.18 - 12:07
(5) См: (4)
   cons24
 
7 - 10.12.18 - 12:08
БСП. Некуда тут вставлять ПолучитьСообщенияПользователю()

Функция СведенияОВнешнейОбработке() Экспорт

    лМетаданные = Метаданные();
    
    ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке();    
    ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиСозданиеСвязанныхОбъектов();
    ПараметрыРегистрации.Назначение.Добавить("Документ.ПоступлениеТоваровУслуг");
    ПараметрыРегистрации.Наименование = лМетаданные.Синоним;
    
    НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
    НоваяКоманда.Представление = ПараметрыРегистрации.Наименование;
    НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();
    НоваяКоманда.Идентификатор = ПараметрыРегистрации.Наименование + НоваяКоманда.Использование;
    НоваяКоманда.ПоказыватьОповещение = Истина;
        
    Возврат ПараметрыРегистрации;
    
КонецФункции


Процедура ВыполнитьКоманду(ИдентификаторКоманды, ОбъектыНазначения, СозданныеОбъекты, ПараметрыВыполнения=Неопределено) Экспорт
    Для Каждого ПТУ из ОбъектыНазначения Цикл
        ОбработатьПТУ(ПТУ,СозданныеОбъекты);
    КонецЦикла;
КонецПроцедуры

Процедура ОбработатьПТУ(СсылкаПТУ,СозданныеОбъекты)
//

КонецПроцедуры
   cons24
 
8 - 10.12.18 - 12:08
Думаю причина в ТипКомандыВызовСерверногоМетода().
   Очевидно
 
9 - 10.12.18 - 12:25
(8) да, ты прав ...
Меняешь его на "ТипКомандыВызовКлиентскогоМетода()"
Создаёшь форму обработке и там пишешь:
&НаКлиенте
Процедура ВыполнитьКоманду(ИдентификаторКоманды, ОбъектыНазначения, СозданныеОбъекты, ПараметрыВыполнения=Неопределено) Экспорт
    Для Каждого ПТУ из ОбъектыНазначения Цикл
        ОбработатьПТУ(ПТУ,СозданныеОбъекты);
    КонецЦикла;
    
    Для Каждого СозданныйОбъект из СозданныеОбъекты Цикл
        Сообщение = Новый СообщениеПользователю();
        Сообщение.Текст = "Создан : "+СозданныйОбъект;
        Сообщение.КлючДанных = СозданныйОбъект;
        Сообщение.УстановитьДанные(СозданныйОбъект);
        Сообщение.Сообщить();
    КонецЦикла;

    
КонецПроцедуры

&НаСервереБезКонтекста
Процедура ОбработатьПТУ(СсылкаПТУ,СозданныеОбъекты)
//

    НовыйДокумент = СсылкаПТУ.ПолучитьОбъект().Скопировать();
    НовыйДокумент.Записать();
    
    СозданныеОбъекты.Добавить(НовыйДокумент.Ссылка);
        
КонецПроцедуры
   Очевидно
 
10 - 10.12.18 - 12:26
(9) + По двойному клику на сообщение - открывается новый документа
   Очевидно
 
11 - 10.12.18 - 12:26
*Документ

Список тем форума
Рекламное место пустует  Рекламное место пустует
Здесь можно обсудить любую тему при этом оставаясь на форуме для 1Сников, который нужен для работы. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.