Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Управляемые формы, печать

Управляемые формы, печать
Я
   Vitaliy_s87
 
09.12.18 - 21:19
С помощью конструктора  печати были автоматически сформированы макет, команда документа и процедура печати в модуле менеджера

Формирование печатной формы проходит ОК, но заполнение параметров макета проходит автоматически по выборке из запроса, вот текст

Процедура ДрукуватиПротокол(ТабДок, Ссылка) Экспорт
    //{{_КОНСТРУКТОР_ПЕЧАТИ(ДрукуватиПротокол)
    Макет = Документы.ПротоколВідповідності.ПолучитьМакет("ДрукуватиПротокол");
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    |    ПротоколВідповідності.Виконавець,
    |    ПротоколВідповідності.ВисотаСидіння,
    |    ПротоколВідповідності.ВідстаньМіжОдинДоОдного,
    |    ПротоколВідповідності.ВідстаньМіжСидіннямиВОдному,
    |    ПротоколВідповідності.Дата,
    |    ПротоколВідповідності.ДатаЗаявки,
    |    ПротоколВідповідності.ЗахиснаОббивка,
    |    ПротоколВідповідності.Кафе,
    |    ПротоколВідповідності.Клас,
    |    ПротоколВідповідності.Кондицонер,
    |    ПротоколВідповідності.КутНахилуидіння,
    |    ПротоколВідповідності.КількістьДверей,
    |    ПротоколВідповідності.КількістьМісцьБезВодія,
    |    ПротоколВідповідності.КількістьПідлокітників,
    |    ПротоколВідповідності.КількістьРядівСидінь,
    |    ПротоколВідповідності.МаркуванняСкла,
    |    ПротоколВідповідності.МодельДвигуна,
    |    ПротоколВідповідності.Мікрофон,
    |    ПротоколВідповідності.МісткістьБагажника,
    |    ПротоколВідповідності.МісткістьБагажникаНаОдного,
    |    ПротоколВідповідності.МісткістьХолодильника,
    |    ПротоколВідповідності.МісткістьХолодильникаНаОдного,
    |    ПротоколВідповідності.МісцеПроведення,
    |    ПротоколВідповідності.НайменуванняДокументу,
    |    ПротоколВідповідності.НайменуванняПІБЗаявника,
    |    ПротоколВідповідності.Номер,
    |    ПротоколВідповідності.НомерДвигуна,
    |    ПротоколВідповідності.НомерЗаявки,
    |    ПротоколВідповідності.ОббивкаЗТканини,
    |    ПротоколВідповідності.Обдув,
    |    ПротоколВідповідності.ОбємБагажнихВідділень,
    |    ПротоколВідповідності.ОбігрівБезДвигуном,
    |    ПротоколВідповідності.ОбігрівЗДвигуном,
    |    ПротоколВідповідності.Організація,
    |    ПротоколВідповідності.Освітлення,
    |    ПротоколВідповідності.ОсвітленняРобочоїЗони,
    |    ПротоколВідповідності.ПередбачуванаЗагальнаПасажировмісність,
    |    ПротоколВідповідності.ПредметнийСтолик,
    |    ПротоколВідповідності.ПротисонячнеОбладнання,
    |    ПротоколВідповідності.Підвіска,
    |    ПротоколВідповідності.ПідлокітникиЗбоку,
    |    ПротоколВідповідності.ПідставкаДляНіг,
    |    ПротоколВідповідності.РегулюванняСпинки,
    |    ПротоколВідповідності.РоздільніСидіння,
    |    ПротоколВідповідності.РучнаПоклажа,
    |    ПротоколВідповідності.СидінняЩоЗміщуються,
    |    ПротоколВідповідності.Співвиконавець,
    |    ПротоколВідповідності.СтанАвтобусаВнутрішній,
    |    ПротоколВідповідності.СтанАвтобусаЗовнішній,
    |    ПротоколВідповідності.СхемаКомпонування,
    |    ПротоколВідповідності.Телевізор,
    |    ПротоколВідповідності.ТемператураПовітря,
    |    ПротоколВідповідності.ТипКузова,
    |    ПротоколВідповідності.ТонованеСкло,
    |    ПротоколВідповідності.ТранспортнийЗасіб,
    |    ПротоколВідповідності.Туалет,
    |    ПротоколВідповідності.Умивальник,
    |    ПротоколВідповідності.Фото1,
    |    ПротоколВідповідності.Фото2,
    |    ПротоколВідповідності.Фото3,
    |    ПротоколВідповідності.Фото4,
    |    ПротоколВідповідності.Фото5,
    |    ПротоколВідповідності.Фото6,
    |    ПротоколВідповідності.Фото7,
    |    ПротоколВідповідності.Холодильник,
    |    ПротоколВідповідності.ЧислоМісцьЕкіпажу,
    |    ПротоколВідповідності.ЧистотаАвтобуса,
    |    ПротоколВідповідності.ЗВТ.(
    |        НомерСтроки,
    |        ЗВТ
    |    ),
    |    ПротоколВідповідності.Література.(
    |        НомерСтроки,
    |        МетодичнаЛітература
    |    )
    |ИЗ
    |    Документ.ПротоколВідповідності КАК ПротоколВідповідності
    |ГДЕ
    |    ПротоколВідповідності.Ссылка В (&Ссылка)";
    Запрос.Параметры.Вставить("Ссылка", Ссылка);
    Выборка = Запрос.Выполнить().Выбрать();

    ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
    Шапка = Макет.ПолучитьОбласть("Шапка");
    ОбластьЗВТШапка = Макет.ПолучитьОбласть("ЗВТШапка");
    ОбластьЗВТ = Макет.ПолучитьОбласть("ЗВТ");
    ОбластьЛітератураШапка = Макет.ПолучитьОбласть("ЛітератураШапка");
    ОбластьЛітература = Макет.ПолучитьОбласть("Література");
    ТабДок.Очистить();

    ВставлятьРазделительСтраниц = Ложь;
    Пока Выборка.Следующий() Цикл
        Если ВставлятьРазделительСтраниц Тогда
            ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
        КонецЕсли;

        ТабДок.Вывести(ОбластьЗаголовок);

        Шапка.Параметры.Заполнить(Выборка);
        ТабДок.Вывести(Шапка, Выборка.Уровень());

        ТабДок.Вывести(ОбластьЗВТШапка);
        ВыборкаЗВТ = Выборка.ЗВТ.Выбрать();
        Пока ВыборкаЗВТ.Следующий() Цикл
            ОбластьЗВТ.Параметры.Заполнить(ВыборкаЗВТ);
            ТабДок.Вывести(ОбластьЗВТ, ВыборкаЗВТ.Уровень());
        КонецЦикла;

        ТабДок.Вывести(ОбластьЛітератураШапка);
        ВыборкаЛітература = Выборка.Література.Выбрать();
        Пока ВыборкаЛітература.Следующий() Цикл
            ОбластьЛітература.Параметры.Заполнить(ВыборкаЛітература);
            ТабДок.Вывести(ОбластьЛітература, ВыборкаЛітература.Уровень());
        КонецЦикла;

        ВставлятьРазделительСтраниц = Истина;
    КонецЦикла;
    //}}
КонецПроцедуры


Я не  програмист но иногда приходиться что то доработать

Исходя из текста процедуры а имеено вот этого
        
Шапка.Параметры.Заполнить(Выборка);
ТабДок.Вывести(Шапка, Выборка.Уровень());

параметры макета заполняються автоматически по наименованию параметра

а мне нужно в ручную указывать заполнение  параметров, а таже указать что бы не выводились незаполненые поля

подскажите пожалуйста текст

я пробовал заменить этот текст

Шапка.Параметры.Заполнить(Выборка);
ТабДок.Вывести(Шапка, Выборка.Уровень());

вот так

Шапка.ТранспортнийЗасіб  =  Выборка.ПротоколВідповідності.ТранспортнийЗасіб()

но так не работает

Подскажите как правильно написать
 
 
   Vitaliy_s87
 
1 - 09.12.18 - 21:19
Я не  програмист но иногда приходиться что то доработать
Исходя из текста процедуры а имеено вот этого
        
Шапка.Параметры.Заполнить(Выборка);
ТабДок.Вывести(Шапка, Выборка.Уровень());

параметры макета заполняються автоматически по наименованию параметра

 а мне нужно в ручную указывать заполнение  параметров, а таже указать что бы не выводились незаполненые поля

подскажите пожалуйста текст

я пробовал заменить этот текст

Шапка.Параметры.Заполнить(Выборка);
ТабДок.Вывести(Шапка, Выборка.Уровень());

вот так

Шапка.ТранспортнийЗасіб  =  Выборка.ПротоколВідповідності.ТранспортнийЗасіб()

но так не работает

Подскажите как правильно написать
   mikecool
 
2 - 09.12.18 - 21:21
Шапка.Параметры.ТранспортнийЗасіб =
   Vitaliy_s87
 
3 - 09.12.18 - 21:51
сори ошибся да та и писал
Шапка.Параметры.ТранспортнийЗасіб =таб док фомируэться никаких ошибок но пусто
   Demasiado
 
4 - 09.12.18 - 22:14
Отладчиком глянуть, может результат выборки пустой?
   hhhh
 
5 - 09.12.18 - 22:17
(3) думаю, ошибка в функции

Выборка.ПротоколВідповідності.ТранспортнийЗасіб()

что за функция такая?
   Vitaliy_s87
 
6 - 09.12.18 - 22:19
(5) вот вопрос то у меня и в том правильно литак писать к результату запроса
Выборка.ПротоколВідповідності.ТранспортнийЗасіб()
   Vitaliy_s87
 
7 - 09.12.18 - 22:20
результат выборки не пустой потому что так работает

Шапка.Параметры.Заполнить(Выборка);
ТабДок.Вывести(Шапка, Выборка.Уровень());
   Vitaliy_s87
 
8 - 09.12.18 - 22:21
мне какажеться что нужно просто правильно написать

Шапка.Параметры.ТранспортнийЗасіб = ??????????
   Vitaliy_s87
 
9 - 09.12.18 - 22:28
может из за вот этих ссылок нужно как то по другому писать
Запрос.Параметры.Вставить("Ссылка", Ссылка);
    Выборка = Запрос.Выполнить().Выбрать();
   hhhh
 
10 - 10.12.18 - 00:36
(9) Шапка.Параметры.ТранспортнийЗасіб  =  Выборка.ТранспортнийЗасіб;
 
 Рекламное место пустует

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует