Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Русские буквы в артикуле номенклатуры

Русские буквы в артикуле номенклатуры
Я
   Never
 
05.12.18 - 08:24
Как можно осуществить поиск русских букв в артикуле номенклатуры? Артикул в номенклатуру заполняется копированием из файла Excel
 
 
   Галахад
 
1 - 05.12.18 - 08:28
(0) А зачем их искать?
   Never
 
2 - 05.12.18 - 08:43
(1) бывает такое что при поиске изделия по артикулу не находит его из за того что в артикуле какая то из букв русская
   catena
 
3 - 05.12.18 - 08:45
Глобальный контекст (Global context)
СтрНайти (StrFind)
Синтаксис:

СтрНайти(<Строка>, <ПодстрокаПоиска>, <НаправлениеПоиска>, <НачальнаяПозиция>, <НомерВхождения>)
   Дмитрий
 
4 - 05.12.18 - 08:52
если только цифры и англ. буквы - артикулы в разных кодировках будут совпадать. можно от этого плясать
   Повелитель
 
5 - 05.12.18 - 08:58
(0)
Функция переводит русские буквы в анг. Процедура взята с просторов интернета, работает у меня в базе много лет.

Функция Транслит(srtRusWord) 
    strRUS = "АБВГДЕЁЖЗИЙКЛМНОПРСТУФХЦЧШЩЪЫЬЭЮЯ"; 
    strENG = "///B///V///G///D///E///YO//ZH//Z///I///Y///K///L///M///N///O///P///R///S///T///U///F///KH//TS//CH//SH//SHCH'///Y///////E///YU//JA//"; 

    strResult = ""; 
    Для i = 1 по СтрДлина(srtRusWord) Цикл 
        s = Сред(srtRusWord, i,1); 
        s=(s); 
        k = Найти(strRUS, s); 
        Если k = 0 тогда 
            strResult = strResult + s; 
        Иначе 
            strResult = strResult + СтрЗаменить(Сред(strENG, (k - 1) * 4 + 1, 4), "/", ""); 
        КонецЕсли 
    КонецЦикла ; 
    
    srtRusWord = strResult; 
    strResult = "";
    Для i = 1 по СтрДлина(srtRusWord) Цикл 
        s = Сред(srtRusWord, i,1); 
        //s=нРег(s); 

        k = Найти(нРег(strRUS), нРег(s)); 
        Если k = 0 тогда 
            strResult = strResult + s; 
        Иначе 
            strResult = strResult + нРег(СтрЗаменить(Сред(strENG, (k - 1) * 4 + 1, 4), "/", "")); 
        КонецЕсли 
    КонецЦикла ; 
    
    Возврат strResult; 
КонецФункции
   НЕА123
 
6 - 05.12.18 - 08:58
в запросе как-то так
like "%[А-Я]%"
   Serg_1960
 
7 - 05.12.18 - 09:04
(2) "бывает такое что..." - что бы ничего такого не было - одноразовое выполнение обработки по поиску и замены русских букв в артикуле и фильтр при копировании артикула из из файла Excel.
   Serg_1960
 
8 - 05.12.18 - 09:08
(5) Имхо, скорее всего у автора проблема с русскими/английскими буквами типа "А","В","Е" и им подобными.
   Повелитель
 
9 - 05.12.18 - 09:09
(8) Данная процедура решит этот вопрос, если ее чуть-чуть подредактировать, оставив "А","В","Е" ...
   Сияющий в темноте
 
10 - 05.12.18 - 09:34
еще иногда русское з вместо тройки пишут,ексель то все стерпит
   JeHer
 
11 - 05.12.18 - 09:41
(0)+(7) А что, если в экселе правильное написание некоторых артикулов с латиницей? Поставщик, к примеру, так захотел.
   Serg_1960
 
12 - 05.12.18 - 09:57
(11) Там, в Excel-е, что хотят - то пусть и пишут - со своим уставом в чужой монастырь не ходят. Я понимаю что Вы хотите сказать, но автор про это ничего не говорил. Если в базе есть функционал поддержки номенклатуры поставщика - то не сложно реализовать два артикула (внутренний и внешний).

Список тем форума
Рекламное место пустует  Рекламное место пустует
Требовать и эффективности, и гибкости от одной и той же программы — все равно, что искать очаровательную и скромную жену... по-видимому, нам следует остановиться на чем-то одном из двух.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.