Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Обновление БП (база) с 2 на 3

Обновление БП (база) с 2 на 3
Я
   alexdomovoi
 
29.11.18 - 13:33
Добрый день! Стал переходить с Бух.база 2 на Бух база 3 скачал версию для перехода, обновил базу шло долгое обновление, вроде все обновилось, запустил 1с в обычном режиме пошло применение обновления, и вылезла такая ошибка:
[url=http://c.radikal.ru/c28/1811/7d/b970eb0ed129.jpg][img]http://c.radikal.ru/c28/1811/7d/b970eb0ed129t.jpg[/img][/url]
 
 
   alexdomovoi
 
1 - 29.11.18 - 13:33
нет что то ссылкой кривизна http://c.radikal.ru/c28/1811/7d/b970eb0ed129.jpg,
куда дальше смотреть не подскажете?
   Admin_Net_1C
 
2 - 29.11.18 - 13:36
(1) смотреть ОбщийМодуль.ЗарплатаКадрыОбновлениеСПредыдущейРедак...
анализировать, почему возникает ошибка...
Как то так...
   cons24
 
3 - 30.11.18 - 11:49
Вангую: в новых релизах фирма 1с удалила из регистра измерение "Организация", у вас в БП2 оно было, получили дубли записей.
   alexdomovoi
 
4 - 05.12.18 - 15:58
(3) Что делать ждать когда исправят?
   Флориан
 
5 - 05.12.18 - 16:00
(4) дубли удалять в Бух.база 2
   strange2007
 
6 - 05.12.18 - 16:38
(4) В этом регистре вроде как убрали периодичность, а у вас видимо этот пункт использовался. Удаляйте из этого регистра все старые записи и оставляйте только новые.
   alexdomovoi
 
7 - 07.01.19 - 00:30
Доброй ночи на базе стал опять проводить обновление до 3 версии выходит очередная ошибка:

{ОбщийМодуль.ЗарплатаКадрыОбновлениеСПредыдущейРедакции.Модуль(2426)}: Ошибка при вызове метода контекста (Записать)
        НаборЗаписей.Записать();
по причине:
Не удалось записать: "Лицевые счета сотрудников по зарплатным проектам"!

Как более конкретно с этим косяком разобраться? Спасибо!
   Fram
 
8 - 07.01.19 - 00:37
(0) перед обновлением до 3 версии 2ую до последнего релиза обновил?
   Fram
 
9 - 07.01.19 - 00:52
(8)+ рекомендации из Readme выполнил?

Переход с редакции 2.0 конфигурации "Бухгалтерия предприятия"
-----------------------------------------------------------------------
Для перехода на версию 3.0.67 необходимо использовать 
версию конфигурации "Бухгалтерия предприятия" не ниже 2.0.66

Для перехода выполните следующие действия:
- установите дистрибутив обновления для перехода с редакции 2.0 в каталог шаблонов;
- откройте информационную базу редакции 2.0 в режиме "Конфигуратор" монопольно;
- сделайте архивную копию данных (Администрирование - Выгрузить данные);
- если в конфигурации созданы пользователи, то установите дополнительную роль; 
"Администратор системы (для перехода на ред. 3.0)" тому пользователю, под которым выполняется
обновление конфигурации (Администрирование - Пользователи);
- обновите конфигурацию (Конфигурация - Поддержка - Обновить конфигурацию);
- переключатель нужно оставить в положении "Поиск доступных обновлений (рекомендуется)" и нажать "Далее";
- в следующем окне нужно еще раз нажать кнопку "Далее";
- выберите версию конфигурации редакции 3.0 и нажмите "Готово";
- если в конфигурации "Бухгалтерия предприятия" ред. 2.0 были введены пользователи,
то после перехода на "Бухгалтерию предприятия" ред. 3.0 для всех пользователей
нужно будет заново установить права на доступ к информационной базе.

В редакции 3.0 изменился механизм настройки прав пользователей.
После обновления необходимо назначить всем пользователям профили доступа.
Для назначения профилей выполните следующие действия:
- откройте обновленную информационную базу редакции 3.0 пользователем
с административными правами
- откройте список пользователей (раздел "Администрирование")
- для каждого из пользователей откройте настройку его прав доступа
("Права доступа" в панели навигации формы пользователя),
установите флажок для выбранного профиля и нажмите "Записать".

Способ нумерации документов в редакции 3.0 изменен по сравнению с редакцией 2.0.
Для правильной нумерации документов необходимо изменить номер первого
создаваемого документа каждого вида так, чтобы он продолжал нумерацию из старой версии.
При этом номера документов, перенесенных из редакции 2.0,
в печатных формах будут отображаться правильно.
Например, последний номер документа «Реализация товаров и услуг» был 00000000131.
После обновления на редакцию 3.0 первый введенный документ будет иметь номер 0000-000001.
Чтобы сохранить правильную нумерацию, необходимо в этом документе изменить номер на 0000-000132.
В дальнейшем всем введенным документам «Реализация товаров, услуг» будет присваиваться правильный номер.

Важная информация
-----------------------------------------------------------------------
Текущая версия конфигурации "Бухгалтерия предприятия" предназначена
для использования с версией системы 1С:Предприятие 8.3 не ниже 8.3.12.1685.

Рекомендуется использовать версию 1С:Предприятие 8.3 не ниже 8.3.12.1790.


Для использования налоговых деклараций со штрих-кодами необходимо,
чтобы в операционной системе был установлен шрифт EanGnivc.

Файл шрифта EANG000.ttf после установки конфигурации размещается
в каталоге, куда был установлен шаблон информационной базы.

Для установки шрифта выполните следующие действия:
- откройте Панель управления (Control Panel) операционной
  системы, для этого нажмите кнопку "Пуск", выберите команды
  "Настройка" (Settings) и "Панель  управления" (Control Panel);
- в Панели управления дважды щелкните значок "Шрифты" (Fonts);
- в меню "Файл" (File) выберите команду "Установить шрифт"
  (Install New Font);
- в поле со списком "Диски" (Drives) выберите нужный диск;
- в поле "Папки" (Folders) откройте каталог, в котором находится
  файл EANG000.ttf;
- в списке "Список шрифтов" (List of fonts) выберите строку
  "EanGnivc (True Type)" и нажмите кнопку OK.

Внимание! Шрифт устанавливается в системе только один раз,
повторную установку выполнять не нужно.
   alexdomovoi
 
11 - 07.01.19 - 01:26
у меня нет там пользователей заведенных, под одним все работает, платформу обновил до последней...
   Winnie Buh
 
12 - 07.01.19 - 10:32
поточнее:
какой точно релиз 2.0 и 3.0 ?
обновляемая база типовая на поддержке или были доработки?
каким образом обновление производится, через штатное "Поддержка" > "Обновить конфигурацию" или через "Сравнить, объединить.."?
   Winnie Buh
 
13 - 07.01.19 - 10:36
(11) у этого одного пользователя в 2.0 перед началом обновления была добавлена роль "Администратор системы (для перехода на ред. 3.0)" ?
   alexdomovoi
 
14 - 08.01.19 - 07:43
(12) c 2.0.66.67 на 3.0.67.54, как то так, БП (Базовая)
   alexdomovoi
 
15 - 08.01.19 - 07:43
(13) там нет такой возможности так как нет ни одного пользователя в списке
   mastodont
 
16 - 08.01.19 - 08:33
(7) смотри отладчиком что он там пытается записать и почему ошибка.
Даты запрета изменения не стоят?
   МимохожийОднако
 
17 - 08.01.19 - 08:49
(15) Добавь пользователя с административными правами перед обновлением. Дай права на переход на новую версию.
   alexdomovoi
 
18 - 08.01.19 - 21:16
(17) да все сделал ошибка не ушла:

{ОбщийМодуль.ЗарплатаКадрыОбновлениеСПредыдущейРедакции.Модуль(2426)}: Ошибка при вызове метода контекста (Записать)
        НаборЗаписей.Записать();
по причине:
Не удалось записать: "Лицевые счета сотрудников по зарплатным проектам"!
   hhhh
 
19 - 08.01.19 - 21:29
(18) ну удалите все эти лицевые счета. Потом подгрузите.
   kennetmccormick
 
20 - 08.01.19 - 21:44
не уникальные записи может попадаются?
   mdao
 
21 - 11.03.19 - 11:17
(19)та же проблема. Как удалить регистр ЛС в Конфигураторе?
   aridscrut
 
22 - 19.03.19 - 16:06
Крч, вот вам экскурс, чтоб обновление не крашилось с ошибкой:
1. После обновления конфигурации ДО ЗАПУСКА ПОЛЬЗОВАТЕЛЬСКОГО РЕЖИМА снимаем замок с общего модуля "ЗарплатаКадрыОбновлениеСПредыдущейРедакции". Делается это через Конфигурация - Поддержка - Настройка поддержки, там находим этот модуль и ставим ему "Редактируется с сохранением поддержки"
2. Открываем в конфигураторе вышеуказанный модуль, находим в нем процедуру "ЛицевыеСчетаСотрудниковКонвертация(СоответствиеКонвертированныхОбъектов)"
3. Заменяем её(можно закомментировать вашу и вставить мою) на:

Процедура ЛицевыеСчетаСотрудниковКонвертация(СоответствиеКонвертированныхОбъектов)
    Запрос = Новый Запрос("ВЫБРАТЬ РАЗЛИЧНЫЕ
                          |    ЛицевыеСчетаСотрудников.Организация
                          |ИЗ
                          |    РегистрСведений.ЛицевыеСчетаСотрудниковПоЗарплатнымПроектам КАК ЛицевыеСчетаСотрудников");
                          
    Если Запрос.Выполнить().Пустой() Тогда 
        
        Запрос = Новый Запрос;
        Запрос.Текст = 
        "ВЫБРАТЬ
        |    УдалитьЛицевыеСчетаРаботниковОрганизации.ФизЛицо,
        |    УдалитьЛицевыеСчетаРаботниковОрганизации.Организация КАК Организация,
        |    УдалитьЛицевыеСчетаРаботниковОрганизации.Банк КАК Банк,
        |    УдалитьЛицевыеСчетаРаботниковОрганизации.НомерЛицевогоСчета,
        |    УдалитьЛицевыеСчетаРаботниковОрганизации.Регистратор.Дата КАК Период
        |ИЗ
        |    РегистрСведений.УдалитьЛицевыеСчетаРаботниковОрганизации КАК УдалитьЛицевыеСчетаРаботниковОрганизации
        |
        |УПОРЯДОЧИТЬ ПО
        |    Организация,
        |    Банк";
        
        Выборка = Запрос.Выполнить().Выбрать();
        
    //НаборЗаписей = РегистрыСведений.ЛицевыеСчетаСотрудниковПоЗарплатнымПроектам.СоздатьНаборЗаписей();

        
    Пока Выборка.СледующийПоЗначениюПоля("Организация") Цикл
Пока Выборка.СледующийПоЗначениюПоля("Банк") Цикл  
                
    ЗарплатныйПроект = ЗарплатныйПроектПоОрганизацииИБанку(
                                    Выборка.Организация,
                                    Выборка.Банк);
            
    Если НЕ ЗначениеЗаполнено(ЗарплатныйПроект) Тогда
    ЗарплатныйПроект = НовыйЗарплатныйПроектПоОрганизацииИБанку(                        Выборка.Организация, Выборка.Банк);
    КонецЕсли;

    Пока Выборка.Следующий() Цикл
НаборЗаписей = РегистрыСведений.ЛицевыеСчетаСотрудниковПоЗарплатнымПроектам.СоздатьНаборЗаписей();
                    НаборЗаписей.Отбор.ФизическоеЛицо.Установить(Выборка.ФизЛицо);
                    НаборЗаписей.Отбор.ЗарплатныйПроект.Установить(ЗарплатныйПроект);
    Запись = НаборЗаписей.Добавить();
    Запись.ДатаОткрытияЛицевогоСчета = Выборка.Период;
    Запись.Организация               = Выборка.Организация;
    Запись.ФизическоеЛицо            = Выборка.ФизЛицо;
    Запись.НомерЛицевогоСчета        = Выборка.НомерЛицевогоСчета;
    Запись.ЗарплатныйПроект          = ЗарплатныйПроект;
    Попытка
    НаборЗаписей.Записать();
    Исключение
ЗаписьЖурналаРегистрации("Запись лицевого счета",УровеньЖурналаРегистрации.Ошибка,Метаданные.РегистрыСведений.ЛицевыеСчетаСотрудниковПоЗарплатнымПроектам,Строка(Выборка.ФизЛицо),Строка(Выборка.НомерЛицевогоСчета));
КонецПопытки;
КонецЦикла;    
КонецЦикла;    
КонецЦикла;
//    НаборЗаписей.Записать();

        
КонецЕсли;    
    
Справочники.ЗарплатныеПроекты.ЗаполнитьБанкПоКлассификатору();    
КонецПроцедуры


Извиняюсь, я тут первый раз вещаю, процедура может криво вставиться, ибо хз, как тут оформления для кода сделать


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.