Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Получить картинку из ХранилищаЗначений и вывести в СКД, в проц. -"ПриКомпоновкеРезультата"

Получить картинку из ХранилищаЗначений и вывести в СКД, в проц. -"ПриКомпоновкеРезультата"
Я
   SkillUp
 
09.11.18 - 12:04
В отчете -"ПрайсЛист", в процедуру "ПриКомпоновкеРезультата", пишу код чтоб вывести картинку из хранилища.

Последовательно, прохожу по всем ячейкам табличного документа и вывожу вместо ХранилицеЗначения соответствующую картинку.При выводе отчета, выводит пустые картинки... Благодарность за подсказку...

Для ТекущаяСтрока = 1 По ДокументРезультат.ВысотаТаблицы Цикл

        Для ТекущаяКолонка = 1 По ДокументРезультат.ШиринаТаблицы Цикл

            ТекущаяОбласть = ДокументРезультат.Область(ТекущаяСтрока, ТекущаяКолонка);
            ТекущаяРасшифровка = ТекущаяОбласть.Расшифровка;

            Если ТипЗнч(ТекущаяРасшифровка) = Тип("ИдентификаторРасшифровкиКомпоновкиДанных") Тогда

                ПоляРасшифровки = ДанныеРасшифровки.Элементы.Получить(ТекущаяРасшифровка).ПолучитьПоля();
                ПолеКартинки = ПоляРасшифровки.Найти("Картинка");

                Если ТипЗнч(ПолеКартинки) = Тип("ЗначениеПоляРасшифровкиКомпоновкиДанных") Тогда

                    ФайлКартинки = ПолеКартинки.Значение;

                    Если ТипЗнч(ФайлКартинки) = Тип("ХранилищеЗначения") Тогда

                        КартинкаВДокументе = ДокументРезультат.Рисунки.Добавить(ТипРисункаТабличногоДокумента.Картинка);
                        КартинкаВДокументе.Картинка = Новый Картинка(ФайлКартинки.Получить());
                        КартинкаВДокументе.РазмерКартинки = РазмерКартинки.Пропорционально;
                        КартинкаВДокументе.Расположить(ТекущаяОбласть);

                    КонецЕсли;

                КонецЕсли;

            КонецЕсли;

        КонецЦикла;

    КонецЦикла;
 
 
   SkillUp
 
1 - 09.11.18 - 12:07
Скорей всего, где-то тут не правильно:

 ФайлКартинки = ПолеКартинки.Значение;

                    Если ТипЗнч(ФайлКартинки) = Тип("ХранилищеЗначения") Тогда

                        КартинкаВДокументе = ДокументРезультат.Рисунки.Добавить(ТипРисункаТабличногоДокумента.Картинка);
                        КартинкаВДокументе.Картинка = Новый Картинка(ФайлКартинки.Получить());
                        КартинкаВДокументе.РазмерКартинки = РазмерКартинки.Пропорционально;
                        КартинкаВДокументе.Расположить(ТекущаяОбласть);

                    КонецЕсли;
   Вафель
 
2 - 09.11.18 - 12:08
а в отладчике какой тип у ФайлКартинки ?
   Вафель
 
3 - 09.11.18 - 12:09
а картинки точно не в томах хранятся?
   SkillUp
 
4 - 09.11.18 - 12:09
(2) ХранилищеЗнач
   SkillUp
 
5 - 09.11.18 - 12:13
(3) не, не в томах.
   ad82117
 
6 - 22.11.18 - 12:45
(5) получилось?
сам бьюсь
никак картинка не выводится.
КартинкаВДокументе.Картинка = Новый Картинка(ФайлКартинки.ФайлХранилеще.Получить());
   Aggressor
 
7 - 22.11.18 - 13:49
Есть такой вариант получения картинки

&НаКлиенте
Процедура ТоварыПриАктивизацииСтроки(Элемент)
     ЭтаФорма.Фото = ПолучитьНавигационнуюСсылку(ЭтаФорма.Элементы.Товары.ТекущиеДанные.Номенклатура.ОсновноеИзображение, "Хранилище");
КонецПроцедуры
   ad82117
 
8 - 22.11.18 - 13:55
(7) у меня был рабочий вариант через навигационную ссылку, где принцип такой же по ячейкам ползать и заполнять, думал проще сделать

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует