Вход | Регистрация
 

Ошибка Операции введенные вручную БП 3.0

Ошибка Операции введенные вручную БП 3.0
Я
   dim3740
 
07.11.18 - 09:59
Операции, введенные вручную ... пару сек думает и вываливается с ошибкой
"{ОбщийМодуль.ОбщегоНазначенияБП.Модуль(1047)}: Значение не является значением объектного типа (Элементы)
    Для каждого ЭлементНастроек Из Настройки.Элементы Цикл"

Релиз обновил последний, окно Конфигуратора еще открыто. Платф 8.3.13.1513
 
 
   dim3740
 
1 - 07.11.18 - 10:02
Сюда ведет: Как победить?

// Заменяет отбор, установленный пользователем в сохраненной настройке списка, на отбор, установленный программно при создании формы списка.

// Вызывается при восстановлении пользовательских настроек динамического списка
// из обработчика списка ПередЗагрузкойПользовательскихНастроекНаСервере.

//
// Параметры:

//  Список      - ДинамическийСписок - Динамический список, для которого устанавливается отбор.
//  Настройки   - ПользовательскиеНастройкиКомпоновкиДанных - Восстанавливаемые настройки списка.

//  ИмяОтбора   - Строка - Имя элемента отбора.
//

Процедура ВосстановитьОтборСписка(Список, Настройки, ИмяОтбора) Экспорт

    Отборы = ОбщегоНазначенияКлиентСервер.НайтиЭлементыИГруппыОтбора(
        Список.КомпоновщикНастроек.Настройки.Отбор, ИмяОтбора);
    
    Если Отборы.Количество() = 0 Тогда
        Возврат;
    КонецЕсли;
    
    ЭлементОтбора = Отборы[0];
    ИдентификаторНастройки = ЭлементОтбора.ИдентификаторПользовательскойНастройки;
    
    Для каждого ЭлементНастроек Из Настройки.Элементы Цикл
        Если ТипЗнч(ЭлементНастроек) = Тип("ЭлементОтбораКомпоновкиДанных") 
            И ЭлементНастроек.ИдентификаторПользовательскойНастройки = ИдентификаторНастройки Тогда
            ЭлементНастроек.ПравоеЗначение = ЭлементОтбора.ПравоеЗначение;
            ЭлементНастроек.Использование  = ЭлементОтбора.Использование;
            Прервать;
        КонецЕсли;
    КонецЦикла;

КонецПроцедуры
   d4rkmesa
 
2 - 07.11.18 - 10:03
(0) Эм. Я бы еще не рисковал на 8.3.13 работать.
   ZDenis
 
3 - 07.11.18 - 10:07
(0) Должна помочь очистка настроек пользователя
   dim3740
 
4 - 07.11.18 - 15:11
(3) Гугл выдал ссылку на внешнюю обработку по сбросу настроек, скачал 1 старт-мани... Она тоже вываливается с ошибкой((((

Есть еще базы на этой же платформе на ноуте - они не выдают ошибки при входе в журнал "Операции..."
   ZDenis
 
5 - 07.11.18 - 15:35
(4) в БП есть встроенная обработка очистки настроек - Администрирование - Настройка пользователей и прав - Персональные настройки пользоватей
   dim3740
 
6 - 07.11.18 - 15:40
(5) Спасибо за ваш труд и помощь! Все помогло))))

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует