Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

На Эксель = ПолучитьCOMОбъект(ИмяФайла); отладка завершается и дальше не идет.

На Эксель = ПолучитьCOMОбъект(ИмяФайла); отладка завершается и дальше не идет.
Я
   SkillUp
 
26.10.18 - 11:51
Функция, которая возвращает ТЗ (считывая эксель);

На Эксель = ПолучитьCOMОбъект(ИмяФайла); отладка завершается и дальше не идет. Не могу понять  из-за чего.

Код функции:

Функция ПолучитьНужнуюТЗ (ИмяФайла);

    Скрипт = Новый COMОбъект("MSScriptControl.ScriptControl");
    Скрипт.language = "javascript";
    
    ВремяНачала = Формат(Скрипт.eval("new Date().getTime()"),"ЧГ=0");
    Эксель = ПолучитьCOMОбъект(ИмяФайла);
    ЛистЭксель = Эксель.WorkSheets(1);
    ВсегоСтрок = ЛистЭксель.Cells.SpecialCells(11).Row;
    ВсегоКолонок = ЛистЭксель.Cells.SpecialCells(11).Column;
    
    Сообщить("Колонок: "+ Строка(ВсегоКолонок) + " Строк: "+ Строка(ВсегоСтрок));
    
    ТЗ = Новый ТаблицаЗначений;
    Для Счетчик = 1 По ВсегоКолонок Цикл
        ТЗ.Колонки.Добавить("Колонка"+Счетчик);
    КонецЦикла;
    
    Для Счетчик = 1 По ВсегоСтрок Цикл
        НоваяСтрока = ТЗ.Добавить();
    КонецЦикла;
    
    Область = ЛистЭксель.Range(ЛистЭксель.Cells(1,1), ЛистЭксель.Cells(ВсегоСтрок,ВсегоКолонок));
    Данные = Область.Value.Выгрузить();
    
    Для Счетчик = 0 По ВсегоКолонок-1 Цикл
        ТЗ.ЗагрузитьКолонку(Данные[Счетчик], Счетчик);
    КонецЦикла;
    ЛистЭксель = Неопределено;
    Эксель = Неопределено;
    
    ВремяОкончания = Формат(Скрипт.eval("new Date().getTime()"),"ЧГ=0");
    //ОчиститьСообщения();
    Сообщить("Выполнение скрипта заняло: " + Строка(ВремяОкончания - ВремяНачала) + " мсек. " + Символы.ПС +
    "Обработано строк: " + Строка(ВсегоКолонок) + " колонок: " + Строка(ВсегоСтрок) + " итого ячеек; " + Строка(ВсегоКолонок * ВсегоСтрок));
    
    Возврат ТЗ;
    
КонецФункции
 
 
   asady
 
1 - 26.10.18 - 11:52
(0) в диспетчере задач процесс экселя появляется?
   SkillUp
 
2 - 26.10.18 - 11:55
(1) Нет.
   SkillUp
 
3 - 26.10.18 - 11:55
(1) ОЙЙЙ, да есть аж 9 шт.
   SkillUp
 
4 - 26.10.18 - 11:55
(1) Офигеть!
   shadow_sw
 
5 - 26.10.18 - 12:00
Ex = новый COMОбъект("Excel.Application");

так попробуй
   asady
 
6 - 26.10.18 - 12:07
(5) не поможет

там наверное модальное окошко эксель выбросил и ждет
   SkillUp
 
7 - 26.10.18 - 12:10
(6) ИМЕННО ОНО! Спасибо!
   shadow_sw
 
8 - 26.10.18 - 12:18
Эксель.Visible = 1;    

вот еще

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует