Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Пытаюсь выгрузить из Эксель (300 000 строк) в ТЗ, не пойму почему в ТЗ нет данных... код:

Пытаюсь выгрузить из Эксель (300 000 строк) в ТЗ, не пойму почему в ТЗ нет данных... код:
Я
   SkillUp
 
17.10.18 - 14:22
Мой код:
Эксель = ПолучитьCOMОбъект(ПолеВвода1);
    ЛистЭксель = Эксель.WorkSheets(1);
    ВсегоСтрок = ЛистЭксель.Cells.SpecialCells(11).Row;
    ВсегоКолонок = ЛистЭксель.Cells.SpecialCells(11).Column;
    
    Сообщить("Колонок: "+ Строка(ВсегоКолонок) + " Строк: "+ Строка(ВсегоСтрок));
    
    ТЗ = Новый ТаблицаЗначений;
    Для Счетчик = 1 По ВсегоКолонок Цикл
        ТЗ.Колонки.Добавить("Колонка"+Счетчик);
    КонецЦикла;
    
    Для Счетчик = 1 По ВсегоСтрок Цикл
        НоваяСтрока = ТЗ.Добавить();
    КонецЦикла;
    
    Область = ЛистЭксель.Range(ЛистЭксель.Cells(1,1), ЛистЭксель.Cells(ВсегоСтрок,ВсегоКолонок));
    Данные = Область.Value.Выгрузить();
    
    Для Счетчик = 0 По ВсегоКолонок-1 Цикл
        ТЗ.ЗагрузитьКолонку(Данные[Счетчик], Счетчик);
    КонецЦикла;
    ЛистЭксель = Неопределено;
    Эксель = Неопределено;
    
    ОчиститьСообщения();
    
    Возврат ТЗ;
 
 
   N-S-B
 
1 - 17.10.18 - 14:26
Скорее всего данные просто подгружаются. Проверь что в ТЗ.Количество()
   segn
 
2 - 17.10.18 - 14:27
(0) Данные = Область.Value.Выгрузить(); - разве это массив?
   RomanYS
 
3 - 17.10.18 - 14:28
Посмотреть отладчиком содержание Данные и Данные[Счетчик]
   RomanYS
 
4 - 17.10.18 - 14:31
ТД = Новый ТабличныйДокумент;
    ТД.Прочитать(ИмяФайла, СпособЧтенияЗначенийТабличногоДокумента.Текст)// эксель файл

    
    Построитель = Новый ПостроительЗапроса;
    Построитель.ИсточникДанных = Новый ОписаниеИсточникаДанных(ТД.Область());
    
    ТЗ = Построитель.Результат.Выгрузить();
   13_Mult
 
5 - 17.10.18 - 14:35
(0) Прочитай внимательнее http://catalog.mista.ru/public/20090/
   МихаилМ
 
6 - 17.10.18 - 14:36
getrows()
   SkillUp
 
7 - 17.10.18 - 14:41
(3) (4) (5)  Разобрался. Спасибо вам...
   SkillUp
 
8 - 17.10.18 - 14:42
(6) Отож ...
   SkillUp
 
9 - 17.10.18 - 17:02
(1) Да, ТЗ.Количество() показывает свыше 300 000 тыс. строк, но что это меняет, ТЗ пустая...

Список тем форума
Рекламное место пустует  Рекламное место пустует
Здесь можно задать вопрос "Как сделать?" и получить кучу ответов, что тебе это делать не надо. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует